Closed

Windows XP client with SP2 cannot connect to SQL over 1433

Archived from groups: microsoft.public.sqlserver.connect,microsoft.public.windowsnt.domain (More info?)

I have a client with a machine that refuses to connect with any SQL Server
over 1433. It is as if the port is being filtered. Windows firewall is OFF
(and I've tried various attempts to change the firewall with no effect, add
the ports explicitly etc.) Other machines on the same network have no
trouble seeing the same SQL Servers, and the affected client can freely ping
the servers it is trying to connect to.

Is there something else that might be blocking 1433? Policies, etc.?

This is pretty much a brand new machine with Windows XP2 loaded on it. I've
been supporting several hundred replication subscribers in the field for
years and have never seen anything this stubborn.

Thanks,

rb
11 answers Last reply
More about windows client connect 1433
  1. Archived from groups: microsoft.public.windowsnt.domain,microsoft.public.sqlserver.connect (More info?)

    I've been having same issue but just found some more info a few minutes ago:
    I found some details:
    On the server open a cmd prompt and run svrnetcn
    Check all the SQL instances and the protocols they are using (if nothing is
    shown under enabled protocols you'll have to add something)

    On the client XP station open cmd prompt and run cliconfg - make sure the
    enabled protocols match thos listed (or set) on the server using the process
    above -

    No idea if that resolves the issue yet as I'm just going through it myself,
    but hope its of some use !!

    "R Baker" wrote:

    > I have a client with a machine that refuses to connect with any SQL Server
    > over 1433. It is as if the port is being filtered. Windows firewall is OFF
    > (and I've tried various attempts to change the firewall with no effect, add
    > the ports explicitly etc.) Other machines on the same network have no
    > trouble seeing the same SQL Servers, and the affected client can freely ping
    > the servers it is trying to connect to.
    >
    > Is there something else that might be blocking 1433? Policies, etc.?
    >
    > This is pretty much a brand new machine with Windows XP2 loaded on it. I've
    > been supporting several hundred replication subscribers in the field for
    > years and have never seen anything this stubborn.
    >
    > Thanks,
    >
    > rb
    >
    >
    >
  2. Archived from groups: microsoft.public.sqlserver.connect,microsoft.public.windowsnt.domain (More info?)

    Can you post your error log, that will tell us if it is trying to listen on
    tcpip port 1433.


    --
    Vikram Vamshi
    Database Engineer
    Eclipsys Corporation
    "R Baker" <nospamx@nospamx.com> wrote in message
    news:%23wXhPDbqFHA.2968@TK2MSFTNGP10.phx.gbl...
    >I have a client with a machine that refuses to connect with any SQL Server
    >over 1433. It is as if the port is being filtered. Windows firewall is OFF
    >(and I've tried various attempts to change the firewall with no effect, add
    >the ports explicitly etc.) Other machines on the same network have no
    >trouble seeing the same SQL Servers, and the affected client can freely
    >ping the servers it is trying to connect to.
    >
    > Is there something else that might be blocking 1433? Policies, etc.?
    >
    > This is pretty much a brand new machine with Windows XP2 loaded on it.
    > I've been supporting several hundred replication subscribers in the field
    > for years and have never seen anything this stubborn.
    >
    > Thanks,
    >
    > rb
    >
  3. Archived from groups: microsoft.public.windowsnt.domain,microsoft.public.sqlserver.connect (More info?)

    Hi,

    I'm having the same problem running on my stand-alone laptop...I can't
    telnet into port 1433 either...
    running "netstat -an" with query analyzer and enterprise manager up and
    running don't show the port in
    use. I can only assume that they use the named pipes to connect to the DB
    engine. Ran the two commands
    suggested by RB: In the Server Network util, Named Pipes and TCP/IP are on.
    The default port for TCP/IP
    is 1433. For the Client Network util, in order, I have TCP/IP, then Named
    Pipes. Again the default port
    is 1433. Below is the error log and EventLog entries created from my most
    recent startup. I see no
    mention of it trying to listen on any TCP/IP port. There's also an error
    regarding:
    "TransactionDispenserInterface: Result Code = 0x8004d01b".

    I'm about to install Service Pack 3. If I get the same results, I'll move on
    to Service Pack 4. Would
    appreciate any feedback in resolving this or suggestions to as to where to
    look next.

    Cheers,

    Quest
    General Dynamics


    PS: Here's a copy of my latest SQL error log:
    ------------------------------------------------------------------------------------------------------------------------------
    2005-09-01 04:24:27.62 server Microsoft SQL Server 2000 - 8.00.194
    (Intel X86)
    Aug 6 2000 00:57:48
    Copyright (c) 1988-2000 Microsoft Corporation
    Developer Edition on Windows NT 5.1 (Build 2600: Service Pack 2)

    2005-09-01 04:24:27.68 server Copyright (C) 1988-2000 Microsoft
    Corporation.
    2005-09-01 04:24:27.68 server All rights reserved.
    2005-09-01 04:24:27.68 server Server Process ID is 1720.
    2005-09-01 04:24:27.68 server Logging SQL Server messages in file
    'C:\Program Files\Microsoft SQL Server\MSSQL\log\ERRORLOG'.
    2005-09-01 04:24:27.82 server SQL Server is starting at priority class
    'normal'(2 CPUs detected).
    2005-09-01 04:24:28.18 server SQL Server configured for thread mode
    processing.
    2005-09-01 04:24:28.21 server Using dynamic lock allocation. [2500] Lock
    Blocks, [5000] Lock Owner Blocks.
    2005-09-01 04:24:28.28 server Attempting to initialize Distributed
    Transaction Coordinator.
    2005-09-01 04:24:28.50 server Failed to obtain
    TransactionDispenserInterface: Result Code = 0x8004d01b
    2005-09-01 04:24:28.54 spid4 Starting up database 'master'.
    2005-09-01 04:24:29.17 server Using 'SSNETLIB.DLL' version '8.0.194'.
    2005-09-01 04:24:29.17 spid5 Starting up database 'model'.
    2005-09-01 04:24:29.28 spid4 Server name is 'GEMSTONE'.
    2005-09-01 04:24:29.28 spid8 Starting up database 'msdb'.
    2005-09-01 04:24:29.28 spid9 Starting up database 'pubs'.
    2005-09-01 04:24:29.28 spid10 Starting up database 'Northwind'.
    2005-09-01 04:24:29.28 spid11 Starting up database 'LJ'.
    2005-09-01 04:24:30.26 spid5 Clearing tempdb database.
    2005-09-01 04:24:30.35 server SQL server listening on Shared Memory,
    Named Pipes.
    2005-09-01 04:24:30.37 server SQL Server is ready for client connections
    2005-09-01 04:24:34.28 spid5 Starting up database 'tempdb'.
    2005-09-01 04:24:35.23 spid4 Recovery complete.

    -----------------------------------------------------------------------------------------------------------------------------


    Type Date Time Source Category Event User Computer
    Information 9/1/2005 4:24:35 AM MSSQLSERVER (2) 17055 N/A GEMSTONE
    17052 :
    Recovery complete.

    Information 9/1/2005 4:24:31 AM H+BEDV AntiVir AntiVir 4096 SYSTEM GEMSTONE
    Information 9/1/2005 4:24:30 AM MSSQLSERVER (2) 17055 N/A GEMSTONE
    17126 :
    SQL Server is ready for client connections

    Information 9/1/2005 4:24:30 AM MSSQLSERVER (2) 17055 N/A GEMSTONE
    19013 :
    SQL server listening on Shared Memory, Named Pipes.


    Warning 9/1/2005 4:24:30 AM MSSQLSERVER (8) 19011 N/A GEMSTONE
    SuperSocket info: (SpnRegister) : Error 1355.


    Information 9/1/2005 4:24:29 AM MSSQLSERVER/MSDE None 5400 N/A GEMSTONE
    Information 9/1/2005 4:24:29 AM MSSQLSERVER/MSDE None 5400 N/A GEMSTONE
    Information 9/1/2005 4:24:29 AM MSSQLSERVER (2) 17055 N/A GEMSTONE
    17834 :
    Using 'SSNETLIB.DLL' version '8.0.194'.

    Information 9/1/2005 4:24:28 AM MSSQLSERVER/MSDE None 5400 N/A GEMSTONE
    Information 9/1/2005 4:24:28 AM MSSQLSERVER (2) 17055 N/A GEMSTONE
    Information 9/1/2005 4:24:28 AM MSSQLSERVER (2) 17055 N/A GEMSTONE
    Information 9/1/2005 4:24:27 AM MSSQLSERVER (2) 17055 N/A GEMSTONE
    Information 9/1/2005 4:24:27 AM MSSQLSERVER (2) 17055 N/A GEMSTONE
    Information 9/1/2005 4:24:27 AM MSSQLSERVER (2) 17055 N/A GEMSTONE
    Information 9/1/2005 4:24:27 AM SecurityCenter None 1800 N/A GEMSTONE
  4. Archived from groups: microsoft.public.windowsnt.domain,microsoft.public.sqlserver.connect (More info?)

    Yes, your server is not listening on tcp-ip, you need to run server network
    utility and enable tcp-ip.

    --
    Matt Neerincx [MSFT]

    This posting is provided "AS IS", with no warranties, and confers no rights.

    Please do not send email directly to this alias. This alias is for newsgroup
    purposes only.

    "Quest" <Quest@discussions.microsoft.com> wrote in message
    news:38E9660E-B372-4BAA-A1B5-243D08EBC0CC@microsoft.com...
    > Hi,
    >
    > I'm having the same problem running on my stand-alone laptop...I can't
    > telnet into port 1433 either...
    > running "netstat -an" with query analyzer and enterprise manager up and
    > running don't show the port in
    > use. I can only assume that they use the named pipes to connect to the DB
    > engine. Ran the two commands
    > suggested by RB: In the Server Network util, Named Pipes and TCP/IP are
    > on.
    > The default port for TCP/IP
    > is 1433. For the Client Network util, in order, I have TCP/IP, then Named
    > Pipes. Again the default port
    > is 1433. Below is the error log and EventLog entries created from my most
    > recent startup. I see no
    > mention of it trying to listen on any TCP/IP port. There's also an error
    > regarding:
    > "TransactionDispenserInterface: Result Code = 0x8004d01b".
    >
    > I'm about to install Service Pack 3. If I get the same results, I'll move
    > on
    > to Service Pack 4. Would
    > appreciate any feedback in resolving this or suggestions to as to where to
    > look next.
    >
    > Cheers,
    >
    > Quest
    > General Dynamics
    >
    >
    >
    > PS: Here's a copy of my latest SQL error log:
    > ------------------------------------------------------------------------------------------------------------------------------
    > 2005-09-01 04:24:27.62 server Microsoft SQL Server 2000 - 8.00.194
    > (Intel X86)
    > Aug 6 2000 00:57:48
    > Copyright (c) 1988-2000 Microsoft Corporation
    > Developer Edition on Windows NT 5.1 (Build 2600: Service Pack 2)
    >
    > 2005-09-01 04:24:27.68 server Copyright (C) 1988-2000 Microsoft
    > Corporation.
    > 2005-09-01 04:24:27.68 server All rights reserved.
    > 2005-09-01 04:24:27.68 server Server Process ID is 1720.
    > 2005-09-01 04:24:27.68 server Logging SQL Server messages in file
    > 'C:\Program Files\Microsoft SQL Server\MSSQL\log\ERRORLOG'.
    > 2005-09-01 04:24:27.82 server SQL Server is starting at priority class
    > 'normal'(2 CPUs detected).
    > 2005-09-01 04:24:28.18 server SQL Server configured for thread mode
    > processing.
    > 2005-09-01 04:24:28.21 server Using dynamic lock allocation. [2500]
    > Lock
    > Blocks, [5000] Lock Owner Blocks.
    > 2005-09-01 04:24:28.28 server Attempting to initialize Distributed
    > Transaction Coordinator.
    > 2005-09-01 04:24:28.50 server Failed to obtain
    > TransactionDispenserInterface: Result Code = 0x8004d01b
    > 2005-09-01 04:24:28.54 spid4 Starting up database 'master'.
    > 2005-09-01 04:24:29.17 server Using 'SSNETLIB.DLL' version '8.0.194'.
    > 2005-09-01 04:24:29.17 spid5 Starting up database 'model'.
    > 2005-09-01 04:24:29.28 spid4 Server name is 'GEMSTONE'.
    > 2005-09-01 04:24:29.28 spid8 Starting up database 'msdb'.
    > 2005-09-01 04:24:29.28 spid9 Starting up database 'pubs'.
    > 2005-09-01 04:24:29.28 spid10 Starting up database 'Northwind'.
    > 2005-09-01 04:24:29.28 spid11 Starting up database 'LJ'.
    > 2005-09-01 04:24:30.26 spid5 Clearing tempdb database.
    > 2005-09-01 04:24:30.35 server SQL server listening on Shared Memory,
    > Named Pipes.
    > 2005-09-01 04:24:30.37 server SQL Server is ready for client
    > connections
    > 2005-09-01 04:24:34.28 spid5 Starting up database 'tempdb'.
    > 2005-09-01 04:24:35.23 spid4 Recovery complete.
    >
    > -----------------------------------------------------------------------------------------------------------------------------
    >
    >
    > Type Date Time Source Category Event User Computer
    > Information 9/1/2005 4:24:35 AM MSSQLSERVER (2) 17055 N/A GEMSTONE
    > 17052 :
    > Recovery complete.
    >
    > Information 9/1/2005 4:24:31 AM H+BEDV AntiVir AntiVir 4096 SYSTEM
    > GEMSTONE
    > Information 9/1/2005 4:24:30 AM MSSQLSERVER (2) 17055 N/A GEMSTONE
    > 17126 :
    > SQL Server is ready for client connections
    >
    > Information 9/1/2005 4:24:30 AM MSSQLSERVER (2) 17055 N/A GEMSTONE
    > 19013 :
    > SQL server listening on Shared Memory, Named Pipes.
    >
    >
    > Warning 9/1/2005 4:24:30 AM MSSQLSERVER (8) 19011 N/A GEMSTONE
    > SuperSocket info: (SpnRegister) : Error 1355.
    >
    >
    > Information 9/1/2005 4:24:29 AM MSSQLSERVER/MSDE None 5400 N/A GEMSTONE
    > Information 9/1/2005 4:24:29 AM MSSQLSERVER/MSDE None 5400 N/A GEMSTONE
    > Information 9/1/2005 4:24:29 AM MSSQLSERVER (2) 17055 N/A GEMSTONE
    > 17834 :
    > Using 'SSNETLIB.DLL' version '8.0.194'.
    >
    > Information 9/1/2005 4:24:28 AM MSSQLSERVER/MSDE None 5400 N/A GEMSTONE
    > Information 9/1/2005 4:24:28 AM MSSQLSERVER (2) 17055 N/A GEMSTONE
    > Information 9/1/2005 4:24:28 AM MSSQLSERVER (2) 17055 N/A GEMSTONE
    > Information 9/1/2005 4:24:27 AM MSSQLSERVER (2) 17055 N/A GEMSTONE
    > Information 9/1/2005 4:24:27 AM MSSQLSERVER (2) 17055 N/A GEMSTONE
    > Information 9/1/2005 4:24:27 AM MSSQLSERVER (2) 17055 N/A GEMSTONE
    > Information 9/1/2005 4:24:27 AM SecurityCenter None 1800 N/A GEMSTONE
    >
    >
    >
    >
    >
  5. Well I installed all of the SP updates up to SP4 and Windows XP still didn't allow my SQL Server 2000 listen on TCP/IP ports. I had to run a security checker, provided by MS called SQLCritUpdPkg_ENU.exe http://www.microsoft.com/downloads/details.aspx?familyid=9552d43b-04eb-4af9-9e24-6cde4d933600&displaylang=en
    for Windows XP to allow SQL Server to open the ports.
  6. i know this thread is super old, but the question's been pissing me off so i figure i should put my answer out there.

    1. hunt down the IPALL interface listed here:
    > sql config manager
    -> sql server network configuration
    -> protocols for <instance name>
    -> tcp/ip
    -> ip addresses
    -> IPALL

    2. change tcp dynamic ports to nothing (not zero)

    3. change tcp port to 1433

    before this i was getting a port range from nmap. after the change was applied, 1433 was open.

    hope this helps.
  7. Hello my dear friends,

    I have subscribed to this magnanimous forum to congratulate Mr BobLablah in a job well done.


    Giving away precious giblets of information like this is priceless.
  8. This is Microsoft article which really helped me to sort out problem
    http://support.microsoft.com/kb/839980

    None of other methods mentioned here were useless
  9. Interesting, thanks!
  10. BobLablah said:
    i know this thread is super old, but the question's been pissing me off so i figure i should put my answer out there.

    1. hunt down the IPALL interface listed here:
    > sql config manager
    -> sql server network configuration
    -> protocols for <instance name>
    -> tcp/ip
    -> ip addresses
    -> IPALL

    2. change tcp dynamic ports to nothing (not zero)

    3. change tcp port to 1433

    before this i was getting a port range from nmap. after the change was applied, 1433 was open.

    hope this helps.


    FINALLY Solved my problem after tons of searching!
    Thank you so much !!!!!!!!!!!!
  11. This topic has been closed by Area51reopened
Ask a new question

Read More

Connection Microsoft Windows XP Windows Product