Sign in with
Sign up | Sign in
Your question

URGENT: D:/ is not a valid win32 application???

Last response: in Systems
Share
November 30, 2005 3:29:38 AM

I've just upgraded my computer with a new mobo, hdd, psu and gfx card, all is well and windows installed smoothly but the problem occurs after windows is installed and I cannot seem to get any CD/DVD to read under XP. It would take a very long time to load, and when it does load up it would either say d:/ is not a valid win32 application or something about an i/o error. I've done a bit of google and looked on all the manufacturer's sites and failed to find any related information. This is very serious as I pretty much can't install anything from my CD/DVDs. I've reinstalled a few times, and each and every time the same problem occurs. My hardware are as follows:

Athlon 64 3200+ Winchester
Abit AN8 Ultra Motherboard
Antec 480w ATX v2.0 PSU
PowerColour Radeon X850XT 256mb
WD Caviar SE 16 250gb Harddisk
2 X 512mb DDR 400 ram
DVD writer is an OEM sony 16X

Hope someone could help me on this, many thanks in advance.
November 30, 2005 9:51:48 AM

Are you sure your cable is correctly connected? The jumpers on the rear of the CD/DVD player are correctly configured?
November 30, 2005 6:18:53 PM

when u go into my computer does it even recognize it?
Related resources
November 30, 2005 8:33:11 PM

Don't know - can't go into his computer... :wink:
November 30, 2005 9:35:33 PM

Quote:
Don't know - can't go into his computer... :wink:


LOL thats good.

Anyway I'd try running Memtest86, or trying other parts (if you have them) until you find out what the problem is.
November 30, 2005 10:25:15 PM

Yeah the drive is in my computer, it just won't load any disks, it'd even burn disks with nero but it just won't read/autorun anything.

I'll give that memtest 86 a try now, and borrowing a spare drive from a friend to see if that would work.
November 30, 2005 10:36:40 PM

Do all your discs fail to autorun or just some? I have many discs that don't autorun and work fine, if only some fail then it could be disc errors. People like to keep discs with the label side down, where a scratch on the bottom is nothing a scratch to the top is fatal. I'd try a different CD/DVD drive first then let Memtest86 run a while.
December 1, 2005 1:10:07 AM

Yes I've tried every single type of cd/dvd I got at home and none work, I've tried with my friend's spare drive and it works, but it's a cdrw so I dunno if it'd matter if I try with a dvd-rw drive and see if that works. It's just very weird as it'd burn disks but refuses to read any. I'll ask my friend to try my drive on his computer later and see how that goes.

I've also had a strange reboot problem which I mentioned in another thread over at the gfx forum. a BSOD shows up with BAD_POOL_HEADER 0x00000019, after a bit of google hunting I'm still not sure of what it could be, but I suspect it's a ram issue, I might have done something to the ram when I took them out of my old mobo and put them into my new one. I'm running with one of the 2 sticks atm and see if it'd crash again.
December 1, 2005 1:23:13 AM

My last comp went through 8 Cd drives in a year (thank god for a warranty) they were all samsung and sony so I hate both companies. I'd take your CD/DVD drive back if a buddies works fine. I recommend a Lite-On brand drive there cheap and never let me down.

EDIT: In my experience Samsung and Sony CD/DVD drives either burn right and not work or work right and not burn.
December 1, 2005 2:36:49 AM

Ha my DVD drive happens to be a sony oem one, I had a lite-on and asus one before, I used both for over a year with no problems. I just didn't expect dvd drives to just die after I installed new components (I didn't even take it out it's bay, just unplugged the power and ide cable).

Something must be wrong with the rams as well, I took one stick out, and I played games and watched movies etc for over 2 hours now without my comp rebooting (fingers crossed)......
December 1, 2005 2:42:29 AM

glad to hear its working for you.
December 1, 2005 9:27:55 PM

While I seem to have fixed the cd drive problem, my system is constantly rebooting from various BSOD. I've been getting BAD_POOL_HEADER, HTTP.SYS, DRIVER_IRQL_NOT_LESS_THAN_OR_EQUAL and all sorts of BSOD with just codes. I've done a lot of reading into these and no solution seems to be able to fix my problem.

Could it be possible it's a fault on the hardware (I suspect mostly new mobo or ram, but it could also be the new hdd or the new gfx card)? I have updated every driver and the bios to the newest possible, SP2 and everything, ran registry mechanic which fixed a bunch of errors, and have NIS 2006 installed and updated.
August 11, 2006 2:51:58 PM

It seems that there are several people on the net that have this problem, and they all seem to have the abit N8 Motherboards. Which means that this is probably hk/windows incompatibility/driver issue. So your CD/DVD drives may not be faulty at all, wait for abit to release new drivers or try the newest nforce drivers.
April 16, 2007 2:20:56 PM

I'm also experiencing this problem, and I'm using an ASRock Mobo so :-(


Also, using a Lite-on burner, contrary to what's said above.. I would buy a Sony or Samsung over a Lite-On any day now, but meh.

This is my first experience with it, and I can't seem to find any info on the Net. I'm nearing the point of just buying another damn dvd writer.


Any help?
April 16, 2007 3:23:50 PM

BAD_POOL_HEADER, HTTP.SYS, DRIVER_IRQL_NOT_LESS_THAN_OR_EQUAL
errors - I got these , turned out it was a generic oem USB card causing the problem , I moved it too another PCI slot and everything went fine :) 
October 4, 2008 4:20:02 PM

a bit late but i had the same problems with autostart. i have abit an8 ultra. cdrom starts work correctly when you use one ide channel. i have cd rom on slave and disk as master on ide 1 channel. when i use ide 2 channel for cd drive it doesn't autostart and got some problems with reading.

February 19, 2009 4:16:08 PM

This is also a bit late but I just got that same message after uninstalling a video game. After much searching for the answer and to no avail, the problem still persisted. That is, until I uninstalled Nero's InCD. If you have Nero try uninstalling it and see if it fixes the problem.
February 19, 2009 4:16:42 PM

This is also a bit late but I just got that same message after uninstalling a video game. After much searching for the answer and to no avail, the problem still persisted. That is, until I uninstalled Nero's InCD. If you have Nero try uninstalling it and see if it fixes the problem.
March 8, 2009 7:19:37 PM

This can happen after a major hardware swap/replacement such as a HDD, Mobo etc. the most common cause is when swapping an existing HDD for a CDROM as the computer is still seeing the newly installed cdrom as a hdd and therefore thinks it should be able to read/write as if it were a hdd once it realizes that it can't then it assumes that there must be a failure in the device and therefore will return on of two messages or both... "D:\\ is not a valid win32 application" or an I/O Device error.
Rarely this can also occur on it's own without changing any hardware. Why this occurs is merely speculation. So I won't bore you with it.

Change the transfer mode for the CD drive in IDE Channel Properties
If the transfer mode for the CD drive was changed or is incorrect, Windows cannot transfer data from the CD to the computer. You can resolve this issue by changing to the correct transfer mode. To change the transfer mode, follow these steps:

1. Click Start, and then click Run.

2. Type devmgmt.msc in the Open box, and then press ENTER.
The Device Manager dialog box will open. (Alternatively: Click Start, Right-click on "My Computer", select Properties. Then click "Hardware" tab and then "Device Manager" button)

3. Expand IDE ATA/ATAPI controllers. A subset will open, listing the different IDE ATA/ATAPI channels for the computer.

4. Right-click the channel where the CD drive is connected, and then click Properties (or just Double-Click the Channel to open the properties). Typically, this channel is "Secondary IDE Channel".

(Warning: Do not change the Primary IDE Channel, Device 0, because this is typically the system disk. Changing this transfer mode setting may cause the computer to operate incorrectly or not at all.)

5. On the Advanced Settings tab, select PIO Only in the Transfer Mode box for the device that represents the CD drive. Typically, this is Device 0. Then, click OK.

6. Test the CD in the CD drive
December 20, 2009 1:32:13 PM

for me it was the jumpers. the default setting on my liteon were incorrect and gave me that same error.
!