Trying to set up FTP server on my NT Server 4.0 box

Archived from groups: microsoft.public.windowsnt.misc (More info?)

I don't have IIS, but I've got two different FTP server
programs to try.

Both are having trouble opening the port (21).

I have a Windows NT domain, a router, and cable modem.

I have configured the router for a Virtual FTP Server as
best as I can figure out how. But I'm not getting
anywhere with it.

Any help? I'm not even sure if the router is the problem
or NT or what.

Please e-mail me as I may not remember to get back to this
group.

--Gabinka
12 answers Last reply
More about trying server server
  1. Archived from groups: microsoft.public.windowsnt.misc (More info?)

    Are you getting errors from the ftp server program, or is
    it just not getting through? Not sure what a "virtual ftp
    server" on the router is, try using "port forwarding" to
    forward port 21 to the ip of the nt server.
  2. Archived from groups: microsoft.public.windowsnt.misc (More info?)

    On Tue, 24 Aug 2004 22:03:41 -0700, "Gabinka" <listmail@earthlink.net>
    wrote:

    >I don't have IIS, but I've got two different FTP server
    >programs to try.
    >
    >Both are having trouble opening the port (21).
    >
    >I have a Windows NT domain, a router, and cable modem.
    >
    >I have configured the router for a Virtual FTP Server as
    >best as I can figure out how. But I'm not getting
    >anywhere with it.
    >
    >Any help? I'm not even sure if the router is the problem
    >or NT or what.
    >
    >Please e-mail me as I may not remember to get back to this
    >group.

    Do you have anything else on the box using port 21?

    Try this from a command line and see if anything responds:

    telnet 127.0.0.1 21


    And tell us more about the error. Is it coming from the FTP server
    program, or NT itself, or is this an error you get from outside?

    You also might try going to GRC.COM and running their "Shields Up"
    test, and see if that shows something open on that port from outside.


    I resisted 'till I couldn't take it anymore.

    (sigh) Address altered against Spam.

    Replace the -at- and put the "spring-mind" in the correct order
  3. Archived from groups: microsoft.public.windowsnt.misc (More info?)

    Thanks to both of you for answering.

    >Do you have anything else on the box using port 21?
    >
    >Try this from a command line and see if anything responds:
    >
    >telnet 127.0.0.1 21
    >
    >
    >And tell us more about the error. Is it coming from the
    FTP server
    >program, or NT itself, or is this an error you get from
    outside?

    Telling you more about it is waht I have to do. Today I
    found out that I do have IIS! I must have installed it
    long ago that I didn't remember. That was why 21 couldn't
    open. I twas already open! So I've scrapped those two
    servers and will just use IIS. BUT...

    I still can't get it to work. I can get it to work from
    inside my network (by using the loopback IP or the local
    IP of the server), but I can't get to it from outside the
    network, which is, of course, what I want and FTP server
    to do!

    I'm getting a public IP address from my ISP and they said
    they don't block FTP so it should work. I have set my D-
    Link DI-514 (B-revision) router's Virtual FTP Server to
    forward to the NT Servers IP (192.168.0.5) and port 21. I
    have set a firewall setting to allow WAN trafic from any
    IP address to get to 192.168.0.5 port 21. Even tried
    having that set to 192.168.0.1 (the router's IP addy) but
    still no go.

    In IE (on my work computer and thus not in my network), I
    get the following error:

    A connection with the server could not be established.
    (I'm using UFP\Max as the login (UFP is my domain, Max is
    an authorized user) and, of course, the correct password.

    I've installed WS_FTP to try it from work (using the same
    login)and I get this:

    Connection failed (IP address that I won't write here) -
    connection refused.
    Connection failed (IP address)

    You also might try going to GRC.COM and running
    their "Shields Up"
    >test, and see if that shows something open on that port
    from outside.

    I've been there before and foudn that I have a nice tight
    secure network. Only now I want to pen a crack. ;-) But
    now I do know that port 21 is open. I jsut can't seem to
    get to it from outside.

    Woudl still appreciate any help. After I get this solved,
    I think I'll try the http server now that I know I have
    IIS.

    --Gabinka
  4. Archived from groups: microsoft.public.windowsnt.misc (More info?)

    On Wed, 25 Aug 2004 10:43:19 -0700,
    <anonymous@discussions.microsoft.com> wrote:

    >
    >Thanks to both of you for answering.
    >
    >>Do you have anything else on the box using port 21?
    >>
    >>Try this from a command line and see if anything responds:
    >>
    >>telnet 127.0.0.1 21
    >>
    >>
    >>And tell us more about the error. Is it coming from the
    >FTP server
    >>program, or NT itself, or is this an error you get from
    >outside?
    >
    >Telling you more about it is waht I have to do. Today I
    >found out that I do have IIS! I must have installed it
    >long ago that I didn't remember. That was why 21 couldn't
    >open. I twas already open! So I've scrapped those two
    >servers and will just use IIS. BUT...
    >
    >I still can't get it to work. I can get it to work from
    >inside my network (by using the loopback IP or the local
    >IP of the server), but I can't get to it from outside the
    >network, which is, of course, what I want and FTP server
    >to do!
    >
    >I'm getting a public IP address from my ISP and they said
    >they don't block FTP so it should work. I have set my D-
    >Link DI-514 (B-revision) router's Virtual FTP Server to
    >forward to the NT Servers IP (192.168.0.5) and port 21. I
    >have set a firewall setting to allow WAN trafic from any
    >IP address to get to 192.168.0.5 port 21. Even tried
    >having that set to 192.168.0.1 (the router's IP addy) but
    >still no go.
    >
    >In IE (on my work computer and thus not in my network), I
    >get the following error:
    >
    >A connection with the server could not be established.
    >(I'm using UFP\Max as the login (UFP is my domain, Max is
    >an authorized user) and, of course, the correct password.
    >
    >I've installed WS_FTP to try it from work (using the same
    >login)and I get this:
    >
    >Connection failed (IP address that I won't write here) -
    >connection refused.
    >Connection failed (IP address)
    >
    >You also might try going to GRC.COM and running
    >their "Shields Up"
    >>test, and see if that shows something open on that port
    >from outside.
    >
    >I've been there before and foudn that I have a nice tight
    >secure network. Only now I want to pen a crack. ;-) But
    >now I do know that port 21 is open. I jsut can't seem to
    >get to it from outside.
    >
    >Woudl still appreciate any help. After I get this solved,
    >I think I'll try the http server now that I know I have
    >IIS.
    >
    >--Gabink

    Try connecting via the command line @ work. From a command prompt,
    type:

    ftp <the ip address>

    Do you get prompted for logon credentials, like so:

    C:\WINXP>ftp xxx.xxx.xxx.xxx

    Connected to blah.blah.org

    220 blah Microsoft FTP Service (Version 4.0).

    User (blah.blah.org:(none)): mark

    331 Password required for mark.

    Password:

    230 User mark logged in.

    ftp>


    If so, then a) it would appear your port forwarding is working, and b)
    you're connecting to the server.

    Try just using the username instead of the DOMAIN\User combo.


    Also, have you tried connecting to known good ftp sites from work to
    test whether your work has blocked port 21? It happens alot. Try
    FTPing to FTP.MICROSOFT.COM with username anonymous.


    I resisted 'till I couldn't take it anymore.

    (sigh) Address altered against Spam.

    Replace the -at- and put the "spring-mind" in the correct order
  5. Archived from groups: microsoft.public.windowsnt.misc (More info?)

    On Wed, 25 Aug 2004 12:26:07 -0700, mhaase-at-springmind.com
    <mhaase-at-springmind.com@> wrote:

    >On Wed, 25 Aug 2004 10:43:19 -0700,
    ><anonymous@discussions.microsoft.com> wrote:
    >
    >>
    >>Thanks to both of you for answering.
    >>
    >>>Do you have anything else on the box using port 21?
    >>>
    >>>Try this from a command line and see if anything responds:
    >>>
    >>>telnet 127.0.0.1 21
    >>>
    >>>
    >>>And tell us more about the error. Is it coming from the
    >>FTP server
    >>>program, or NT itself, or is this an error you get from
    >>outside?
    >>
    >>Telling you more about it is waht I have to do. Today I
    >>found out that I do have IIS! I must have installed it
    >>long ago that I didn't remember. That was why 21 couldn't
    >>open. I twas already open! So I've scrapped those two
    >>servers and will just use IIS. BUT...
    >>
    >>I still can't get it to work. I can get it to work from
    >>inside my network (by using the loopback IP or the local
    >>IP of the server), but I can't get to it from outside the
    >>network, which is, of course, what I want and FTP server
    >>to do!
    >>
    >>I'm getting a public IP address from my ISP and they said
    >>they don't block FTP so it should work. I have set my D-
    >>Link DI-514 (B-revision) router's Virtual FTP Server to
    >>forward to the NT Servers IP (192.168.0.5) and port 21. I
    >>have set a firewall setting to allow WAN trafic from any
    >>IP address to get to 192.168.0.5 port 21. Even tried
    >>having that set to 192.168.0.1 (the router's IP addy) but
    >>still no go.
    >>
    >>In IE (on my work computer and thus not in my network), I
    >>get the following error:
    >>
    >>A connection with the server could not be established.
    >>(I'm using UFP\Max as the login (UFP is my domain, Max is
    >>an authorized user) and, of course, the correct password.
    >>
    >>I've installed WS_FTP to try it from work (using the same
    >>login)and I get this:
    >>
    >>Connection failed (IP address that I won't write here) -
    >>connection refused.
    >>Connection failed (IP address)
    >>
    >>You also might try going to GRC.COM and running
    >>their "Shields Up"
    >>>test, and see if that shows something open on that port
    >>from outside.
    >>
    >>I've been there before and foudn that I have a nice tight
    >>secure network. Only now I want to pen a crack. ;-) But
    >>now I do know that port 21 is open. I jsut can't seem to
    >>get to it from outside.
    >>
    >>Woudl still appreciate any help. After I get this solved,
    >>I think I'll try the http server now that I know I have
    >>IIS.
    >>
    >>--Gabink
    >
    >Try connecting via the command line @ work. From a command prompt,
    >type:
    >
    >ftp <the ip address>
    >
    >Do you get prompted for logon credentials, like so:
    >
    >C:\WINXP>ftp xxx.xxx.xxx.xxx
    >
    >Connected to blah.blah.org
    >
    >220 blah Microsoft FTP Service (Version 4.0).
    >
    >User (blah.blah.org:(none)): mark
    >
    >331 Password required for mark.
    >
    >Password:
    >
    >230 User mark logged in.
    >
    >ftp>
    >
    >
    >
    >If so, then a) it would appear your port forwarding is working, and b)
    >you're connecting to the server.
    >
    >Try just using the username instead of the DOMAIN\User combo.
    >
    >
    >Also, have you tried connecting to known good ftp sites from work to
    >test whether your work has blocked port 21? It happens alot. Try
    >FTPing to FTP.MICROSOFT.COM with username anonymous.
    >


    Also, be sure you have given the user "Log on locally" rights, and
    that you haven't restricted logons to "Anonymous only" (it's been a
    while since I set up IIS, but I believe that's an option).
  6. Archived from groups: microsoft.public.windowsnt.misc (More info?)

    >Try connecting via the command line @ work. From a
    command prompt,
    >type:
    >
    >ftp <the ip address>
    >
    >Do you get prompted for logon credentials, like so:
    >
    >C:\WINXP>ftp xxx.xxx.xxx.xxx
    >
    >Connected to blah.blah.org
    >
    >220 blah Microsoft FTP Service (Version 4.0).

    no. I got
    ftp: connect: unknown error number

    >
    >If so, then a) it would appear your port forwarding is
    working, and b)
    >you're connecting to the server.
    >
    >Try just using the username instead of the DOMAIN\User
    combo.
    >
    >
    >Also, have you tried connecting to known good ftp sites
    from work to
    >test whether your work has blocked port 21? It happens
    alot. Try
    >FTPing to FTP.MICROSOFT.COM with username anonymous.

    I was able to get to another Ftp site I use for stories I
    write. It's hosted by someone else. I want to host my own
    still.

    WS_FTP, the ftp client I like to use, has a Firewall tab
    and I wonder if something there can't help me.

    I did get a hold of my router's manufacturer, and they are
    pretty sure the router is set up correctly. MY ISP can't
    help me much beyond saying they don't block FTP.

    --Gabinka
  7. Archived from groups: microsoft.public.windowsnt.misc (More info?)

    >Also, be sure you have given the user "Log on locally"
    rights, and
    >that you haven't restricted logons to "Anonymous only"
    (it's been a
    >while since I set up IIS, but I believe that's an option).

    Almost all my users are Admins on the network. Because all
    but one of the users are me. I just use a different
    username on the different computers at home. And yes, I
    didn't set it to Anonymous only

    But I think I've diagnosed the problem this evening. I
    just don't knknow how to fix it yet. I don't have
    TCP/IP bound to any services. I'm pretty sure it needs to
    be bound to at least the Server service. I've tried
    uninstalling and reinstalling it to no avail. I can't
    seem to find anywhere to add a binding. Enable and
    disable yes, but it has to exist to be enabled or
    disabled.

    I may have to uninstall the NIC and reinstall it and see
    if it binds automatically to all the services. It's
    presently bound to the NIC, but not to the services.

    Any ideas if that doesn't work?

    --Gabinka
  8. Archived from groups: microsoft.public.windowsnt.misc (More info?)

    >
    >But I think I've diagnosed the problem this evening. I
    >just don't knknow how to fix it yet. I don't have
    >TCP/IP bound to any services. I'm pretty sure it needs
    to
    >be bound to at least the Server service. I've tried
    >uninstalling and reinstalling it to no avail. I can't
    >seem to find anywhere to add a binding. Enable and
    >disable yes, but it has to exist to be enabled or
    >disabled.
    >
    >I may have to uninstall the NIC and reinstall it and see
    >if it binds automatically to all the services. It's
    >presently bound to the NIC, but not to the services.
    >
    >Any ideas if that doesn't work?

    It didn't work. I do have WINS (TCP/IP) bound to all
    three services, but I can't seem to get just plain TCP/IP
    to bind to any of the services.

    If this is the problem, I'm stymied. I even scoured my NT
    Server and TCP/IP books and didn't find anything helpful.
    In the Bindings tab in Network Properties, I can only
    enable or disable, move up or move down. But I can't Add
    or Remove.

    Any help on this one?

    --Gabinka
  9. Archived from groups: microsoft.public.windowsnt.misc (More info?)

    >If this is the problem, I'm stymied. I even scoured my
    NT
    >Server and TCP/IP books and didn't find anything
    helpful.
    >In the Bindings tab in Network Properties, I can only
    >enable or disable, move up or move down. But I can't Add
    >or Remove.
    >
    >Any help on this one?

    And apparently this isn't the problem. I ran the common
    ports test from grc.com and my port 21 is still showing
    closed.

    Darn it.

    --Gabinka
  10. Archived from groups: microsoft.public.windowsnt.misc (More info?)

    On Wed, 25 Aug 2004 23:48:20 -0700, "Gabinka"
    <anonymous@discussions.microsoft.com> wrote:

    >
    >>If this is the problem, I'm stymied. I even scoured my
    >NT
    >>Server and TCP/IP books and didn't find anything
    >helpful.
    >>In the Bindings tab in Network Properties, I can only
    >>enable or disable, move up or move down. But I can't Add
    >>or Remove.
    >>
    >>Any help on this one?
    >
    >And apparently this isn't the problem. I ran the common
    >ports test from grc.com and my port 21 is still showing
    >closed.
    >
    >Darn it.


    Just so I'm clear on where we are on this (don't want to start just
    throwing fixes at it):

    1) You are able to connect to the FTP Server locally (from the NT
    Server Itself) by typing "ftp 127.0.0.1" at a command prompt?

    2) You are also able to connect to the Server from within your LAN by
    typing "ftp <server ip>" at a command prompt from another computer on
    your network?

    3) The GRC.COM common ports test shows port 21 "closed"?
  11. Archived from groups: microsoft.public.windowsnt.misc (More info?)

    >-----Original Message-----

    >Just so I'm clear on where we are on this (don't want to
    start just
    >throwing fixes at it):
    >
    >1) You are able to connect to the FTP Server locally
    (from the NT
    >Server Itself) by typing "ftp 127.0.0.1" at a command
    prompt?

    Yes.

    >2) You are also able to connect to the Server from within
    your LAN by
    >typing "ftp <server ip>" at a command prompt from another
    computer on
    >your network?

    Yes, but also by WS_FTP or IE. Using the local IP of teh
    server.


    >3) The GRC.COM common ports test shows port 21 "closed"?

    Yep.

    Ihterestingly enough, switching to port 23 almost worked
    for one of the FTP server software packages. I could
    connect from outside my entwork, but I couldn't pull up
    the file list.

    And all this may be moot as I'm going to upgrade the
    server OS. We'll see if I still have a problem after that.

    Thanks for all your help.

    --Gabinka
    >
    >
    >.
    >
  12. Archived from groups: microsoft.public.windowsnt.misc (More info?)

    On Thu, 26 Aug 2004 13:14:29 -0700, "Gabinka"
    <anonymous@discussions.microsoft.com> wrote:

    >
    >>-----Original Message-----
    >
    >>Just so I'm clear on where we are on this (don't want to
    >start just
    >>throwing fixes at it):
    >>
    >>1) You are able to connect to the FTP Server locally
    >(from the NT
    >>Server Itself) by typing "ftp 127.0.0.1" at a command
    >prompt?
    >
    >Yes.
    >
    >>2) You are also able to connect to the Server from within
    >your LAN by
    >>typing "ftp <server ip>" at a command prompt from another
    >computer on
    >>your network?
    >
    >Yes, but also by WS_FTP or IE. Using the local IP of teh
    >server.
    >
    >
    >>3) The GRC.COM common ports test shows port 21 "closed"?
    >
    >Yep.
    >
    >Ihterestingly enough, switching to port 23 almost worked
    >for one of the FTP server software packages. I could
    >connect from outside my entwork, but I couldn't pull up
    >the file list.
    >
    >And all this may be moot as I'm going to upgrade the
    >server OS. We'll see if I still have a problem after that.


    Sounds to me like you still have something in your router
    misconfigured or blocking the port forwarding. The fact that it
    works internally means there's nothing wrong with the server itself.
    If that's the case, upgrading the server OS won't make any difference.

    Have you tried turning off the firewall portion of the D-Link
    entirely? Just for the few minutes it'll take for a test.


    I resisted 'till I couldn't take it anymore.

    (sigh) Address altered against Spam.

    Replace the -at- and put the "spring-mind" in the correct order
Ask a new question

Read More

Routers Servers FTP Windows