Sign in with
Sign up | Sign in
Your question

Dual monitors question: ATI Extended Mode not working

Last response: in Graphics & Displays
Share
December 15, 2005 7:57:04 PM

System specs:
AMD Athlon 3200+ 64 bit (not in 64 bit mode)
2 Gig DDR RAM
ATI Radeon 9800 Pro 256
Catalyst 5.12
Windows XP Home SP2

I do gaming and also work on this computer and I recently added a second monitor I had laying around. Using the RGB out for my primary (19" monitor) and the DVI out (with a DVI to RGB adapter) to my secondary (21" CRT monitor), I am able to go to "Stretched Horizontally." I don't like the Stretched mode as the refresh rate is limited to 60 hz and the taskbar stretches across both monitors.

ATI's website says that there is a mode called Extended Desktop. I assume this is very similar to nVidia's "DualView" mode. However, it isn't even an option in the Catalyst Control Center. I've gone through ATI's support website (which isn't half bad, by the way) and after a week of back-and-forth they are saying it's a problem with my Windows installation and I have to repair or reinstall Windows! Gimme a break!

For example, when I right-click on the desktop, choose Properties, choose Settings, I get a single monitor shown that labels itself as [multiple monitors] on Radeon 9800 Pro. It's supposed to have two monitors shown so I can choose the option to "Extend my windows desktop to this monitor" but there's no second monitor shown.

Anyone had this problem? Any suggestions before I plow into reinstalling XP? *shudder*

Thanks,
Jamon
December 16, 2005 6:27:35 PM

Nobody has run into this before?
-jamon
December 16, 2005 10:17:58 PM

Well I fixed it! I was reading a tutorial about installing dual monitors and they said to check the device manager to see if there were any other video cards installed. I knew there weren't, but it made me think--well, check it anyway. I went there and what do you know--under Display Adapters, the Radeon 9800 Pro (Secondary) was disabled. Don't ask me why--I dunno how it got that way.

So if you have this problem, do this:
1. Right-click My Computer and choose Properties
2. Go to Hardware and choose Device Manager
3. Expand the Display Adapters tab and check to make sure they are all enabled. If not, enable them. You might have to restart to get it to work (I didn't but you never know) but it should work then.

Thanks!
Jamon
Related resources
a b U Graphics card
December 19, 2005 1:14:29 AM

It's unlikely any of us have experienced your problem. Both primary and secondary displays are enabled by default, and the only time I've seen the secondary display disabled is when some idiot told a guy he was supposed to do that in response to "why do I have two displays listed".

Anyway, since most of us don't take advice from idiots, most of us have both displays enabled. And with both displays enabled, windows Display Manager controls extended desktop settings, hence it has nothing to do with Catalyst Control Center, etc.
a b U Graphics card
December 19, 2005 1:16:08 AM

BTW, I'm not calling you an idiot, rather, I'm saying that it would appear that you, or someone else using the computer, was newbie enough to take someone else's advice...when that someone else was an idiot.

Hey, we were all newbies at one time!
December 19, 2005 3:34:53 AM

You know, you may have a point. Either that or I disabled it sometime when I was trying to hook up my miniDV camera to record my screen and was having problems.

Anyway, it's fixed now, me being an idiot notwithstanding. :roll:

-j
Anonymous
a b U Graphics card
a b C Monitor
October 28, 2009 5:57:55 PM

jamon51 said:
Well I fixed it! I was reading a tutorial about installing dual monitors and they said to check the device manager to see if there were any other video cards installed. I knew there weren't, but it made me think--well, check it anyway. I went there and what do you know--under Display Adapters, the Radeon 9800 Pro (Secondary) was disabled. Don't ask me why--I dunno how it got that way.

So if you have this problem, do this:
1. Right-click My Computer and choose Properties
2. Go to Hardware and choose Device Manager
3. Expand the Display Adapters tab and check to make sure they are all enabled. If not, enable them. You might have to restart to get it to work (I didn't but you never know) but it should work then.

Thanks!
Jamon



Thank you SO much for posting this. We had the EXACT same problem. And I'm not sure what the other people here were complaining about. This computer was brand new and no one had messed with it. Today we tried to get the Extended Desktop to work, and it would not until we turned on the 2nd device in Device Manager. Thanks again!
July 3, 2011 12:08:52 AM

This info helped me solve a similar problem, the Screen Resolution control panel and the ATI Catalyst Control Center both would only duplicate the displays. Nothing I tried would work to extend the displays with separate resolutions. Choosing extend desktop would just flash the screen and ignore my changes. I was about to give up and return the video card when I saw this post about Device Manager.

Except for me the fix was kind of the opposite, device manager only showed one display adapter, which it should since my video card supports 3 monitors. But then I remembered an old trick to show hidden/non-present devices:

- Open an elevated Command Prompt (right-click, Run As Administrator)
- Run these commands:
Set DEVMGR_SHOW_NONPRESENT_DEVICES=1
Start Devmgmt.msc
- After Device Manager launches, from the View menu select Show Hidden Devices
- Expand Display Adapters
- Right click any adapters that are no longer installed, and select Uninstall
- Reboot, even if you aren't prompted for a restart

It showed my current Sapphire Radeon HD5670, but it also showed an old nVidia card listed that was no longer installed. After uninstalling it and rebooting the Extend Desktop worked. It also showed Standard VGA Graphics Adapter but I left that one in case it's needed for safe mode or fallback when the card is replaced.
!