Swiss German/French Microsoft Keyboard problem

Archived from groups: microsoft.public.windowsnt.misc (More info?)

I purchased in Switzerland a German/French Keyboard and find now that
the key coding with Language set to German and Keyboard set to German
many keys do not display the character indicated. Instead they display
the old DOS keys.
Examples:
-- ctrl-alt-2 should be an "@", but comes up as a "²"
-- ctrl-alt-] should display a"]", but instead displays a "~"
and a number more keys do not make sense.....

Is there anything I do wrong? I use Windows XP
Thank you
Joseph
1 answer Last reply
More about swiss german french microsoft keyboard problem
  1. Archived from groups: microsoft.public.windowsnt.misc (More info?)

    Joseph Rudigier wrote:
    >
    > I purchased in Switzerland a German/French Keyboard and find now that
    > the key coding with Language set to German and Keyboard set to German
    > many keys do not display the character indicated. Instead they display
    > the old DOS keys.
    [...]
    > Is there anything I do wrong? I use Windows XP

    The Swiss and German keyboard layouts are pretty different. Therefore, it is not
    enough to set your keyboard layout to "German" ("Deutsch") but you need to set
    it to "German (Switzerland)" ("Deutsch (Schweiz)").
    Your current setting seems to be something like "German (Germany)" or "German
    (IBM)". (control panel --> keyboard --> schemes and layouts)
    If you are a German (not a Swiss) user be aware you won't find a sharp-s ("ß")
    on the Swiss keyboard and there is no easy way to produce this character if you
    use the Swiss keyboard layout (if this is a problem come back here).
    If you are a Swiss user be aware that your region scheme is probably not set to
    Switzerland. Otherwise you should have got the Swiss layout automatically.

    Stephan
Ask a new question

Read More

Keyboards Microsoft Windows Displays