Sign in with
Sign up | Sign in
Your question

Major problem with Linksys BEFW11S4

Last response: in Networking
Share
April 23, 2003 11:46:36 PM

Hello all,

I've recently moved, and have taken with me all my assorted nerd belogings, including my Linksys WAP/Router BEFW11S4 Ver. 2. I'm on a cable modem provided by Adelphia, and it is, quite simply, the most evil thing I have ever encountered in my 20 years on this earth. I have had this router now for nearly a year, and prior to my recent move (and consecutive swap of cable modems, although the ISP did not change) the router worked absolutely flawlessly. With this new cable modem (Terayon TJ715), the router has simply ceased to work. I can LAN across it just fine (4-port switch on the back), but if I try in any way shape or form to get out to the internet on any of my computers, none of them have internet access......UNLESS I connect the cable modem DIRECTLY to their NICs, then everything is fine. Naturally, this is extremely annoying. I set about trying to fix it.

The first thing I did, figuring it was some odd cabling problem, was swap out the CAT5e patch cable that came with the modem with one of my spares. Plugged on RJ45 into the modem, the other into the NIC, to test, and it worked fine. Plugged it into the router, nothing. Tried a crossover cable, nothing for either connection. (Wasn't expecting much.)

Now getting extremely frustrated, I hop around to linksys' website, and they recommend MAC address cloning with Adelphia (which still seems odd to me as I never used it before with Adelphia and the router worked just fine). I go ahead and clone the MAC with the MAC address of this computer's NIC. Do the restart, power down thing, wait a bit, and start up again. Try to connect to the internet. Nothing. I try the MACs of both my laptop's wired and wireless NICs, nothing both times. I check for firewall settings on the router (there are none), I check firewall settings on my own machines (there are none), I check everything I can possibly think of. Still no internet with the router.

By this time I'm getting very annoyed. I take a look at the modem itself. When it's plugged into a NIC, the LEDs on the front light up as they should (Power -> Cable -> PC -> Data, from top to bottom), and everything works fine. When I connect the modem to the router, they only light as far as Cable, and then nothing. No matter how long I leave the modem and the router disconnected from power, nothing. There is no reset switch on the cable modem, and thus I can't actually push a button to reset it. I've reset and reconfigured the router so many times that I can nearly do it in my sleep, blindfolded, with my hands tied behind my back using my tounge to type. No matter what I do: NO INTERNET BEHIND THE ROUTER, AND THUS NO SHARING OF THE INTERNET CONNECTION.

I head to adelphia's page (www.adelphiapowerpage.com) and check their TOS, while they don't support home networking, they don't forbid it. Makes sense. I head to Terayon's site to check info on the modem. Networking with their modem, according to them, is essentially not their issue. I head Linksys, again. I check, recheck, and double-check anything and everything I can about the BEFW11S4. Still no internet. I scream, rant, rave and threaten bodily harm upon the cable modem (whom I suspect is the problem), and all its earthbound descendants. Still no internet. I ask several people with expertise in networking, they suggest several things. I try them all. Still no internet. (Sensing a trend here?)

I've done ABSOLUTELY EVERYTHING I CAN POSSIBLY THINK OF. As far as I know, Adelphia does not require inputting the host name and DNS suffix for access. It uses its own DHCP servers, and thus I have the router set accordingly. (Obtain IP automatically), I have the MAC on the router cloned to this computer's NIC MAC. I have this computer's IP set in the DMZ (for the hell of it, I'm desperate). I have a shotgun sitting in the corner fully loaded and ready to waste this cable modem at moment's notice (not really, but right now one would be handy). And yet, still, somehow, I have absolutely no internet connection behind this router. I am about ready to say "fudge it all" (only I didn't say fudge, I said THE word.. the F--- word! <extra points if you catch the reference>), and go out and buy a new cable modem just to see if that will frickin' work.

The only ONLY thing that I can think of is that the router and cable modem are in some way not communicating (as evidenced by the LEDs on the modem and the inability of the router to obtain an IP address for itself from Adelphia's DHCP servers.) The router does not have a firewall enabled on it. But it seems as if the modem is blocked from accessing it, or transmitting data to it for some reason. The LEDs on the router suggest that it recognizes the link to the cable modem, but the cable modem does not "return the favor", it only shows the "good" status of the cable line (the coaxial line), and that the power is on. It doesn't realize it's connected to any computers whatsoever.

So, without further adieu: WHAT THE HELL IS HAPPENING HERE?! I am about to simply throw half of this crap out the door and be done with it. Having these 3 PCs (2 wired, and the wireless laptop) working together is extremely important (AND WORKED FINE BEFORE I MOVED AND GOT A NEW CABLE MODEM FROM ADELPHIA! AUGH!) for me. I need for all of them to have internet access. None of them do. I would prefer not having to shell out more cash because of one fluke that I'll inevitably find out about later down the road and realize I could've tweaked ONE SMALL LITTLE ANNOYING THING and fixed it all without new equipment. Can anyone tell this is getting on my nerves? :p 

-Gonk
April 24, 2003 12:13:51 PM

couple of things:

1) Can you directly connect any of your client PC's (desktop/laptop etc) to the modem and they work? If so, cloning the MAC is not the problem.

2) It sounds to me like the router is broken - specifically the WAN port. Maybe it got dropped when you moved or something? A way that I can think of to test if would be to set up a DHCP server <A HREF="http://www.weird-solutions.com/download/index.html" target="_new">DHCP turbo personal edition</A> or even setup ICS if you have an OS that includes that. Then connect the router WAN port to the NIC on the PC and see if it will get an IP address.

3) If it's not a hardware problem, (I know you said you tried everything) is is possible Adelphia requires PPPoE username and password? Not likely because you would need to set that up in the PC direct connect as well, but I thouht I'd throw that out anyway...


Keep us posted.

<i>It's always the one thing you never suspected.</i>
April 24, 2003 5:55:29 PM

I think you're correct. Was talking with one of Linksys' live support people on their website, and it looks like the WAN port is bad. Fortunately it's still covered by their 1 year warranty, so I'll be able to RMA it. Thanks for the help, though, I greatly appreciate it. :) 
!