BIOS doesn't recognize my SATAII HD

I just built this new computer and after entering BIOS on initial boot up my WD 120G SATAII HD was not recognized in the BIOS.
I tried using a different SATA cable but it didn't work. Tried plugging the SATA cable to different ports on the MB still nothing. Tried using the molex adapter or the SATA power adapter still got nothing.
Basically, I tried changing all the cables that I could but nothing worked.
Could it be a bad HD? My motherboard is ASUS A8N-E.
4 answers Last reply
More about bios doesn recognize sataii
  1. did you check in BIOS if the controller was enabled or if it was set to operate as RAID? SATA controller SHOULD be ENABLED and RAID SHOULD be DISABLED

    And if you plugged both the molex and the SATA power at the same time, you may have ruined the drive.

    One more thing.. check on the drive if there is a jumper for SATA1/II operation. Try it at both position.
  2. Raid was disabled and SATA was enabled. I didn't plug the molex and sata power cords at the same time. I plugged them in separately. I tried the jumper too but nothing happened. I just put my ear on the HD and I didn't hear any noise coming from it, so I guess that it's dead?
  3. well,it might be... if you have another one to try do it and you'll see.
  4. As the previous poster wisely said you could try another SATA drive on that board to see if it works.

    You could also try the suspect drive on another motherboard if you have access to one.

    You may want to try removing all jumpers as well as trying all possible jumper settings.
Ask a new question

Read More

Hard Drives BIOS HD Cable SATA Storage