Sign in with
Sign up | Sign in
Your question

Cd Rom Device Not Ready

Last response: in Components
Share
December 26, 2005 11:52:14 PM

Device not ready. Device not accessible.
I connected a cd rom drive to my computer so that I could install software for an external hard drive. The cd rom light goes on during boot but when I attempt to use it I get the above message.
I can see the drive in my computer.
When I right click on the drive and hit eject - it does, so there is some communication with the pc.
Sorry to admit that I have been mucking about in the bios and probablly need to fix those settings.
Tried a second cd rom and different cable with the same results.
In device manager, under properties of the drive I only have Disconnect, and Auto Insert Notification checked. Not DMA.
I don't know if my attempts to download drivers for my new hard drive from the internet may have conflicted with the driver for my cd rom.
Running Windows 98 on and OLD computer.

Can you tell me what setting I should have in my bios for my master and slaves, how I can uninstall anything that may be causing this, and reinstall the drive cleanly. Would try to reformat and reinstall Windows - but don't see how I can without a cd and don't know if a reinstall would fix things anyway.
Thanks for your help - I am going crazy.

More about : rom device ready

December 27, 2005 1:46:04 PM

Try to get the latest drivers for your CD-ROM. Using the standard CD-ROM drivers that comes with Win98 may not be enough.

Is the CD burned or stamped? Many CD-ROM drives will have trouble reading old burned CDs because they have to fallback to a slower speed to successfully read in the data. Plus, CD formats change over time, so you need to have drivers that can understand those format.

I know for certain Kenwood CD-ROMs have a terrible time reading old burned CDs especially the ones with zen technology.
December 27, 2005 2:33:18 PM

if you boot to Command Prompt, can you read a CD?
Otherwise delete the CD-Rom from the Device Manager and have Windows re-discover it.
!