Sign in with
Sign up | Sign in
Your question

why is my second hard disk slow??

Last response: in Storage
Share
January 1, 2006 10:59:47 AM

hi all, i have a dell dimension 4600, 2.8 gh pentium processor. my master hard drive is 80gigs and when i tried to hook up a second hard disk, another 80 gigger as a slave, the performance of the second was noticeably slower and i can't figure this out. even though i double checked the jumper settings and played around with them i can't get it to work correctly.

a guy i asked at compusa said that if i hook it up incorrectly the second drive simply won't be recognized, although when i hooked it up with different jumper settings it was recognized all the time. is this true? also, could this have anything to do with the power needed to run the second hard drive? thanks for the help.

More about : hard disk slow

January 1, 2006 11:19:20 AM

how are you testing them? if you have them on the same IDE cable it can cause performance isuues cause IDE is only one way. what your friend meant was the master should be at the end of the ide cable and the slave should use the plug at the middle of the cable.

try hdtune

and run its benchmark utility on the drives to see what the performance is like.

and then try a different IDE socket to see if that will fix it.
January 5, 2006 4:10:50 PM

try looking to see if they are both running in Udma 5 or 6.
don't have either one set to pmo

also, try putting the second drive at cable select instead.

hope you find your problem
Related resources
February 7, 2006 10:56:59 PM

I think your second hard disk is at PIO mode instead of DMA mode.

(1) To confirm, right click on "My Computer", go to "Properties", then "Hardware", then "Device Manager", then double-click "IDE ATA/ATAPI controller" or something like that, then double-click on "Primary IDE channel", then "Advanced Settings". Make sure that "Transfer Mode" for both disks are set as "DMA if available". If "Current Transfer Mode" still says "PIO", please do the following:

(2) Reboot and go to BIOS setup (hit a special key during reboot, such as F2 or F8, normally announced on the first screen), then check to see if your second hard disk is in "off" mode. If it is, turn it on or change it to "Auto". It may say "Unknown Device" at the beginning, but if you reboot again it should recognize the second hard disk.

Now do (1) again and you should see "DMA mode" instead of "PIO mode". The speed should be much higher in DMA mode.

Hope this helps. I had the same problem with my Dell computer and it took me two days to finally figure it out. It's a very stupid BIOS setting on Dell's part. Somehow the "off" setting prevents DMA mode but still allows the much slower PIO mode. Let me know if it solves your problem.


-Calvin
Anonymous
a b G Storage
June 17, 2011 8:53:29 PM

Calvin,

I know this thread is VERY old, bit I just wanted to say thank you for solving a very annoying problem for me.

I was having the same prob as the original poster with my Dell Dimension 3000 after I'd installed a 300GB HDD as a slave. It was taking nearly 10 minutes to transfer 1GB of data from the main HDD to it, or vice versa.

I did what you said in the BIOS settings, and now it takes about 50 seconds!

I'm more than happy, as this has been bugging me for days and nobody else on the web seemed to know what to do.

Thanks again,

Nick, Oxford, UK :hello: 
!