Local printer not shown on terminal Server.

Archived from groups: microsoft.public.windowsnt.terminalserver.client (More info?)

We have a local printer (A Brother Multifunction printer) that does not
shown up on the terminal server then we are connecting.

I have tried to install the drivers on the server to see if the terminal
server would connect the printer from the Remote Desktop client, but no.. it
wouldn't..

How can i make this local printer to be (it's local on the computer who
connects), used through the terminal service??

/Jonas
2 answers Last reply
More about local printer shown terminal server
  1. Archived from groups: microsoft.public.windowsnt.terminalserver.client (More info?)

    Most Brother MFC printers are NOT terminal services compliant. Your best hope
    is to try to map this printer to a LaserJet 4 driver via user defined inf
    file.

    Instructions here:
    http://www.workthin.com/tsp.htm
    http://www.workthin.com/printingsupport.com/matrix.htm

    Patrick Rouse
    Microsoft MVP - Terminal Server
    http://www.workthin.com

    "Jonas Haggren" wrote:

    > We have a local printer (A Brother Multifunction printer) that does not
    > shown up on the terminal server then we are connecting.
    >
    > I have tried to install the drivers on the server to see if the terminal
    > server would connect the printer from the Remote Desktop client, but no.. it
    > wouldn't..
    >
    > How can i make this local printer to be (it's local on the computer who
    > connects), used through the terminal service??
    >
    > /Jonas
    >
    >
    >
  2. Archived from groups: microsoft.public.windowsnt.terminalserver.client (More info?)

    There is one more solution using custom INF file and custom mapping:

    Please create two registry key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal
    Server\Wds\rdpwd\PrinterMappingINFName = <exact location of the custom INF
    file>

    Ex: C:\WINNT\inf\printOEM.inf


    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal
    Server\Wds\rdpwd\PrinterMappingINFSection = <section name in custom INF
    file>

    Ex: OEM Printer Mapping


    NOTE: both registry values must be “string” type


    For this above example you custom INF file should be Named:
    “printOEM.inf”

    Located in: “C:\WINNT\inf\”

    section title: “[OEM Printer Mapping]”


    inside the file:


    [OEM Printer Mapping]

    “client side driver name ” = “server side driver name”

    “your OEM driver name” = “HP LaserJet 4”

    “your OEM driver name” = “your OEM driver if it is capable to
    install”


    --
    Zenon Pilat (MS)
    ---
    This posting is provided "AS IS" with no warranties, and confers no rights
    ---

    "Jonas Haggren" <jonas.haggren@REMOVE_THIS.evolver.se> wrote in message
    news:%23B8qPt3DFHA.2568@TK2MSFTNGP10.phx.gbl...
    > We have a local printer (A Brother Multifunction printer) that does not
    > shown up on the terminal server then we are connecting.
    >
    > I have tried to install the drivers on the server to see if the terminal
    > server would connect the printer from the Remote Desktop client, but no..
    > it wouldn't..
    >
    > How can i make this local printer to be (it's local on the computer who
    > connects), used through the terminal service??
    >
    > /Jonas
    >
Ask a new question

Read More

Terminal Server Printers Windows