Sign in with
Sign up | Sign in
Your question

Local drive access terminal server 2003 upgrade

Last response: in Windows 2000/NT
Share
July 31, 2004 8:00:56 AM

Archived from groups: microsoft.public.windowsnt.terminalserver.connectivity (More info?)

Performed an upgrade from terminal server 2000 to 2003. This is a
member server of a domain. Added the appropriate users to the local
Remote Desktop Users group to allow them login. The users can login,
but to not see local redirected drives even if checking the option in
the RDP client. However, if a user is a member of the terminal
server's local administrator's group, they do see the drives. I
obviously can't leave everyone a member of the local computer's admin
group. I've done a new install of a 2003 terminal server before and
didn't have this issue. Is there a security setting that I'm missing
somwhere? Permission compatibility is set to Relaxed Security. Any
help is much appreciated.
Anonymous
August 17, 2004 11:26:04 PM

Archived from groups: microsoft.public.windowsnt.terminalserver.connectivity (More info?)

To preserve same user experience, after upgrade from Win2000 the drive
redirection is blocked since this is a new feature.
Please check if the setting for Drive mapping is not disabled on TSCC.MSC.
1. Start tscc.msc from command prompt
2. Open RDP-Tcp Properties dialog page
3. Click Client Settings tab
4. Make sure the check box for Drive mapping in Disable the following is not
checked.

--
Zenon Pilat (MS)
---
This posting is provided "AS IS" with no warranties, and confers no rights
---

"Jeff" <jeffstrong@comcast.net> wrote in message
news:bf90e941.0407310300.1f21734e@posting.google.com...
> Performed an upgrade from terminal server 2000 to 2003. This is a
> member server of a domain. Added the appropriate users to the local
> Remote Desktop Users group to allow them login. The users can login,
> but to not see local redirected drives even if checking the option in
> the RDP client. However, if a user is a member of the terminal
> server's local administrator's group, they do see the drives. I
> obviously can't leave everyone a member of the local computer's admin
> group. I've done a new install of a 2003 terminal server before and
> didn't have this issue. Is there a security setting that I'm missing
> somwhere? Permission compatibility is set to Relaxed Security. Any
> help is much appreciated.
Anonymous
August 31, 2004 7:46:33 PM

Archived from groups: microsoft.public.windowsnt.terminalserver.connectivity (More info?)

Hi, I'm having a similar problem.
Thanks to your suggestion, I can now access my Local Printers.
However, I still can't access my Local Hard Drive.
How do I overcome this when this box is greyed out?

4. Make sure the check box for Drive mapping in Disable the following is not
checked

--

Regards,

Slarty Bartfast
"Zenon Pilat [MS]" <zenonp@online.microsoft.com> wrote in message
news:o U472qMhEHA.596@TK2MSFTNGP11.phx.gbl...
> To preserve same user experience, after upgrade from Win2000 the drive
> redirection is blocked since this is a new feature.
> Please check if the setting for Drive mapping is not disabled on TSCC.MSC.
> 1. Start tscc.msc from command prompt
> 2. Open RDP-Tcp Properties dialog page
> 3. Click Client Settings tab
> 4. Make sure the check box for Drive mapping in Disable the following is
not
> checked.
>
> --
> Zenon Pilat (MS)
> ---
> This posting is provided "AS IS" with no warranties, and confers no rights
> ---
>
> "Jeff" <jeffstrong@comcast.net> wrote in message
> news:bf90e941.0407310300.1f21734e@posting.google.com...
> > Performed an upgrade from terminal server 2000 to 2003. This is a
> > member server of a domain. Added the appropriate users to the local
> > Remote Desktop Users group to allow them login. The users can login,
> > but to not see local redirected drives even if checking the option in
> > the RDP client. However, if a user is a member of the terminal
> > server's local administrator's group, they do see the drives. I
> > obviously can't leave everyone a member of the local computer's admin
> > group. I've done a new install of a 2003 terminal server before and
> > didn't have this issue. Is there a security setting that I'm missing
> > somwhere? Permission compatibility is set to Relaxed Security. Any
> > help is much appreciated.
>
>
Related resources
Anonymous
September 1, 2004 8:48:39 PM

Archived from groups: microsoft.public.windowsnt.terminalserver.connectivity (More info?)

General Policy on your TS Server must be set to disable drive redirection
Start gpedit.msc
Navigate to Computer Configuration => Administrative Templates => Terminal
Services => Client/Server
You will find the GP saying "Do not allow drive redirection"
Please check the setting for this policy - this policy must be Disabled or
Not Configured (in this setting the client setting decide if drive
redirection will be working or not)
When this policy is Enabled it will gray out the check box in TSCC.MSC
--
Zenon Pilat (MS)
---
This posting is provided "AS IS" with no warranties, and confers no rights
---

"Slarty Bartfast" <Slarty@Bartfast.com> wrote in message
news:eApZu2xjEHA.3896@TK2MSFTNGP15.phx.gbl...
> Hi, I'm having a similar problem.
> Thanks to your suggestion, I can now access my Local Printers.
> However, I still can't access my Local Hard Drive.
> How do I overcome this when this box is greyed out?
>
> 4. Make sure the check box for Drive mapping in Disable the following is
> not
> checked
>
> --
>
> Regards,
>
> Slarty Bartfast
> "Zenon Pilat [MS]" <zenonp@online.microsoft.com> wrote in message
> news:o U472qMhEHA.596@TK2MSFTNGP11.phx.gbl...
>> To preserve same user experience, after upgrade from Win2000 the drive
>> redirection is blocked since this is a new feature.
>> Please check if the setting for Drive mapping is not disabled on
>> TSCC.MSC.
>> 1. Start tscc.msc from command prompt
>> 2. Open RDP-Tcp Properties dialog page
>> 3. Click Client Settings tab
>> 4. Make sure the check box for Drive mapping in Disable the following is
> not
>> checked.
>>
>> --
>> Zenon Pilat (MS)
>> ---
>> This posting is provided "AS IS" with no warranties, and confers no
>> rights
>> ---
>>
>> "Jeff" <jeffstrong@comcast.net> wrote in message
>> news:bf90e941.0407310300.1f21734e@posting.google.com...
>> > Performed an upgrade from terminal server 2000 to 2003. This is a
>> > member server of a domain. Added the appropriate users to the local
>> > Remote Desktop Users group to allow them login. The users can login,
>> > but to not see local redirected drives even if checking the option in
>> > the RDP client. However, if a user is a member of the terminal
>> > server's local administrator's group, they do see the drives. I
>> > obviously can't leave everyone a member of the local computer's admin
>> > group. I've done a new install of a 2003 terminal server before and
>> > didn't have this issue. Is there a security setting that I'm missing
>> > somwhere? Permission compatibility is set to Relaxed Security. Any
>> > help is much appreciated.
>>
>>
>
>
January 5, 2007 6:53:29 PM

Hi,

We are having a maddening problem that is similar. Have already checked gpedit & tscc settings. RDP access to local drives used to work, but now they fail. Can see the drives listed, but when clicking on them, get an hourglass that goes away after about 15 seconds. At this point explorer is "not responding", and has to be terminated.

Suspect a recent Windows Update broke something. Running XP SP2 fully patched on the client, W2K3 R2 fully patched on the server.

Any help would be much appreciated. Have spent over a man-week trying to figure this one out.

Steve
January 16, 2007 7:22:02 PM

I have also been pulling my hair out on this. Have you come up with any solution?
January 25, 2007 4:01:31 PM

Hi,

Here is the latest. We removed terminal services, and re-installed. After that, access to "local drives" when RDPd (i.e. the drives on the computer running RDP is working again, but only after a looooooong hourglass - at least 20 seconds).

We noticed something else that may provide the ultimate clue. When the Win2K3 server is restarted, we get a message that pops up from the systray region that complains that "terminal services needs to contact a TS licensing server" and threatens that after "(32) more days TS will cease to function."

This is interesting. A few months ago, we had experimented with switching the lisc mode of TS from the "free" two simultaneous users to the full mode. We then switched it back - or thought we had. This might have triggered the original problem with RDP local resources, that re-install of TS helped a bit.

Your comments and results of your tests will be most appreciated. We are not Windoze gurus; most of our servers are FreeBSD or SUSE linux.

Thanks,

$teve
January 25, 2007 4:10:16 PM

Yep, we found our problem. It had to do with a registry entry that our server provider decided not to tell anyone about.

Here's their answer!
=====================
Sorry about the wait here. The change was made within our default kick for the Windows 2003 server. It was implemented to disable Printer redirects. There is a key called 'fEnablePrintRDR'. Mapping directly creates a tunnel network between the server itself and your machine. Thus, although you did not see the drives map inside "My Computer", you could have browsed to '\\tsclient' and viewed all of the mapped drives. When I changed the value in the registry, it enabled an auto-mapping that creates "virtual drives" mapping your drives to server drive letters. The Key is located in the following path via RegEdit:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\Wds\rdpwd]

The value of this DWORD was changed to 1.

=============


Oh, so change the printer setting to get local drives to work.... that was obvious! [ just a little sarcasm... :)  ]


We are running Centos on our servers so this to is a new experience for us.

good luck!
!