Sign in with
Sign up | Sign in
Your question

Cant open .exe files in Windows 7 64-bit?

Tags:
Last response: in Windows 7
Share
March 20, 2011 8:21:51 PM

Everything was running fine, and all of a sudden I can not open .exe files unless i run them as an administrator. When I try to run them, the cursor does its 'loading' thing and then nothing open on the screen. I check processes under task manager and the program is open, but is not on my taskbar, or open anywhere on my screen. This is happening to about 90% of my programs.

This is the second time I have had this problem. I had it before, and I did a clean re-install of windows 7 64-bit, and it happened again.

I have tried multiple fixes, and nothing has worked so far.

Does anyone know how to fix this? I can post system specs if needed.




So I figured it out I belive. The driver for my Asus Xonar D2X sound card is what looks to be the culprit. I have no idea why and now I have to find a way to install the driver so I can use my card without this happening again.
a b $ Windows 7
March 20, 2011 8:58:04 PM

You got a virus.
m
0
l
Related resources
March 20, 2011 9:03:37 PM

daship said:
You got a virus.



As I said...I just reinstalled. As in less than 4 hrs ago.

And I already have antivirus installed and have scanned, and it reports nothing.
m
0
l
March 20, 2011 11:24:35 PM

What version of Windows 7 you got?What are your security software?
Are you admin?
Where did you get the os from?
m
0
l
March 21, 2011 12:17:28 AM

Quote:
yes. Right click on the exe file then choose run as admin



Congrats. You apparently didnt read the op. I do not want to have to either set permissions for ever single .exe, or manually have to run them as admin every time i want to open them.

This is what I am trying to stop happening
m
0
l
March 21, 2011 12:19:22 AM

damian86 said:
What version of Windows 7 you got?What are your security software?
Are you admin?
Where did you get the os from?



Windows 7 Professional 64-bit.

Norton and Spybot S&D

And memory express.
m
0
l
March 21, 2011 5:17:08 AM

Quote:
Just type UAC into the start menu or Control Panel search box.
You can simply drag the slider up or down, depending how much you want to be bothered.
If you drag it all the way down to the bottom, you’ll have disabled it entirely.

But disabling it completely its your funeral



Already did it. Its second from bottom. Although Im not too worried with the firewalls im behind. (hardware, not software). And yes firewalls, as in 3.

But I am not just trying to jerry rig a temporary fix, I am trying to solve the problem, and in doing so, making my life easier and learning about how to fix this problem in the future.
m
0
l
March 21, 2011 1:43:28 PM

Cmon, and UAC doesnt protect anyone from anything.... it might slow down my grandmother from installing malware, but only for the time for her to say do it anyways... personally I have UAC off and dont get viruses or malware...

Whats weird is this has happened twice... This makes me think you are doing something. Try setting UAC to 0 just to see if it helps or not...
Is it possible to rollback to that point in time with Restore? Otherwise do another reinstall and pay close attention to when it changes and what you are doing..
m
0
l
August 7, 2013 12:32:36 PM

1.open command prompt
2.type in "cd\windows" press enter
3.type "regedit" press enter.
once you do that the registery editor will open.
4.press on HKEY_CLASSES_ROOT
5. click on defult
6. where it says value, type "exefile" that worked for me its that simple! hope i helped someone out
m
0
l
!