Help wanted from a registry guru

Archived from groups: microsoft.public.win95.general.discussion (More info?)

I have a niggling problem with opening files from Explorer (Win95). When I
right click on a file of a type which hasn't been associated with a program
(e.g. Default.cfg), Explorer opens a pop-up window with Open With... in bold
as the first option. Selecting this opens another pop-up window entitled
Open With which lists all the available programs. If I choose Winword (and
uncheck Always use this program to open this file) the file isn't opened if
the filename/path contains a space character. Word treats each part of the
filename/path separated by a space character as a separate file name. For
example when I try to open C:\Program Files\Proxomitron\Default.cfg, Word
reports if can't open C:\Program.doc and then reports that it can't open
Files\Proxomitron\Default.cfg. If I copy Default.cfg to the root directory
and try opening it from Explorer using Winword the file is opened OK. Excel
behaves in the same way. EVERYTHING else appears to work normally.

I don't know when the problem arose because I can't remember using this
feature before. I suspect a registry problem. It may have happened some
years ago when Office 95 was upgraded to Office 97. Does anyone know which
keys need to be changed or added to fix this problem?

I have also noticed that the registry if full of references to a C:\Msoffice
directory that was deleted after the upgrade to Office 97. Neither RegClean
or RegCleaner find or fix these errors. Is there a good registry guide that
explains how to get all this junk out of the registry?

Thanks in anticipation.
7 answers Last reply
More about help wanted registry guru
  1. Archived from groups: microsoft.public.win95.general.discussion (More info?)

    You do not need to use the Registry to correct poor file type
    associations. Use Explorer-View-Folder Options-File Types instead.
    The problem is probably occurring because you are using Open With for
    complex associations like Word instead of File Types.
    It is not a Registry problem.

    Your problem with files is caused by a poor association not
    accounting for spaces.
    Explorer-View-Folder Options-File Types
    Find the association.
    Edit, highlight Open, Edit again and put a space and "%1" (including
    the quotation marks) in the application so it looks like this
    (correct the path to yours)

    "C:\Program Files\Microsoft Office\Office\WINWORD.EXE" "%1"

    As to Registry cleaners...
    I suggest at this stage you ignore the invalid references as the
    danger of error in correcting them is hardly worth it if they are
    doing no harm.
    Regclean does not fix errors or all invalid references as it only
    works on one major Registry key.
    Others may suggest Registry cleaners for you to use. I will not.

    ....Alan
    --
    Alan Edwards, MS MVP W95/98 Systems
    http://dts-l.org/index.html

    In microsoft.public.win95.general.discussion, "Charlie"
    <noname@isp.com> wrote:

    >I have a niggling problem with opening files from Explorer (Win95). When I
    >right click on a file of a type which hasn't been associated with a program
    >(e.g. Default.cfg), Explorer opens a pop-up window with Open With... in bold
    >as the first option. Selecting this opens another pop-up window entitled
    >Open With which lists all the available programs. If I choose Winword (and
    >uncheck Always use this program to open this file) the file isn't opened if
    >the filename/path contains a space character. Word treats each part of the
    >filename/path separated by a space character as a separate file name. For
    >example when I try to open C:\Program Files\Proxomitron\Default.cfg, Word
    >reports if can't open C:\Program.doc and then reports that it can't open
    >Files\Proxomitron\Default.cfg. If I copy Default.cfg to the root directory
    >and try opening it from Explorer using Winword the file is opened OK. Excel
    >behaves in the same way. EVERYTHING else appears to work normally.
    >
    >I don't know when the problem arose because I can't remember using this
    >feature before. I suspect a registry problem. It may have happened some
    >years ago when Office 95 was upgraded to Office 97. Does anyone know which
    >keys need to be changed or added to fix this problem?
    >
    >I have also noticed that the registry if full of references to a C:\Msoffice
    >directory that was deleted after the upgrade to Office 97. Neither RegClean
    >or RegCleaner find or fix these errors. Is there a good registry guide that
    >explains how to get all this junk out of the registry?
    >
    >Thanks in anticipation.
    >
    >
  2. Archived from groups: microsoft.public.win95.general.discussion (More info?)

    Alan,
    Thanks for the feedback. I simplified my query as it was long enough as it
    was. I actually have two old Windows 95 PCs - a "clean" PC that I use for
    work and only have loaded with tried and tested standard office software and
    a "dirty" PC that I use for web browsing and evaluating downloaded software.
    Neither has a file association set for .cfg files and I don't want to set
    one as only some the .cfg files are text. However the first PC quite
    happily opens .cfg with Word and other files with long filenames that
    include spaces via the Explorer "Open With.." option. It is only the second
    PC shows the problem. I assume that somewhere in the registry there is (or
    should be) a key that defines how Open With... works and there is a subtle
    difference between the two PCs - with perhaps the first PC using "%1" whilst
    the second uses simply %1. I can't find any difference in the set up of the
    two PCs and was hoping someone could point me in the right direction. If
    not I'll just live with the idiosyncrasy.
    Charlie


    "Alan Edwards" <edwards@southcom.com.au> wrote in message
    news:jdr290dd0povjfn6c4cfq9j2q6eppfhb1r@4ax.com...
    You do not need to use the Registry to correct poor file type
    associations. Use Explorer-View-Folder Options-File Types instead.
    The problem is probably occurring because you are using Open With for
    complex associations like Word instead of File Types.
    It is not a Registry problem.

    Your problem with files is caused by a poor association not
    accounting for spaces.
    Explorer-View-Folder Options-File Types
    Find the association.
    Edit, highlight Open, Edit again and put a space and "%1" (including
    the quotation marks) in the application so it looks like this
    (correct the path to yours)

    "C:\Program Files\Microsoft Office\Office\WINWORD.EXE" "%1"

    As to Registry cleaners...
    I suggest at this stage you ignore the invalid references as the
    danger of error in correcting them is hardly worth it if they are
    doing no harm.
    Regclean does not fix errors or all invalid references as it only
    works on one major Registry key.
    Others may suggest Registry cleaners for you to use. I will not.

    ....Alan
    --
    Alan Edwards, MS MVP W95/98 Systems
    http://dts-l.org/index.html

    In microsoft.public.win95.general.discussion, "Charlie"
    <noname@isp.com> wrote:

    >I have a niggling problem with opening files from Explorer (Win95). When I
    >right click on a file of a type which hasn't been associated with a program
    >(e.g. Default.cfg), Explorer opens a pop-up window with Open With... in
    bold
    >as the first option. Selecting this opens another pop-up window entitled
    >Open With which lists all the available programs. If I choose Winword (and
    >uncheck Always use this program to open this file) the file isn't opened if
    >the filename/path contains a space character. Word treats each part of the
    >filename/path separated by a space character as a separate file name. For
    >example when I try to open C:\Program Files\Proxomitron\Default.cfg, Word
    >reports if can't open C:\Program.doc and then reports that it can't open
    >Files\Proxomitron\Default.cfg. If I copy Default.cfg to the root directory
    >and try opening it from Explorer using Winword the file is opened OK.
    Excel
    >behaves in the same way. EVERYTHING else appears to work normally.
    >
    >I don't know when the problem arose because I can't remember using this
    >feature before. I suspect a registry problem. It may have happened some
    >years ago when Office 95 was upgraded to Office 97. Does anyone know which
    >keys need to be changed or added to fix this problem?
    >
    >I have also noticed that the registry if full of references to a
    C:\Msoffice
    >directory that was deleted after the upgrade to Office 97. Neither
    RegClean
    >or RegCleaner find or fix these errors. Is there a good registry guide
    that
    >explains how to get all this junk out of the registry?
    >
    >Thanks in anticipation.
    >
    >
  3. Archived from groups: microsoft.public.win95.general.discussion (More info?)

    Alan has pointed you to the solution - it is the "%1" (with quotes) in the
    open action for the filetype associated with Winword. Yours is either
    "C:\Program Files\Microsoft Office\Office\WINWORD.EXE" %1
    or it is simply
    "C:\Program Files\Microsoft Office\Office\WINWORD.EXE"
    (with the path changed as applicable). Although this value is stored in the
    registry, it is accessed from an Explorer window using View / Options / File
    types. Select the file type associated with Winword (probably Microsoft Word
    Document), choose Edit, select the open action, choose Edit and change the
    "Application used to perform action" entry as suggested.
    --
    Jeff Richards
    MS MVP W95/W98
    "Charlie" <noname@isp.com> wrote in message
    news:OaefDWjLEHA.1032@tk2msftngp13.phx.gbl...
    > Alan,
    > Thanks for the feedback. I simplified my query as it was long enough as
    it
    > was. I actually have two old Windows 95 PCs - a "clean" PC that I use for
    > work and only have loaded with tried and tested standard office software
    and
    > a "dirty" PC that I use for web browsing and evaluating downloaded
    software.
    > Neither has a file association set for .cfg files and I don't want to set
    > one as only some the .cfg files are text. However the first PC quite
    > happily opens .cfg with Word and other files with long filenames that
    > include spaces via the Explorer "Open With.." option. It is only the
    second
    > PC shows the problem. I assume that somewhere in the registry there is
    (or
    > should be) a key that defines how Open With... works and there is a
    subtle
    > difference between the two PCs - with perhaps the first PC using "%1"
    whilst
    > the second uses simply %1. I can't find any difference in the set up of
    the
    > two PCs and was hoping someone could point me in the right direction. If
    > not I'll just live with the idiosyncrasy.
    > Charlie
  4. Archived from groups: microsoft.public.win95.general.discussion (More info?)

    I see what you mean. You only want a temporary Open and not a
    permanent association. Why not skip the Open With and set up a
    shortcut to Word (or whatever text editor you like) in the
    Windows\SendTo folder so you can use a right-click and use Send To to
    open any file with that editor?

    ....Alan

    --
    Alan Edwards, MS MVP W95/98 Systems
    http://dts-l.org/index.html

    In microsoft.public.win95.general.discussion, "Charlie"
    <noname@isp.com> wrote:

    >Alan,
    >Thanks for the feedback. I simplified my query as it was long enough as it
    >was. I actually have two old Windows 95 PCs - a "clean" PC that I use for
    >work and only have loaded with tried and tested standard office software and
    >a "dirty" PC that I use for web browsing and evaluating downloaded software.
    >Neither has a file association set for .cfg files and I don't want to set
    >one as only some the .cfg files are text. However the first PC quite
    >happily opens .cfg with Word and other files with long filenames that
    >include spaces via the Explorer "Open With.." option. It is only the second
    >PC shows the problem. I assume that somewhere in the registry there is (or
    >should be) a key that defines how Open With... works and there is a subtle
    >difference between the two PCs - with perhaps the first PC using "%1" whilst
    >the second uses simply %1. I can't find any difference in the set up of the
    >two PCs and was hoping someone could point me in the right direction. If
    >not I'll just live with the idiosyncrasy.
    >Charlie
    >
    >
    >"Alan Edwards" <edwards@southcom.com.au> wrote in message
    >news:jdr290dd0povjfn6c4cfq9j2q6eppfhb1r@4ax.com...
    >You do not need to use the Registry to correct poor file type
    >associations. Use Explorer-View-Folder Options-File Types instead.
    >The problem is probably occurring because you are using Open With for
    >complex associations like Word instead of File Types.
    >It is not a Registry problem.
    >
    >Your problem with files is caused by a poor association not
    >accounting for spaces.
    >Explorer-View-Folder Options-File Types
    >Find the association.
    >Edit, highlight Open, Edit again and put a space and "%1" (including
    >the quotation marks) in the application so it looks like this
    >(correct the path to yours)
    >
    >"C:\Program Files\Microsoft Office\Office\WINWORD.EXE" "%1"
    >
    >As to Registry cleaners...
    >I suggest at this stage you ignore the invalid references as the
    >danger of error in correcting them is hardly worth it if they are
    >doing no harm.
    >Regclean does not fix errors or all invalid references as it only
    >works on one major Registry key.
    >Others may suggest Registry cleaners for you to use. I will not.
    >
    >...Alan
  5. Archived from groups: microsoft.public.win95.general.discussion (More info?)

    Jeff,
    Thanks for the suggestion. That appears to have fixed it. I don't
    understand why changing the file association details for a .doc file should
    fix a problem opening .cfg files that don't have an associated program - but
    it apparently does. Strange!
    Charlie

    "Jeff Richards" <JRichards@msn.com.au> wrote in message
    news:OUMDPGkLEHA.1144@TK2MSFTNGP12.phx.gbl...
    Alan has pointed you to the solution - it is the "%1" (with quotes) in the
    open action for the filetype associated with Winword. Yours is either
    "C:\Program Files\Microsoft Office\Office\WINWORD.EXE" %1
    or it is simply
    "C:\Program Files\Microsoft Office\Office\WINWORD.EXE"
    (with the path changed as applicable). Although this value is stored in the
    registry, it is accessed from an Explorer window using View / Options / File
    types. Select the file type associated with Winword (probably Microsoft Word
    Document), choose Edit, select the open action, choose Edit and change the
    "Application used to perform action" entry as suggested.
    --
    Jeff Richards
    MS MVP W95/W98
    "Charlie" <noname@isp.com> wrote in message
    news:OaefDWjLEHA.1032@tk2msftngp13.phx.gbl...
    > Alan,
    > Thanks for the feedback. I simplified my query as it was long enough as
    it
    > was. I actually have two old Windows 95 PCs - a "clean" PC that I use for
    > work and only have loaded with tried and tested standard office software
    and
    > a "dirty" PC that I use for web browsing and evaluating downloaded
    software.
    > Neither has a file association set for .cfg files and I don't want to set
    > one as only some the .cfg files are text. However the first PC quite
    > happily opens .cfg with Word and other files with long filenames that
    > include spaces via the Explorer "Open With.." option. It is only the
    second
    > PC shows the problem. I assume that somewhere in the registry there is
    (or
    > should be) a key that defines how Open With... works and there is a
    subtle
    > difference between the two PCs - with perhaps the first PC using "%1"
    whilst
    > the second uses simply %1. I can't find any difference in the set up of
    the
    > two PCs and was hoping someone could point me in the right direction. If
    > not I'll just live with the idiosyncrasy.
    > Charlie
  6. Archived from groups: microsoft.public.win95.general.discussion (More info?)

    On Thu, 29 Apr 2004 16:42:59 +0100, "Charlie" <noname@isp.com> wrote:

    >I have a niggling problem with opening files from Explorer (Win95). When I
    >right click on a file of a type which hasn't been associated with a program
    >(e.g. Default.cfg), Explorer opens a pop-up window with Open With... in bold
    >as the first option. Selecting this opens another pop-up window entitled
    >Open With which lists all the available programs. If I choose Winword (and
    >uncheck Always use this program to open this file) the file isn't opened if
    >the filename/path contains a space character. Word treats each part of the
    >filename/path separated by a space character as a separate file name. For
    >example when I try to open C:\Program Files\Proxomitron\Default.cfg, Word
    >reports if can't open C:\Program.doc and then reports that it can't open
    >Files\Proxomitron\Default.cfg. If I copy Default.cfg to the root directory
    >and try opening it from Explorer using Winword the file is opened OK. Excel
    >behaves in the same way. EVERYTHING else appears to work normally.

    That's a common issue. Some parsers will break parameters when spaces
    are encountered, as per original DOS-era command line parameter syntax
    rules. Others expect one parameter and grab everything as such, or
    add thier own quotes around what's provided (and thus fail if the
    parameter is already in quotes).

    The issue here is that info in the registry is interpreted by whatever
    queries the registry. There may be a standard syntax in
    HKEY_CLASSES_ROOT behind simple and DDE file associations, but the
    program that receives the parameters may parse differently.

    For example, Paint Shop Pro needs quotes, while LView Pro (or is it
    IView) will fail if extra quotes are added.

    The quotes may be needed around the program command and/or the
    parameter. A %1 parameter is assumed if none is set in the command
    line within HKCR, but you can add an explicit "%1" to force quotes.

    Things get more difficult with Open With, because the command line is
    being created on the fly - so you can't preset it. There's an HKCR
    entry for "Unknown" that has this as the command line...

    C:\WIN98\rundll32.exe shell32.dll,OpenAs_RunDLL %1

    ....so you could change that to...

    C:\WIN98\rundll32.exe shell32.dll,OpenAs_RunDLL "%1"

    ....in the hope this will pass to WinWord.exe correctly. Or you could
    add a shortcut to WinWord to the SendTo folder and send things to it
    that way - which I don't like, as binary files may be corrupted.

    >I have also noticed that the registry if full of references to a C:\Msoffice
    >directory that was deleted after the upgrade to Office 97. Neither RegClean
    >or RegCleaner find or fix these errors. Is there a good registry guide that
    >explains how to get all this junk out of the registry?

    MS Office adds a ton of stuff to the registry, and it's quite brittle
    and geeky stuff too - I wouldn't pick a fight with it :-(


    >-------------------- ----- ---- --- -- - - - -
    Tip Of The Day:
    To disable the 'Tip of the Day' feature...
    >-------------------- ----- ---- --- -- - - - -
  7. Archived from groups: microsoft.public.win95.general.discussion (More info?)

    Thanks for letting us know that you got it sorted out.

    When you select the item from the Open With list, you are telling the system
    to use that file association, even though the filename extension doesn't
    match.
    --
    Jeff Richards
    MS MVP W95/W98
    "Charlie" <noname@isp.com> wrote in message
    news:%23JLpPWvLEHA.1272@tk2msftngp13.phx.gbl...
    > Jeff,
    > Thanks for the suggestion. That appears to have fixed it. I don't
    > understand why changing the file association details for a .doc file
    should
    > fix a problem opening .cfg files that don't have an associated program -
    but
    > it apparently does. Strange!
    > Charlie
Ask a new question

Read More

Windows