Sign in with
Sign up | Sign in
Your question

Problem Sending Mail with Inbox

Last response: in Cell Phones & Smartphones
Share
Anonymous
September 12, 2004 2:31:01 PM

Archived from groups: microsoft.public.pocketpc (More info?)

Hi all,

I'm trying to use an SMTP server which requires authorization and TLS
to relay mail. The server is running on one of my Linux boxes, so I
have full control. The problem is, Inbox refuses to use EHLO and AUTH
LOGIN after STARTTLS. In the account setup I have checked "Outgoing
e-mail server requires authentication" and "Require SSL
connection". By running a network sniffer I have been able to dump the
SMTP traffic and it looks like this:

220 <my server> ESMTP Exim 3.35 #1 Sun, 12 Sep 2004 09:48:57 +0200
EHLO Inbox
250-<my server> Hello Inbox [217.213.128.30]
250-SIZE
250-PIPELINING
250-STARTTLS
250 HELP
STARTTLS
220 OpenSSL/0.9.6beta go ahead
--- ENCRYPTED DATA START ---
MAIL FROM:
<my email addr>
250 <my email addr> is syntactically correct
RCPT TO:
<some other email addr>
550 relaying to <some other email addr> prohibited by administrator
QUIT
221 <my server> closing connection
--- ENCRYPTED DATA END ---

The problem here is that after STARTTLS there should come another EHLO
so that Inbox sees that "AUTH LOGIN" is available, instead of just
going ahead with "MAIL FROM".

The same thing works fine from Outlook on my desktop. It looks like
this:

220 <my server> ESMTP Exim 3.35 #1 Sun, 12 Sep 2004 10:12:57 +0200
EHLO johanspc
250-<my server> Hello johanspc [192.168.1.2]
250-SIZE
250-PIPELINING
250-STARTTLS
250 HELP
STARTTLS
220 OpenSSL/0.9.6beta go ahead
--- ENCRYPTED DATA START ---
EHLO johanspc
250-<my server> Hello johanspc [192.168.1.2]
250-SIZE
250-PIPELINING
250-AUTH LOGIN
250 HELP
AUTH LOGIN
334 <some base64 data>
<some base64 data>
334 <some base64 data>
<some base64 data>
235 Authentication succeeded
MAIL FROM: <my email addr>
250 <my email addr> is syntactically correct
RCPT TO: <some other email addr>
250 <some other email addr> verified
DATA
354 Enter message, ending with "." on a line by itself

etc.

--- ENCRYPTED DATA END ---


So it works with desktop Outlook, but not with PPC Inbox. Any idea
what the problem could be here?


Johan
Anonymous
September 12, 2004 3:46:43 PM

Archived from groups: microsoft.public.pocketpc (More info?)

Is it possible that your Username/Password for the SMTP server is not the
same as the Username/Password for the POP3? The PPC doesn't know how to
handle this situation....

--
Helio Diamant - MS/MVP Mobile Devices
http://www.pocketpcfreak.com


"Johan Parin" <johan.parin@abc.se> wrote in message
news:84hdq37ut6.fsf@johanspc.jparin.org...
>
> Hi all,
>
> I'm trying to use an SMTP server which requires authorization and TLS
> to relay mail. The server is running on one of my Linux boxes, so I
> have full control. The problem is, Inbox refuses to use EHLO and AUTH
> LOGIN after STARTTLS. In the account setup I have checked "Outgoing
> e-mail server requires authentication" and "Require SSL
> connection". By running a network sniffer I have been able to dump the
> SMTP traffic and it looks like this:
>
> 220 <my server> ESMTP Exim 3.35 #1 Sun, 12 Sep 2004 09:48:57 +0200
> EHLO Inbox
> 250-<my server> Hello Inbox [217.213.128.30]
> 250-SIZE
> 250-PIPELINING
> 250-STARTTLS
> 250 HELP
> STARTTLS
> 220 OpenSSL/0.9.6beta go ahead
> --- ENCRYPTED DATA START ---
> MAIL FROM:
> <my email addr>
> 250 <my email addr> is syntactically correct
> RCPT TO:
> <some other email addr>
> 550 relaying to <some other email addr> prohibited by administrator
> QUIT
> 221 <my server> closing connection
> --- ENCRYPTED DATA END ---
>
> The problem here is that after STARTTLS there should come another EHLO
> so that Inbox sees that "AUTH LOGIN" is available, instead of just
> going ahead with "MAIL FROM".
>
> The same thing works fine from Outlook on my desktop. It looks like
> this:
>
> 220 <my server> ESMTP Exim 3.35 #1 Sun, 12 Sep 2004 10:12:57 +0200
> EHLO johanspc
> 250-<my server> Hello johanspc [192.168.1.2]
> 250-SIZE
> 250-PIPELINING
> 250-STARTTLS
> 250 HELP
> STARTTLS
> 220 OpenSSL/0.9.6beta go ahead
> --- ENCRYPTED DATA START ---
> EHLO johanspc
> 250-<my server> Hello johanspc [192.168.1.2]
> 250-SIZE
> 250-PIPELINING
> 250-AUTH LOGIN
> 250 HELP
> AUTH LOGIN
> 334 <some base64 data>
> <some base64 data>
> 334 <some base64 data>
> <some base64 data>
> 235 Authentication succeeded
> MAIL FROM: <my email addr>
> 250 <my email addr> is syntactically correct
> RCPT TO: <some other email addr>
> 250 <some other email addr> verified
> DATA
> 354 Enter message, ending with "." on a line by itself
>
> etc.
>
> --- ENCRYPTED DATA END ---
>
>
> So it works with desktop Outlook, but not with PPC Inbox. Any idea
> what the problem could be here?
>
>
> Johan
Anonymous
September 12, 2004 5:13:20 PM

Archived from groups: microsoft.public.pocketpc (More info?)

Helio Diamant writes:

Helio> Is it possible that your Username/Password for the SMTP
Helio> server is not the same as the Username/Password for the POP3?
Helio> The PPC doesn't know how to handle this situation....

No it's the same. And I'm using IMAP, not POP3.


Johan
!