Sign in with
Sign up | Sign in
Your question

3Com network adapter

Last response: in Windows 95/98/ME
Share
Anonymous
August 28, 2004 4:55:02 PM

Archived from groups: microsoft.public.win95.general.discussion (More info?)

I have a dual boot with XP and 95. My network Card was made and installed
after 95 so it doesn't have it in it's list of adapters. I used XP to find
out what the adapter is and downloaded and installed it on 95. buut whenever
I start 95 it says that adapter is not working properly or drivers are
missing. It works fine on XP. What should I do?

More about : 3com network adapter

Anonymous
August 28, 2004 8:45:45 PM

Archived from groups: microsoft.public.win95.general.discussion (More info?)

Did you download and install Windows 95 drivers, from the manufacturer's web site?
Tell us the name and model number of the Network card, and give us the link you used
to get the drivers.
--
Glen Ventura, MS MVP W95/98 Systems
http://dts-l.org/goodpost.htm

"Patrick" <Patrick@discussions.microsoft.com> wrote in message
news:7B48942F-B62F-457E-8E48-DB027CBE8BEF@microsoft.com...
> I have a dual boot with XP and 95. My network Card was made and installed
> after 95 so it doesn't have it in it's list of adapters. I used XP to find
> out what the adapter is and downloaded and installed it on 95. buut whenever
> I start 95 it says that adapter is not working properly or drivers are
> missing. It works fine on XP. What should I do?
Anonymous
August 28, 2004 8:45:46 PM

Archived from groups: microsoft.public.win95.general.discussion (More info?)

I don't know the model Number but it's a 3Com 3C918 Integrated Fast Ethernet
Controller (3C905B-TX Compatible)
I downloaded it from www. drivermagic.com
Can you help me I have been trying for weeks to get this to work?

"glee" wrote:

> Did you download and install Windows 95 drivers, from the manufacturer's web site?
> Tell us the name and model number of the Network card, and give us the link you used
> to get the drivers.
> --
> Glen Ventura, MS MVP W95/98 Systems
> http://dts-l.org/goodpost.htm
>
> "Patrick" <Patrick@discussions.microsoft.com> wrote in message
> news:7B48942F-B62F-457E-8E48-DB027CBE8BEF@microsoft.com...
> > I have a dual boot with XP and 95. My network Card was made and installed
> > after 95 so it doesn't have it in it's list of adapters. I used XP to find
> > out what the adapter is and downloaded and installed it on 95. buut whenever
> > I start 95 it says that adapter is not working properly or drivers are
> > missing. It works fine on XP. What should I do?
>
>
Related resources
Can't find your answer ? Ask !
Anonymous
August 28, 2004 8:45:47 PM

Archived from groups: microsoft.public.win95.general.discussion (More info?)

that is what 95 says all the drives for it haven't been loaded.

"Patrick" wrote:

> I don't know the model Number but it's a 3Com 3C918 Integrated Fast Ethernet
> Controller (3C905B-TX Compatible)
> I downloaded it from www. drivermagic.com
> Can you help me I have been trying for weeks to get this to work?
>
> "glee" wrote:
>
> > Did you download and install Windows 95 drivers, from the manufacturer's web site?
> > Tell us the name and model number of the Network card, and give us the link you used
> > to get the drivers.
> > --
> > Glen Ventura, MS MVP W95/98 Systems
> > http://dts-l.org/goodpost.htm
> >
> > "Patrick" <Patrick@discussions.microsoft.com> wrote in message
> > news:7B48942F-B62F-457E-8E48-DB027CBE8BEF@microsoft.com...
> > > I have a dual boot with XP and 95. My network Card was made and installed
> > > after 95 so it doesn't have it in it's list of adapters. I used XP to find
> > > out what the adapter is and downloaded and installed it on 95. buut whenever
> > > I start 95 it says that adapter is not working properly or drivers are
> > > missing. It works fine on XP. What should I do?
> >
> >
Anonymous
August 29, 2004 2:06:00 AM

Archived from groups: microsoft.public.win95.general.discussion (More info?)

Look in Device Manager under the Network Adapters category.
Does it show the NIC as "3Com 3C918 Integrated Fast Ethernet Controller (3C905B-TX
Compatible)" or "3Com EtherLink 10/100 PCI TX NIC (3C905B-TX)", or as something
else?

Does Device Manager show the NIC with a problem? Are there any devices listed in
the "Other" category in Device Manager? When you installed the NIC and booted to
Win98, the system must have detected the NIC....what did the NIC identify itself as,
in that "new hardware detected" box?

What procedure did you use to install the drivers in Win98, from the .zip file you
downloaded?

Assuming you have the right drivers downloaded, unzip them to a folder on your hard
drive, then remove the NIC from Device Manager, and restart in Safe Mode.

Open Device Manager in Safe Mode, remove all instances of any NIC and all items in
the "Other" category.

Restart in normal mode. Windows will detect the NIC....note what it identifies
itself as, by name. Point the installer to the folder where you unzipped the driver
files, and let it install the NIC again.
--
Glen Ventura, MS MVP W95/98 Systems
http://dts-l.org/goodpost.htm


"Patrick" <Patrick@discussions.microsoft.com> wrote in message
news:5A5655CC-2ADB-4857-935A-41293046AEE6@microsoft.com...
> I don't know the model Number but it's a 3Com 3C918 Integrated Fast Ethernet
> Controller (3C905B-TX Compatible)
> I downloaded it from www. drivermagic.com
> Can you help me I have been trying for weeks to get this to work?
>
> "glee" wrote:
>
> > Did you download and install Windows 95 drivers, from the manufacturer's web
site?
> > Tell us the name and model number of the Network card, and give us the link you
used
> > to get the drivers.
> > --
> > Glen Ventura, MS MVP W95/98 Systems
> > http://dts-l.org/goodpost.htm
> >
> > "Patrick" <Patrick@discussions.microsoft.com> wrote in message
> > news:7B48942F-B62F-457E-8E48-DB027CBE8BEF@microsoft.com...
> > > I have a dual boot with XP and 95. My network Card was made and installed
> > > after 95 so it doesn't have it in it's list of adapters. I used XP to find
> > > out what the adapter is and downloaded and installed it on 95. buut whenever
> > > I start 95 it says that adapter is not working properly or drivers are
> > > missing. It works fine on XP. What should I do?
> >
> >
!