file permissions

Archived from groups: microsoft.public.windowsxp.basics (More info?)

I haven't been able to change file permissions with XP. I have administrative
capabilities and when I select a file or folder and deselect Read-only, then
apply, I then choose Apply changes to this folder and subfolders. The menu
goes away with no warnings but when I check the folder or files again they
are still Read-only.
Thanks for any suggestions.
2 answers Last reply
More about file permissions
  1. Archived from groups: microsoft.public.windowsxp.basics (More info?)

    The problem is file ownership, as others have stated, the read only
    attribute for folders in XP is normal though you can change that attribute
    for individual files as opposed to folders. You can take ownership as
    follows:
    Note, file ownership and permissions supersede administrator rights. How
    you resolve it depends upon which version of XP you are running.

    XP-Home

    Unfortunately, XP Home using NTFS is essentially hard wired for "Simple File
    Sharing" at system level.

    However, you can set XP Home permissions in Safe Mode. Reboot, and start
    hitting F8, a menu should eventually appear and one of the
    options is Safe Mode. Select it. Note, it will ask for the administrator's
    password. This is not your administrator account, rather it is the
    machine's administrator account for which users are asked to create a
    password during setup.

    If you created no such password, when requested, leave blank and press
    enter.

    Open Explorer, go to Tools and Folder Options, on the view tab, scroll to
    the bottom of the list, if it shows "Enable Simple File Sharing" deselect it
    and click apply and ok. If it shows nothing or won't let you make a change,
    move on to the next step.

    Navigate to the files, right click, select properties, go to the Security
    tab, click advanced, go to the Owner tab and select the user that was logged
    on when you were refused permission to access the files. Click apply and
    ok. Close the properties box, reopen it, click add and type in the name of
    the user you just enabled. If you wish to set ownership for everything in
    the folder, at the bottom of the Owner tab is the following selection:
    "Replace owner on subcontainers and objects," select it as well.

    Once complete, you should be able to do what you wish with these files when
    you log back on as that user.

    XP-Pro

    If you have XP Pro, temporarily change the limited account to
    administrative. First, go to Windows Explorer, go to Tools, select Folder
    Options, go to the View tab and be sure "Use Simple File Sharing" is not
    selected. If it is, deselect it and click apply and ok.

    If you wish everything in a specific folder to be accessible to a user,
    right click the folder, select properties, go to the Security tab, click
    Advanced, go to the Owner tab,
    select the user you wish to have access, at the bottom of the box, you
    should see a check box for "Replace owner on subcontainers and objects,"
    place a check in the box and click apply and ok.

    The user should now be able to perform necessary functions on files in the
    folder even as a limited account. If not, make it an admin account again,
    right click the folder, select Properties, go to the Security tab and be
    sure the user is listed in the user list. If not, click add and type the
    user name in the appropriate box, be sure the user has all the necessary
    permissions checked in the permission list below the user list, click apply
    and ok.

    That should do it and allow whatever access you desire for that folder even
    in a limited account.


    --
    Michael Solomon MS-MVP
    Windows Shell/User
    Backup is a PC User's Best Friend
    DTS-L.Org: http://www.dts-l.org/

    "Michel" <test@test.com> wrote in message
    news:4D6B792D-6A47-45FE-B811-26857D7610B3@microsoft.com...
    >I haven't been able to change file permissions with XP. I have
    >administrative
    > capabilities and when I select a file or folder and deselect Read-only,
    > then
    > apply, I then choose Apply changes to this folder and subfolders. The menu
    > goes away with no warnings but when I check the folder or files again they
    > are still Read-only.
    > Thanks for any suggestions.
  2. Archived from groups: microsoft.public.windowsxp.basics (More info?)

    If you are referring to a green square in the selection box that is normal;
    folders always show it no matter what. The green box that appears does not
    mean read only; the way I understand it is that it means undetermined. A
    folder can contain many files and they aren't necessarily all read-only;
    some may be, others not. A green check box does mean read-only. When using
    the classic Windows visual style a greyed out checkmark appears instead. I
    think the whole thing is kind of pointless and confusing myself.

    The way I check folders is to open a command prompt and use the attrib
    command; for example:

    attrib /s /d c:\myfolder

    Hope that helps

    "Michel" <test@test.com> wrote in message
    news:4D6B792D-6A47-45FE-B811-26857D7610B3@microsoft.com...
    >I haven't been able to change file permissions with XP. I have
    >administrative
    > capabilities and when I select a file or folder and deselect Read-only,
    > then
    > apply, I then choose Apply changes to this folder and subfolders. The menu
    > goes away with no warnings but when I check the folder or files again they
    > are still Read-only.
    > Thanks for any suggestions.
Ask a new question

Read More

Read Only Permissions Windows XP