reading a Windows Cyrillic file in Notepad or Wordpad

Archived from groups: microsoft.public.windowsxp.basics (More info?)

I have a text file encoded as Windows Cyrillic. But it is always displayed
as Windows Western. On the Font dialog in Notepad, I selected Cyrillic
(with Courier New), both before and after going to the Open File dialog
(with ANSI encoding selected). I tried the same thing using the character
set selector in Wordpad (with Arial).

How do I get Notepad or Wordpad to display Windows Cyrillic text files
correctly?

Thanks,
Emilio
5 answers Last reply
More about reading windows cyrillic file notepad wordpad
  1. Archived from groups: microsoft.public.windowsxp.basics (More info?)

    The text file must be saved in Unicode format in order to keep the cyrillic
    characters. If it is saved in ANSI format they will be lost.

    "Emilio Echeverría" <spam@spam.com> wrote in message
    news:%23JjTpITiEHA.1512@TK2MSFTNGP10.phx.gbl...
    >I have a text file encoded as Windows Cyrillic. But it is always displayed
    > as Windows Western. On the Font dialog in Notepad, I selected Cyrillic
    > (with Courier New), both before and after going to the Open File dialog
    > (with ANSI encoding selected). I tried the same thing using the character
    > set selector in Wordpad (with Arial).
    >
    > How do I get Notepad or Wordpad to display Windows Cyrillic text files
    > correctly?
    >
    > Thanks,
    > Emilio
    >
    >
  2. Archived from groups: microsoft.public.windowsxp.basics (More info?)

    You are showing your ignorance, Thane, and making a nuisance of yourself.
    Now I'm going to have to re-post this question in hopes someone who knows
    what they're talking about will answer. Please do not reply to my re-post,
    Thane.

    Windows Cyrillic is an 8-bit code like ISO-8857-9, one character per byte,
    with the Cyrillic characters in the 0x80-0xff range, just as Windows Western
    and ISO-8857-1 use that area for letters with accents, umlauts, etc. If you
    go to the XP Character Map, it shows these encodings as well as the Unicode
    encodings.

    "Thane of Lochaber" <NONE> wrote in message
    news:e1Rh5LTiEHA.1040@TK2MSFTNGP09.phx.gbl...
    > The text file must be saved in Unicode format in order to keep the
    cyrillic
    > characters. If it is saved in ANSI format they will be lost.
    >
    > "Emilio Echeverría" <spam@spam.com> wrote in message
    > news:%23JjTpITiEHA.1512@TK2MSFTNGP10.phx.gbl...
    > >I have a text file encoded as Windows Cyrillic. But it is always
    displayed
    > > as Windows Western. On the Font dialog in Notepad, I selected Cyrillic
    > > (with Courier New), both before and after going to the Open File dialog
    > > (with ANSI encoding selected). I tried the same thing using the
    character
    > > set selector in Wordpad (with Arial).
    > >
    > > How do I get Notepad or Wordpad to display Windows Cyrillic text files
    > > correctly?
    > >
    > > Thanks,
    > > Emilio
    > >
    > >
    >
    >
  3. Archived from groups: microsoft.public.windowsxp.basics (More info?)

    What I was doing was trying to help you, which I regret doing now. I am
    wrong sometimes and if I have wasted your valuable time I'm very sorry.
    Don't worry though, this will be the last time I ever reply to any posts
    from you. As for you saying you have to re-post this that itself is a good
    example of ignorance. Go ahead if you like, perhaps someone else will be
    willing to help you despite your hateful attitude. Good luck with your
    documents.

    "Emilio Echeverría" <spam@spam.com> wrote in message
    news:eSufiYTiEHA.1656@TK2MSFTNGP09.phx.gbl...
    > You are showing your ignorance, Thane, and making a nuisance of yourself.
    > Now I'm going to have to re-post this question in hopes someone who knows
    > what they're talking about will answer. Please do not reply to my
    > re-post,
    > Thane.
    >
    > Windows Cyrillic is an 8-bit code like ISO-8857-9, one character per byte,
    > with the Cyrillic characters in the 0x80-0xff range, just as Windows
    > Western
    > and ISO-8857-1 use that area for letters with accents, umlauts, etc. If
    > you
    > go to the XP Character Map, it shows these encodings as well as the
    > Unicode
    > encodings.
    >
    > "Thane of Lochaber" <NONE> wrote in message
    > news:e1Rh5LTiEHA.1040@TK2MSFTNGP09.phx.gbl...
    >> The text file must be saved in Unicode format in order to keep the
    > cyrillic
    >> characters. If it is saved in ANSI format they will be lost.
    >>
    >> "Emilio Echeverría" <spam@spam.com> wrote in message
    >> news:%23JjTpITiEHA.1512@TK2MSFTNGP10.phx.gbl...
    >> >I have a text file encoded as Windows Cyrillic. But it is always
    > displayed
    >> > as Windows Western. On the Font dialog in Notepad, I selected Cyrillic
    >> > (with Courier New), both before and after going to the Open File dialog
    >> > (with ANSI encoding selected). I tried the same thing using the
    > character
    >> > set selector in Wordpad (with Arial).
    >> >
    >> > How do I get Notepad or Wordpad to display Windows Cyrillic text files
    >> > correctly?
    >> >
    >> > Thanks,
    >> > Emilio
    >> >
    >> >
    >>
    >>
    >
    >
  4. Archived from groups: microsoft.public.windowsxp.basics (More info?)

    Hello!

    "Emilio Echeverría" <spam@spam.com> wrote in message news:<#JjTpITiEHA.1512@TK2MSFTNGP10.phx.gbl>...
    > I have a text file encoded as Windows Cyrillic. But it is always displayed
    > as Windows Western. On the Font dialog in Notepad, I selected Cyrillic
    > (with Courier New), both before and after going to the Open File dialog
    > (with ANSI encoding selected). I tried the same thing using the character
    > set selector in Wordpad (with Arial).
    >
    > How do I get Notepad or Wordpad to display Windows Cyrillic text files
    > correctly?
    >

    Both are Unicode programs now (unlike Windows 95 times) and
    both are _bad_ choice of reading Cyrillic text
    (it still can be done, but with some tricks):

    No need to change your system settings.

    1) The best choice is a NON-Unicode plain text editor - there are
    many of them on shareware.com or on tucowes.com
    I use http://UltraEdit.com
    In such editor, because it's a non-Unicode program you _can_
    choose say "Courier New" then choose "Script=Cyrillic" and
    work with Cyrillic text files normally

    2) Second choice is MS Word ver. 2000 and higher
    There you can _explicitely_ specify the encoding of your
    text file and thus it will work Ok - please see the instruction
    in the "Unicode and Cyrillic" section of my site. But here is
    the direct link:
    http://ourworld.compuserve.com/homepages/PaulGor/cp_e.htm#open

    3) In Notepad, you can do that with a trick - you can use, instead
    of standard Unicode fonts of your system such as "Arial" or
    "Courier new" another font, old Cyrillic font, non-Unicode one
    made for Windows 3.1 - just choose it in Notepad's menu

    There are a lot of such fonts, you can download say
    "ER Kurier 1251" from my site:
    http://ourworld.compuserve.com/homepages/PaulGor/fonts_e.htm#part12

    If it still does not work (I tried it long ago, so am not sure(
    then you need to modify such font first:
    see "Method _2_" here:
    http://ourworld.compuserve.com/homepages/PaulGor/word_r.htm#screen


    --
    Regards,
    Paul Gorodyansky
    "Cyrillic (Russian): instructions for Windows and Internet":
    http://RusWin.net
    Russian On-screen Keyboard: http://Kbd.RusWin.net
  5. Archived from groups: microsoft.public.windowsxp.basics (More info?)

    "David Candy" <david@mvps.org> wrote in message news:<uc$gLjViEHA.2400@tk2msftngp13.phx.gbl>...
    > ...
    > The encoding in File Open is unicode setting as programs have to guess
    > the encoding for unicode and can guess wrong as unicode has a two byte
    > header but someone may have an ANSI file with those two characters
    > first so it checks further and can guess wrong.

    No, there is no guessing in File/Open in Notepad -
    it just assumes, without any guessing, that the non-Unicode text
    belong to the system encoding - System Code Page - which is
    "Western, 1252" on Western machines. That is, ANSI in the
    Notepad menus is really "System Code Page", non-Unicode, legacy
    encoding.

    It's why - as you correectly pointed - one of the solutions could
    be (though, it would be an overhead) to change System Code Page -
    in Control Panel/Regional Options/Advanced -
    "Language for non-Unicode programs" (it's not really Language
    it's Code Page, encoding).

    --
    Regards,
    Paul Gorodyansky
    "Cyrillic (Russian): instructions for Windows and Internet":
    http://RusWin.net
    Russian On-screen Keyboard: http://Kbd.RusWin.net
Ask a new question

Read More

Notepad Microsoft Windows XP