Sign in with
Sign up | Sign in
Your question

hi bro, i can't update bios for my mb giga945g-pro

Last response: in Motherboards
Share
February 1, 2006 11:21:42 PM

i download the newest bios ver F9 on the vendor website. i use flashbios to update the new bios ver. but after i reboot, nothing appears on my screen... :oops:  ,beats me! :?: .after that i wait for about 15min, and push reset button. comp runs smothly again...????.
after that i try another test, i updated another time, and when it appeared dark screen, i turned it off. and pushed it on, in this time, nothing runs :!: ????
what the hell is going on in my pc??. is that called "dual bios" of gigabyte's....
help mememememememe 8O
thanks.
P.M: how can i update bios? because my bios's just only F7 ver.
February 17, 2006 8:34:27 AM

Regarding gigabyte website, there are 2 version of this mobo, rev 1.x and rev. 2.x. Make sure you have download the right bios for your mobo. Wrong version can make your mobo no boot. :( 
Try to clear cmos and after power on please wait for 1 or 2 minutes. Usually backup bios will take over main bios and boot the pc. After pc boot, enter the bios setup and go to bios menu and choose copy backup bios to main. Good Luck.


cheers
Chris.
February 17, 2006 8:54:29 AM

you used the @bios?
Related resources
February 18, 2006 11:19:10 AM

hello Christ,
thanks for your advice, but it's useless. because the bios in main page of gigabyte doesn't mention about the version of main board:
http://www.giga-byte.com/Motherboard/Support/BIOS/BIOS_...
So maybe u give me somemore advices??
and i couldnt find any information about version on my mainboard
thanks fo r your helps
February 20, 2006 1:04:50 AM

Sorry for my mistake, i'm look in GA-915g PRO bios. For your problem, does your mobo can display after 1 or 2 minutes after power on? If no, you must take your mobo to gigabyte RMA center. IF yes so you may copy backup bios to main bios from your bios menu.
February 20, 2006 9:00:50 AM

hi,
lastnight i downloaded new version bios of my mainboard: F10. because i 'd just bought a presler cpu, and reading on the vendor 's mainpage. It says about someproblem with oldbios if i update to presler. So I used @Bios software to update my main to F10( my current version of bios is F7). And after upadated, again i saw a black screen, nothing run. I have waited for 2 minutes, and after that i pressed reset button, my friend run again.... :?: ..
So i go to bios setup and using Q-flash/Dualbios utility (after press dellete). It said that my computer had Boot up from "Backup bios"" 8O , what 's that???.
how can i update now.......Please help me....! :?:
a b V Motherboard
February 20, 2006 8:41:55 PM

Last time I did this, I first pulled the battery for a couple of seconds, then booted up. It found the floppy with the new bios on it, I typed in the right stuff, and went on from there.
February 21, 2006 3:36:14 AM

Looklike your main bios problem. Maybe the bios chip is bad. When main bios problem, backup bios take over to boot system. DO you see "copy backup bios to main" menu? if yes, execute it. If success dont forget to set "Boot from main bios". And after restart dont forget go to bios and choose "load optimized default....setup",
Goodluck


christ
February 23, 2006 1:03:26 PM

I'm totaly a luckyless guy, I bought a dump mainboard and a suck bios....That are called "Dual bios".. :evil:  ...when i brought my main to service to upgrade my bios...they said they had no responsibility :twisted:
maybe i should try again, because i just flashed bios using "@bios" tool, maybe it 's totally unsafe to upgrade bios....this time i 'll buy a floppy disk to upgrade,,,,hopefully it works :cry: 
thanks...
February 27, 2006 5:30:30 PM

NEVER upgrade a mobo bios unless u must !!
May 12, 2006 8:11:17 PM

I have same problem when I updated my BIOS from F7 to F9 with @BIOS!!!
I updated both BIOSes and my mobo failed to boot at all then I returned it to reseller and they REFLASH it with F7 version.

After it I upgraded my BIOS to version F11 with a floppy by BIOS FLASH UTILITY 8) , and it worked well till I both a Sparkle 7900GT! :cry: 

After pluging my new VGA, MB didn't boot from my SATA RAID hdds and it started searching fot boot devices from LAN, CDD, FLOPPY and it failes to detect bootable partitons!

I noticed that GB made a system called BBS to search for all possible bootable devices and it makes booting a little longer!

I downgrade my BIOS to F8 and it is working well with my new VGA and SATA RAID hdd. but I still have problem with my hdd attached to IDE RAID controller! my windows which is installed on SATA RAID controller doesn't recognize the partitions on ATA RAID!

note : I don't have any problems with ONBOARD VGA (and without my new VGA)

What can I do to solve the problem?

(Sparkle said : cahnge power supply!!!!! 8O
Gigabyte said : Disable USB keyboard support!!!!! 8O )
May 13, 2006 10:58:09 PM

hello concunam2005 :) 


i think you got the same problem i had with my new gigabyte 955 royal motherboard

i bought the motherboard from the dealer and after using it for 1 week i decided to upgrade the bios

without reading any instructions i proceded with bios flash using @bios program provided in CD 8)

@bios downloaded the latest flash file and started flashing
then when it finished flashing it gave me a message saying flash succsfull and i need to reboot :) 

i restarted the computer and it showed me a black screen 8O

i switched it off from and tried 5 times to start it but it didnt

in the 6th attempt it started but i noticed it didnt upgrade :?

===============================

after booting my computer i decided to start the @bios again and do a 2nd flash attempt

guess what............ :roll:

after flashing the motherboard showed a black screen and stoped working
everithing will work inside the computer (cpu fan, lights) but it will keep showing ablack screen ....... :oops: 

after 3 days i decided to return the mainboard to the dealer
they asked me what did you do with it
i sayed " absoletly nothing"
after 5 days they called me and gave another one :D 
==========================================
after getting the new mainboard i decided to flash it using @bios hehehhe

but it stopped working looooooooool

i got a new one from them again (2nd motherboard replaced under warranty) .. REASON : black screen
=========================================
after investigating my self for the reason which stopped it working.. i found something intresting which maybe the MAIN REASON
1-i didnt DISABLE the HT feature in the mainboard settings
which is an important step before flashing using @bios :idea:

This is the only thing i can guess which made the problem
anyways i would try flashing using floppy and tell you what will happen

good luck
!