Sign in with
Sign up | Sign in
Your question
Solved

OSX Macbooks keep disconnecting from SMB Share

Last response: in Mac Os X
Share
August 2, 2012 5:49:21 AM

Hi Guys,

I'm having a little issue with my office network. We have a small network of 4 Windows 7 PC's and 2 Apple Macbooks pro running Snow leopard 10.6.8

We use to have an old server that was running Windows XP which was working great with all the computers. 2 weeks ago the server died, so instead of buying a new server I just moved the "Shared" folder (with all our files) to one of the Windows 7 PC's and made that our new server.

Everything has been working fine between the PC's, they have NO issue. But the macs refuse to stay connected. They'll connect fine and work Ok for a few hours, but eventually they will always disconnect and we'll have to restart them. We restart them several times a day and it's very annoying.

The windows 7 share is just a regular share with the "everyone" group getting full permissions (even though we connect with the Administrator account on the PC). I disable 128bit encryption, and enabled SMB file sharing on the macs, I disabled sleep and hibernation on all machines but it still disconnects.

Does anybody have any ideas to what could be causing this or what alternatives I can take?

Is there a way to start an AFP server on that Windows machine?
a b $ Windows 7
August 2, 2012 6:02:32 AM

IDK maybe the put hard disks to sleep when ever possible is checked in energy saver and then you get disconnected. It is checked by default so it sounds logical.
August 2, 2012 6:05:31 AM

Thanks, I checked it out. It's already set on NO sleep ever.
Related resources
a b $ Windows 7
August 2, 2012 6:16:35 AM

Bummer.
Thats all I got for now.
August 2, 2012 2:04:04 PM

Do you have any message when it disconnect?

What happen exactly when you try to connect again before restarting?
August 2, 2012 2:32:09 PM

yoaverez said:
Thanks, I checked it out. It's already set on NO sleep ever.


HDD sleep does not affect drive mounting. You should leave HDD sleep at say, 10-20 minutes so your hard drive motors doesn't prematurely wear out.

On a different topic, check the host windows 7 computer's network properties on the adapter that is used to connect to the network, I suspect LAN. Check to see if it has any power saving functions enabled on the LAN adapter, watch for obscure ones like disconnect link or downgrade to 10M while asleep or something similar. Then, try manually assigning an IP address to the win 7 computer (you probably have already done this).
August 6, 2012 3:00:04 PM

I was actually in the same boat as you for some time. I have a home network where i have 1 MBP running 10.6.8, and 2 PowerMacs running 10.5.6, with many other PCs, both wired and wireless with Widnows 7 and XP. Originally i was trying to setup a file server with Windows Server 2003, but my MBP just wouldn't pickup the machine over the network, but the PowerMacs did for some reason. After going back and forth and not getting anywhere, I ended up just converting one of the PowerMacs into Leopard Server and everything will stay connected to it without a problem.

Now i still do use one of my Windows 7 machines as a media server, in which i have a few shared folders, but, depending on how long the W7 tower is one for, wired into the router, after a few hours my Macs won't see or connect at all, and the only way i have found to fix it was to restart the W7 tower itself, now the Macs. I have tried restarting them, but that still didn't help.

So i really don't have a solution to your problem, but i wanted to let you know you're not the only one, i have been having the same issue, but i haven't found any fix to it unfortunately. All the Mac people it's a Windows problem and to replace all the PCs with Macs, which just isn't possible, and the PC users have given me some fixes top try, but they don't really have an effect.

Best solution

August 7, 2012 4:33:12 AM
Share

Check out this link:

http://alan.lamielle.net/2009/09/03/windows-7-nonpaged-...

It did solve the problem for me so far (crossing fingers).
August 13, 2012 7:23:43 PM

Best answer selected by yoaverez.
!