Problem with opening Catalyst Control Center DisplaysManager

8 answers Last reply
More about problem opening catalyst control center displaysmanager
  1. Have you tried the new Catlyst 6.2 drivers from the ati site?
  2. Yes :(
  3. I know its not a very inviting option for some people, but have you tried formatting your operating system drive? It might be something that was installed previously that is creating conflicts but i do not know for sure.

    Another option is to wait for an alternate set of drivers by omegadrivers or something, unless you are set on using the CCC. I personally dont like CCC and prefer the omegadrivers control panel.
  4. I doubt if this will work, but try reinstalling .Net.
  5. when i used catalyst i used dotnetfx 1.1 even though it said there was version 2.0 out... maybe try using 1.1
  6. use drive clenaer pro remove everything related with ati then reinstall

    if it doesn't help there is no way out but formatting
  7. Ok. I formated disc and reinstaled all... now everything works :) Huh... I hate to do that (to reinstal Virus XP)...
  8. Glad to hear that you got your problem fixed :D
Ask a new question

Read More

Radeon Runtime Catalyst Graphics