Sign in with
Sign up | Sign in
Your question

Having trouble installing Windows 7 to SSD

Last response: in Windows 7
Share
March 26, 2011 12:33:40 PM

Hello,

I am trying to install Windows 7 on a new Crucial C300 64GB SSD. I've tried many different ways to try and get it to work properly but I always end up with the same problem. It installs and gets to the point that says "completing installation" then it reboots. It goes through the various BIOS screens and gets to the Win7 boot logo like a normal startup would. After that it's just a blank screen. No cursor or anything. I have to hold the power button to turn it off, and I get the "windows did not shut down properly" screen when it reboots. Trying to boot it again brings it to the same blank screen after the boot logo.

I have tried to install two different copies at least 20 times now trying so many configurations. Here's what I've done:

Unplugged all other drives
Tried both IDE and AHCI modes
Updated drive firmware
updated BIOS
Tried two different copies of Windows 7
Installed from both the DVD and an external hard drive

The drive is a SATA III device, and says it is also SATA II compatible, which is what my motherboard supports.

At this point I don't know if it's my SSD or Windows or some other problem I'm not thinking of. I have installed Windows 7 numerous times before on this machine.

I appreciate any assistance.
March 26, 2011 4:26:59 PM

Turned out it wasn't the SSD at all. Apparently Windows 7 hangs if there are two monitors plugged in during installation... unbelievable.
m
0
l
May 22, 2013 11:44:36 PM

I'm having this exact same problem with Samsung 840 Pro and latest firmware released on may 2013. I don't have 2 monitors. tired AHCI and IDE and I can't complete Windows Install....
m
0
l
!