Sign in with
Sign up | Sign in
Your question

Need help getting a 2nd (slave) drive to work

Last response: in Storage
Share
February 20, 2006 9:44:32 PM

I recently bought a WD320 to suppliment my WD120 hard drive. I've physically installed the new drive and the computer sees it - sort of. It won't let me actually access it even tho it says it's there.

I'm running on a Gigabyte GA-7N400 mobo and I'm running Win2k. I've got the old hard drive on the end plug of the ribbon cable and the new drive on the middle plug. I've tried it with the new drive's jumper set to auto detect, and I've tried it with the jumper manually set to Slave. When I enter the Bios, the computer sees both drives - WDC WD120BB-00CAA1 and WDC WD3200JB-22KFA0. When I go to add/remove hardware and try to trouble shoot a device it also shows both drives, and says both drives are working properly.

Despite that, my C: drive only shows 111 GB total capacity, and there is no other Hard Drive listed at all. Can someone help me figure out what I've done wrong here? I've tried unplugging the old drive completely and just plugging in the new drive to see if it works. I get an error message basically saying there's no OS, so I assume that means the drive is good.

I would really appreciate any help anyone could give me on this.

-Dwarf

More about : 2nd slave drive work

February 20, 2006 10:48:36 PM

you have to partition it.

right click on my computer, select manage, disk management
the top part will show any volumes on your computer which will vary from computer to computer of course. I have 9 because I have 3 hard drives and linux installed as well as xp. Yours will probably only show drive c.

below that your will see disks labeled like Disk 0 Disk 1 Cd-Rom 0 etc
The new drive will most like still have NO volumes on it which is what you need to fix.
right click on it and make a new primary partition and format it.
Now you can use the new drive.
If you want it split up well thats another story and more complicated of course.
February 20, 2006 11:23:02 PM

Alright. I right-clicked on my computer, went to disk management. Disk 0 (the old drive) shows 111.78 gb NTFS. Disk 1 (the new drive) shows 55.36 gb Unallocated. Definately not the 320 gb drive I have. I right clicked on Disk 1 and selected Create Volume, but the most it will allow me to select for that disk is 56690mb (55.36gb). Am I doing something wrong, or is there something with Win2k that won't recognize the full 320gb?

-Dwarf
Related resources
February 20, 2006 11:50:02 PM

If you go into your bios does it show the full size of 320gb there ?
Cause it sounds like you might need a bios update.
February 21, 2006 2:05:52 AM

The Bios appears to show the drive size correctly.

I followed the suggestion of a friend of mine and unhooked the old drive and tried to do a fresh Win2k install on the new drive. Apparently Win2k is the problem - it only sees the drive as roughly 131gb. I guess there's a drive size-limit in Win2k. :(  It sees the TOTAL drive as 131gb, so I can't even partition it as 2 smaller drives to get around the Win2k limit.

Is anyone aware of a way to overcome this limit so that I can utilize the full 320gb of the drive?

-Dwarf
February 21, 2006 4:04:54 AM

Well, I finally figured it out. It was more than just needing initialized. Apparently despite having Win2k with SP4, I needed to make an adjustment in the registry to turn on Large Volume support or something like that. Once I made the registry change and rebooted my computer, Disk Management recognized 298 gb free on drive E:. More of a hassle than I expected, but it's finally resolved.

Thanks to everyone who offered advice and suggestions - it's much appreciated!!

-Dwarf
!