Sign in with
Sign up | Sign in
Your question

Harddrive USB versus IDE weirdness

Last response: in Storage
Share
February 21, 2006 5:36:54 PM

Hi all,
I haven't found anything here that describes some bizarre behaviour I've been experiencing lately with a hard drive of mine.

First of all it's an older Maxtor 80 GB (yeah, I know). I've used it internally as the main C drive in an older system before buying a new system at which time I put it into an external enclosure. Everything was fine before and after until about a week ago when it it simply stopped being recognized when plugged into any USB port.

Some symptoms:
1. As long as it is plugged into the USB port the system will not get past the Post on boot.
2. WinXP sp2 will recognize an "external storage device" if you plug it in after boot up but it will not allow access to the drive in any way, AND will not finish shut down as long as it's still plugged in.

Ok... so far it sounds like its having problems mounting and unmounting the filesystem, but I want to rule out that it's the USB and/or the enclosure at fault.

1. The problem drive does not work in any of my USB ports.
2. I have two other drives in external enclosures. Both work fine in the same USB port.
3. A good drive still works in the problem drive's enclosure.
4. The problem drives still fails to work in a good drive's enclosure.

Ok. I think that rules out the USB/enclosure as the source of the problem.

So next I take out the harddrive and plug it into the system internally as a secondary slave drive... works fine! Boots no problem. All files accessible.

Great! Reset the jumper back to cable select, put it back into the USB enclosure and tried it again. Still no dice, but this time WinXP doesn't recognize anything.. not even the usual "external storage device detected" message I would get before.

At this point I've decided to stop "experimenting" until I have a better idea what is going on. I've got a lot of data on that drive and nowhere else and don't want to risk ruining it beyond repair. During the successful boot when it was mounted internally I got most of it's contents copied, but I wasn't very thorough and left my financial records on it. Duh.

Has anyone experienced anything like this and/or know what the problem this drive is having with the enclosure? Keep in mind it has worked fine in the enclosure for almost a year now. This problem is completely out of the blue!

Any feedback is appreciated. Thanks.
February 22, 2006 4:00:19 AM

yes. i've experience this before and i know how to resolve it. however, i'm far to high to begin giving you instructions to fix it. i can barely type straight. every time i start a sentence it moves up and conflicts with the sentence above. anyways, i will be able to help tomorrow morning.

thanks

-mpjesse
February 23, 2006 1:14:27 AM

:lol: 
Best reply. Ever.
February 24, 2006 5:26:48 AM

Did a bit more testing with this half working drive and discovered some more interesting anomalies. The drive, if installed internally, will only work if the jumper is set to slave AND it is alone on its IDE controller. If it set as master, or put another drive as master on the same cable's there's not a peep from her. WinXP neither acknowledges the drive's existence nor reports any failure. If it is a single solitary slave then it seems to work just fine. In fact I used the opportunity to backup everything and then reformatted it, diskchecked, etc.. no problems.

At this point I don't trust the drive anymore. With almost 500 Gigs of hardrive space in my remaining 5 drives (and at only about 30% capacity), I'm not bitter... just kinda curious...

I would be interested in hearing any of mpjesse's insights though... you still flying? Hellooooooo... *throws dorito at him*
!