Sign in with
Sign up | Sign in
Your question

Windows 7 x64 Ultimate wireless connection problem

Last response: in Windows 7
Share
March 29, 2011 7:29:09 PM

Hello, I have a custom built computer running Windows 7 Ultimate 64bit as stated in the thread title. I've had this computer since November 2010. Up until recently no internet problems to speak of, however the last few days the internet has been a nightmare. However, before I get into the behavior I'll give you some relevant information.

Computer Specifications:
Processor: Intel i5 760
MotherBoard: Asus p7p55d - e
RAM: 2 x 2gb Kingston DDR3 (don't remember the timings, although I don't see how it could matter)
Video Card: Nvidia Geforce GT 240

The network adapter on the motherboard is a Realtek PCIe GBE Family Controller although I'm using a usb wireless device to access the network(Dlink DWA 125).

So the setup here is very basic, its a DSL connection, comes straight into the router/modem(Echolife HG520). Its all configured correctly and I would blame the router(because its getting on in age and not at all top of the line) except for the fact that my laptop running XP Pro SP3 has no internet connection issues whatsoever on the same network. It does have to pass through a cement/brick wall however the signal strength is ok and as I stated before my laptop has no connection issues.

So this is the basic behavior I experience on my Windows 7 machine. Every so often(random amount of time, never longer than 5 minutes) the windows 7 machine loses connection to the router. In some cases it loses the ability to see any wireless networks in this area whatsoever(there are 4, it never sees more than 2). After a minute or two it regains connection and repeats the whole proccess. Just from pinging the router I can see massive changes in response time. For instance in the last ping I received these response times:

316ms
2710ms
Request timed out.
2ms

Here are the things I've already tried:
I've tried resetting the router/restarting the computer.
I've tried changing the usb port that the usb wireless adapter was using (incase the port was failing).
I've tried using windows to search for newer drivers for the usb adapter, it said none were found. However I went to the dlink website and found a newer version, installed it and it didn't make a difference.
I've tried rebuilding the TCP/IP stack (which seemed to make it less horrible for at least a small while).
I've tried using the usb adapter on another computer, it is functional (even after I threw it across the room in a fit of rage lol).
I would have tried to system restore to a point before the issue began, but apparently it was too long ago(with all the driver uninstalls/installs).

An extra note, I did install some windows updates several days before the problems started, but I've looked at what they were for and they didn't involve the internet in anyway (usually directdraw or direct2d/3d). If no one has any other ideas I'll try uninstalling those updates.

Let me know if you have even the smallest idea what the problem could be.
a b $ Windows 7
March 29, 2011 7:36:18 PM

I know you said you tried it in another computer and it worked. How long did you test it on that other computer, what kind of test did you do, and what kind of OS was on that test computer?
March 29, 2011 11:02:56 PM

It was my laptop that has XP Pro SP3, I switched its built in wireless adapter off, plugged in the usb adapter from my win 7 machine, installed the drivers and surfed around on the web, facebook games etc etc. I don't remember exactly how long, although given how long the internet usually lasts I would imagine it was long enough. Anyways, I just tested it another time though for more than an hour and it never lost connection. This last time I tested it by downloading some files for work.

EDIT: Last night I got a windows update that miraculously included new drivers for both my usb device and the Realtek PCIe GBE Family Controller on the motherboard. I'm not sure if it was just coincidence or if something had been broken but since then it seems to be working ok, I'll post back here if that changes.
April 2, 2011 9:47:01 PM

Scratch the last edit I made, the new drivers from windows update worked for half a day or two, now the problem is back and bad as ever. Anyone have any more ideas?
!