Sign in with
Sign up | Sign in
Your question

Real head scratcher of a sound problem

Last response: in Components
Share
February 27, 2006 11:42:57 PM

If you like solving challenging problems, then this thread is for you. :) 

I recently purchased parts for a new system and built it over the weekend. Most things went well and I got the system up and running saturday evening.
By Sunday evening I loaded in my sound drivers and tested out my new soundcard. A Creative X-Fi platinum.
I tested it with headphones only since my speakers were in the other room. Late sunday night I decided to move the new system from the kitchen (where I do all my PC building) to my computer room.
I got it where I wanted it and first thing I did was hook up my speakers. That went well and I tested out all the speakers and everything worked. I listened to a few sample clips and then decided to listen to a cd while I did more optimization.
I turned the unit around since I was done hooking things up. As I was tweaking and loading software I had to restart.
Once I did so and came back I tried to listed to my cd again. Media player told me that no sound device was present.
I tried opening Creatives 'Console launcher' that comes in there cd software package.
Told me no supported audio device was present and did not open.
I went into device manager and found that my soundcard was being detected and had no problems.
I thought perhaps my soundcard was defective and I would have to RMA it. I went into my BIOS and switced on the sound device that came with my Asus MOBO.
I went back into Windows and loaded its drives and tried media player.
No joy :cry: 
I went into device manager and was told that the AC97 sound card was being detected and had no problems.
Hmm...
So I figured that the Creative card is fine (which is good) and that it must be some sort of Windows problem (which is bad)

I tried a restore point to basicly right after I loaded the Creative cards drivers. Did not work.
I tried it right before and then loaded them again. Same problem

I have tried basicly everything I know to try and get these cards to work. Nothing I do is seeming to work.

So I turn to you for help. I am willing to try anything and no suggestion is too trivial or too 'stupid'
I may be overlooking something small.

Thanks in advance for any help :) 
February 28, 2006 5:05:56 AM

I suggest a clean reinstall of Windows XP, or barring that, a motherboard replacement should that fail.
February 28, 2006 6:48:03 AM

Power down, remove AC pwr cable, etc

Remove the card.

Reboot twice.

Re-install the card in another slot.

Reboot once (maybe).

Boom, should work.
Related resources
February 28, 2006 8:17:08 AM

Firstly, are you getting the problem only with media player, or are you getting no sound at all in windows ? Also, is this problem only with the speakers, or with the headphones too ?

If the device is being reported in Device Manager, then you could try running the sound tests in dxdiag.

You didn't mention the motherboard model, but it may be worth checking the ASUS site for any known hardware conflicts/incompatabilities. You could also check for BIOS updates whilst you're there.

Also check the System Information to see if there are any conflicts there.

I'd certainly deactivate the onboard sound, remove the drivers and try moving the card to a different slot as previously suggested (reinstalling the latest drivers of course).

Which driver versions are you using for the sound card ? Are these the latest available from the Creative site ?

Personally, I never use the drivers that come on CD with the product, and always go and download the latest drivers from the manufacturer.

If you could provide more detail on your system and OS (we're assuming winxp here I think), then that would help.
February 28, 2006 2:02:40 PM

Windows XP pro
Asus A8N32 SLI Mobo

Moving the card to another slot is out of the question, I have no other free PCI slots.
I doubt it is the PCI slot since
A. It was working for a brief time
B. Hardware manager still reports that the card has no problems

I am thinking it is not a hardware problem at all but some sort of Windows problem
February 28, 2006 2:09:25 PM

Hmm
DXdiag tells me I have no soundcards installed

I have two :?
I have no idea why Windows is not picking up either, I think that is where my problem lies. If I can somehow get windows to pick up my sound devices everthing would be good.
February 28, 2006 2:23:59 PM

There's a long thread the creative site here .

As far as I can tell, the administrator of the forum recognises the problem with X-Fi XtremeMusic and Platinum edition cards used on nForce4 mobos. Not sure if it's the exact same problem you are having, but I saw a post there by someone with the same hardware you have, and the same problem of the card not being recognised.

I also have the A8N32-SLi board with an X-Fi XtremeMusic card. At this point in time, it is working ok, but I did have problems initially due to an ACPI error when installing WinXP. However, I digress.

Check out that thread and see if it's the same problem.

Hope this helps
February 28, 2006 2:37:49 PM

Thanks for the thread

From reading the first page, that is not my problem but I will keep reading it.
The card installed fine and worked for a brief period of time then quit.
What is really confusing me is that Windows also refuses to play anything through my AC97 soundcard either.
It would be extremly unlikely that im having problems with two different devices.
That is why I am pretty convinced it is some sort of windows problem.
February 28, 2006 2:44:36 PM

Yeah - rechecked that thread.

It actually relates to ppl having problems during the installation of the drivers (system rebooting), and relates specifically to an older firmware version of the sound card for Xtreme Music and Platinum cards when used on nForce4 mobos.

There was a poster on that thread that finally managed to get the drivers installed (or so he thought), and now has a problem very similar to your own.

It does sound like you are having a problem with your drivers, or there is a hardware compatability issue.

Other than fully deinstalling your current drivers and reinstalling, I think it may be worthwhile contacting Creative themselves to discuss the problem.

Note that, having both the onboard sound and the X-Fi installed and enabled is only going increase the risk of conflicts, so I would only have 1 or the other enabled/installed at any 1 time.

If the onboard sound doesn't work with the X-Fi not installed, and AC97 drivers installed, then you may need to reinstall windows. Deinstalling rarely removes all the registry entries, and that could be causing a problem also. You could try using RegCleaner to help with that problem.

Other than that, I'm out of ideas.
February 28, 2006 8:37:56 PM

Ughh
I tried to update my BIOS through ASUS update. That did not work so I uninstalled the program and tried to reinstall it. It will not install and the error it gives is that it cannot find a motherboard...
Not quite sure what to make of that. This new system is turning into quite a headache
February 28, 2006 8:47:25 PM

I never trust BIOS updates through windows.

The method I used was to download the new BIOS, copy to blank floppy and rename to A8N32SLI.ROM. This is explained on page 4-5 of the manual (ASUS Crashfree BIOS 2).

Then just reboot with the floppy.

Not sure about the problems with that program, but if you use the above method, then you should not need to install the program anyway :) 
February 28, 2006 10:21:00 PM

Well, I did not think updating the BIOS would solve the problem.
And sure enough, it did not.
:( 
March 1, 2006 7:08:22 AM

One more thought - maybe it's a problem with the DirectX files. Have you tried reinstalling them ?
March 2, 2006 1:12:57 AM

I have the latest SDK installed and its not working either
March 2, 2006 1:48:23 AM

I had a problem close to yours with a a8n-sli permium. First thing I would do is flash the cmos. Take out the battery and move the jumper for 10 seconds and do a fresh install. Do not install the soundcard and check to see if your onboard sound is working. Make sure you have the latest bios drivers and sound drivers....and chipset drivers. If you still have problems with the sound you have a faulty motherboard. I went through hours and hours of troubleshooting and come to find out I had a faulty motherboard.
There is also a known issue with nforce chipsets and x-fi soundcards which may be the root of your problem. A new driver update is due out in the next couple of weeks if you want to wait for that and see if that helps you.
March 2, 2006 3:09:20 AM

I will try that, but I doubt it will work.
I am almost convinced this has to be some sort of Windows problem. The onboard sound not working in the exact same fashion as the X-Fi makes me think Windows is to blame.
I tried moving the X-Fi to another PCI slot and the problem still remains.

I will try removing the battery and seeing if that does the trick.
As a last resort I will format and reinstall Windows :evil: 
March 2, 2006 3:23:53 AM

There is nothing to compliacted about onboard sound. If you have all the lastest drivers and it doesnt work or if you get hissing and popping noises you have a faulty motherboard. Windows dont have much to do with this. First thing to do is make sure you dont have a bad motherboard. By doing a fresh install and making sure you have all the latest drivers and you still have problems it is safe to assume you have a bad motherboard. Try out Asus phone support they will be more then happy to help you out.
March 3, 2006 5:55:11 PM

Quote:
I have the latest SDK installed and its not working either


I was suggesting that you try and reinstall DirectX. It may be that on of the dx files or registry entries was corrupted.

If you have already tried this, then please ignore this post.
March 4, 2006 2:20:57 AM

I have always been told that it is a really really really bad idea to unistall DirectX
I did it once to an old computer just for kicks and damn near killed the thing, it was about as unstable as unstable can get.

I have one last thing im going to try.
I am going to take my old Audigy 2 ZS and place it in the new system and see if it works.
If that does not work I am going to format and reinstall windows and see if I can get the onboard sound working and then the X-FI working
I am working 60 hours a week right now so it makes it hard to find time to work on this issue :( 
March 4, 2006 2:44:08 AM

here are somethings you can try.

reinstall directx
try a different media player like winamp
try a linux live cd
try restoring to before you loaded the drivers for the creative card
if you have anouther computer kicking around try plopping the card into that machine and see if you have any problems

although you may have to reload windows from fresh.

i hope these help, although i have been out of the creative loop for a while (since sb live 5.1 era) But that fact that the mobo audio isn't working either and it's the same error sounds like a buggered windows installation.
March 4, 2006 3:02:53 AM

anytime your jumping sound platforms any software related to the prior hardware can cause a problem, so its a trip to add and remove software. be sure to disable the onboard sound. and with the card out go to safemode, administrator and go to device manager, under sound, remove everything. check add and remove for any sound software. restart and everything should be ok except for no sound, good! shut down and add your card, you should have a card that can work now!
!