Sign in with
Sign up | Sign in
Your question

HELP! - CD/DVD Drives and Floppy stopped working in Windows

Last response: in Components
Share
March 1, 2006 8:08:38 PM

Hello all,

I need your help. I'm not sure if this is a virus or a driver issue, but for the second time in 2 months, my CD, DVD RW, and floppy drive will not read discs while in Windows. I rebuilt my PC from scratch the last time this happened and all was good until last night, but I believe the fix should not be so difficult.

When a floppy disk is inserted, it reads for a bit then errors out saying the disk isn't formatted. If I click on the floppy icon with no disk inserted, I get the same error.

The two optical drives behave a little differently. If no disk is inserted, Windows explorer opens and no files are seen. If a disk is inserted, I get an error regarding invalid media.

My PC is about 3 years old and I've never had a problem before 2 months ago. I'm running a AMD Athlon 2500 on an Abit NF7-S motherboard. I'm sure this isn't a hardware issue as all drives work in DOS mode.

Has anyone heard of this before? :cry: 
March 1, 2006 9:04:01 PM

Have you checked for any Viruses or Malware? Did you install any new progams 2 months ago? What version of Windows are you running (Guessing XP, but you never know) and when was the last time you did a clean install?
March 2, 2006 12:58:05 AM

I'm running XP Pro. I reformatted and reinstalled everything two months ago. I just ran a full system scan for viruses....nothing. No new programs have been installed.

Here's an interesting finding. I disconnected my floppy drive and windows is still showing a floppy in My Computer. I click on it and the same error pops up...The disk is not formatted. Do you want to format now?
Related resources
March 2, 2006 11:28:21 PM

Have you tried removing the floppy drive from device manager and let windows redetect it? You might want to try the same with your cd/dvd drives. Sometimes that works.
March 2, 2006 11:37:42 PM

I had the same problem on an old system (Celeron2 - Win98) that I was still running up until last month. The drives would appear under MyComputer but would always show as "unaccessable". What happened is that my CD-ROM had crapped out and was causing everything on that bus to fail. I unplugged the faulty drive and the others started working again. Then I replaced it with another I had laying around and everything was back to normal.

Good Luck!
March 3, 2006 1:40:27 AM

troj planted hijackers malware can messup hardware comunication, try safemode with networking and do an online scan at like Panda or trendmicro or both
March 3, 2006 1:45:28 AM

Another symptom...Plugging in USB external drives results in Disk is not Formatted errors as well. I plug in a digital camera or MP3 player and that error pops up. I disconnected both optical drives and the floppy and disabled the IDE bus in BIOS. When I booted Windows back up and plugged in my digital camera, it still gave the error.

I'll try scanning for malware. I tried that two months ago with no luck but it's worth a shot.

Thanks. More ideas are welcomed.
!