usb flash problem

i have a 1GB pny flash drive and it suddenly stopped working...

when i plug it into any computer (ive tried several) it recognises that a usb storge device has been plugged in but it never realizes it it a 1gb flash. so i end up with a drive E or something that has storage of 0 and cannot be read by the computers. i tried to reformat the drive in xp and xp pro with no success. the computers say that the drive is unreadable and if i double click it in "my computer" it tell me to insert a disk.

is there a program or a command to force a format of it? or some other way i can fix it without having to dig up the reciept from black friday to RMA it. @_@
2 answers Last reply
More about flash problem
  1. sounds like the usb drive died. it happens, especially if you carry it around alot.
    dont know if it can be fix and if it's still under warrenty RMA.
  2. had a feeling that might be the case... bummer... now i have to go find a receipt from like 4 months ago.
Ask a new question

Read More

Components