Sign in with
Sign up | Sign in
Your question

exe opens with paint

Last response: in Windows 7
Share
April 4, 2011 12:23:02 AM

I can't open any .exe files(This is most of my computer files) all of my icons in the program list and
desktop have an paint icon. It seems that my file
types are messed up. I also get the message
"Paint cannot read this file
This is not a valid bitmap file, or its format is not currently supported"
When I try to open anything, including system restore, msconfig, regedit, etc I get this error (I can't even turn off my touchpad). It got this way by setting the default program that a .exe file should open with, with paint. My computer is nearly useless right now, any help?

My files were not put like this by a virus, I was simply trying to mess with an icon, which I didn't know was a .exe, so I tried openning it with paint (Um, you know to edit the icon). And then bam all my .exe files will no longer work and only open with paint.

I don't imagine this being such a difficult thing to fix, but if it is please go into some detail, really frustrated with this issue. Please help sombody :cry: 

What I am able to do: Is access the internet (by right clicking the paint file which is supposed to be the internet and clicking my pinned url, in which my internet pops up and I can do anything on the internet.

More about : exe opens paint

a b $ Windows 7
April 4, 2011 1:22:27 AM

Control Panel\Programs\Default Programs\Set Associations
m
0
l
April 4, 2011 1:32:35 AM

Ok, I found my way to Control Panel\Programs\Default Programs\Set Associations But what am I supposed to do once I've gotten here, am I supposed to look for .exe (Which I cannot find)

EDIT: I confirmed there to not be a .exe when I was looking at \Set Associations
m
0
l
Related resources
April 4, 2011 2:00:58 AM

Hello, I followed the "Let me fix it myself" Guide for windows 7 users, I followed the guide Exactly, Until I got to here

5. On the File menu, click Save as.
6. Select All Files in the Save as type list, and then type Exe.reg in the File name box.
7. Select Unicode in the Encoding list.
8. Return to the Command Prompt window, type REG IMPORT Exe.reg, and then press ENTER.
9. Click Yes, and then click OK in response to the registry prompts.

On step 8 I got this error trying to import the file "ERROR: Error opening the file. There may be a disk or file system error."
m
0
l
a b $ Windows 7
April 4, 2011 2:09:43 AM

back up your registry now and go to regedit and search for the entries and change value by hand. If value is not there add them.
m
0
l
April 4, 2011 2:16:49 AM

nevermind! I was able to fix it by clicking the registery icon and importing it without using the command prompt! I Restarted and my computer is fixed, I deleted the registery addition to prevent me from re-adding it! Dude tysm for giving me that link man thanks!!!

And I was gonna take it into the shop tomarrow.... Your a lifesaver!
m
0
l
a b $ Windows 7
April 4, 2011 2:18:36 AM

Good to know you fixed it
m
0
l
October 7, 2011 7:20:16 AM

Im having this same problem at step number 8. could someone PLEASE explain exactly what to do? i'm desperate
m
0
l
!