Sign in with
Sign up | Sign in
Your question

Warcraft 3 LAN game through openvpn not working

Last response: in Networking
Share
Anonymous
April 20, 2005 10:35:09 AM

Archived from groups: comp.dcom.vpn (More info?)

Hello,
I'm experimenting with setting up a VPN so I can have friends VPN in to
my LAN and play a LAN game of warcraft III. I have my XP system set as
the server with the TAP virtual NIC and the real NIC set to bridge.
2 clients have tried connecting, and while I can ping them and see
thier shares, etc... and they can see mine, a hosted game refuses to
showup on the client (and vice-versa).
I ran a port scan on the remote client system, and the WC3 port 6112
shows up.

Is it possible that the VPN isn't sending broadcasts across?

Any ideas I could try?

Here's the server config (.ovpn):

dev tap
dev-node tap-bridge
server-bridge 192.168.15.106 255.255.255.0 192.168.15.200
192.168.15.254
keepalive 10 120
client-to-client
ca ca.crt
cert server.crt
key server.key # This file should be kept secret
dh dh1024.pem
verb 3


I noticed this error from the server when started:

Tue Apr 19 00:13:39 2005 us=167630 TAP-WIN32 device [tap-bridge]
opened:
\\.\Global\{E337A46B-B8C1-4B40-9134-64761FA0BB7B}.tap
....
Tue Apr 19 00:13:49 2005 us=172299 NOTE: could not get adapter index
for
\DEVICE\TCPIP_{E337A46B-B8C1-4B40-9134-64761FA0BB7B}, status=55 : The
specified network resource or device is no longer available.

but the network starts fine.

I thought maybe broadcasts aren't being passed, so I set
bcast-buffers 256
but I see this on screen, so I'm not sure if broadcasts are being
passed throught the VPN correctly:

Tue Apr 19 00:15:46 2005 us=520776 GLOBAL STATS
Tue Apr 19 00:15:46 2005 us=520862 Max bcast/mcast queue length,1
Anonymous
May 11, 2005 12:21:03 AM

Archived from groups: comp.dcom.vpn (More info?)

It seems the problem was different version of WC3. Each version of the
game needs to be the exact same patch version. Once everyone upgraded,
all players can see the server and each other.

Bruce

ps: I used the very cool Ethereal packet snooper program to see the
games UDP packets being broadcast correctly.
!