Sign-in / Sign-up
Your question
Closed

/NOEXECUTE=OPTIN on every boot

Tags:
  • Computers
  • Boot
  • Windows 7
Last response: in Windows 7
April 4, 2011 4:19:26 PM

Hello,

Ive been having this issue recently that has never occurred before. Every time I start my computer, it loads up past the motherboard screen then stops in a black screen. The black screen shows the following:

Edit boot option
Edit windows boot option for: Windows 7
Path:\Windows\System32\Winload.exe
Partition 1
Hard Disk 9430081d

/NOEXECUTE=OPTIN

Press Enter To Sumbit

After pressing enter my computer boots to the desktop and everything is fine but having to press enter every time on this screen has become very annoying as I want to power my computer, walk away and come back to the desktop

If anyone can provide insight on this problem, it will be much appreciated!

More about : noexecute optin boot

a b $ Windows 7
April 4, 2011 4:41:28 PM

Have you been playing with your boot options? Somehow you have set things so that the "Edit Boot Options" menu appears at every boot. This article explains how you can make this happen. I guess that all you have to do is to reverse this procedure to get back to normal booting.
Score
0
April 4, 2011 4:46:43 PM

I'll have a look at the article and report back, thanks!

edit: excuse my lack of understanding with this area but could anyone interpret a reverse procedure from the article? I'm having a hard time
Score
0
Related resources
a b $ Windows 7
April 4, 2011 5:33:32 PM

It will be a question of changing the option optionsedit from true to false, or removing it altogether. You use the bcdedit program to do this, but it's not terribly intuitive, and you need to be careful. I can't check this out right now as I'm on my iPad, not my PC; I'll check back later and if no-one else has come up with an answer I'll look further. It may be possible to use the much friendlier EasyBCD program to fix this.
Score
0
April 4, 2011 5:43:18 PM

Ya I had trouble locating "optionsedit" even using the command "bcdedit/?osloader" , I've downloaded EasyBCD, so I'll see if I can figure something out. As you have mentioned, I'm trying to be as careful as possible to avoid any mis-edits.

Thanks for your help thus far, if the problem still isn't solved, I hope to see you later tonight then.
Score
0

Best solution

a b $ Windows 7
April 4, 2011 5:56:41 PM

OK, back at the PC now. I managed to reproduce your problem and resolve it with the commands:

bcdedt /set optionsedit yes

bcdedit /deletevalue optionsedit

so try the second of those. If that doesn't do it try

bcdedit /set optionsedit No

I hope one of these works for you. (You didn't waste your time downloading BCDEdit - it's a useful program, particularly if you want to dual-boot, but I couldn't see how to make it solve this problem.)
Share
April 4, 2011 7:56:56 PM

"bcdedit /set optionsedit No" did the trick

Just tested it by shutting down my computer, rebooted after a few minutes and it went right to my desktop after windows screen.

Thanks for your help!
Score
0
April 4, 2011 7:57:03 PM

Best answer selected by JzX.
Score
0
a b $ Windows 7
April 4, 2011 7:58:18 PM

Great. And I learnt something too, which is always a bonus.
Score
0
April 21, 2011 6:13:18 PM

thanks and happy......but i am using dell xps m1330......before when i have this problem there was a beeping sound and stop untill i press enter........now the beeping sound is still there and boot continues without pressing enter...... please solve this problem. :sarcastic: 
Score
0
July 6, 2011 2:57:17 PM

Ijack said:
OK, back at the PC now. I managed to reproduce your problem and resolve it with the commands:

bcdedt /set optionsedit yes

bcdedit /deletevalue optionsedit

so try the second of those. If that doesn't do it try

bcdedit /set optionsedit No

I hope one of these works for you. (You didn't waste your time downloading BCDEdit - it's a useful program, particularly if you want to dual-boot, but I couldn't see how to make it solve this problem.)




Just wanted to say, I found this looking for a reason why I got the 'edit boot options' screen on bootup on my stinkpad running windows 7. The second option, bcdedit /set optionsedit No, worked perfectly. Thanks!

tim
Score
0
September 22, 2011 11:28:53 AM

I had the same problem few times and I think that it is happening on people which have a button pressed. Maybe F5 or shift ot something else is making the OS to say this message.
Score
0
November 28, 2011 9:43:07 AM

Ijack said:
OK, back at the PC now. I managed to reproduce your problem and resolve it with the commands:

bcdedt /set optionsedit yes

bcdedit /deletevalue optionsedit

so try the second of those. If that doesn't do it try

bcdedit /set optionsedit No

I hope one of these works for you. (You didn't waste your time downloading BCDEdit - it's a useful program, particularly if you want to dual-boot, but I couldn't see how to make it solve this problem.)


I don't really understand this. Where should I enter all this commands? on the command interface or where?
Score
0