Sign in with
Sign up | Sign in
Your question

XP doesnt like my WD SATA RAID

Last response: in Storage
Share
March 19, 2006 12:10:12 AM

HELP!!!

I have a ASUS A8n-VM CSM mobo and XP home SP2 won't finish installing on my 2 WD SATA 80gigs RAID 0 array. The mobo see's the array and XP does too when I install the drivers off the Asus disc BUT when XP restarts to finish the install it doesnt see the array and begins the install all over again. Do I need to flash the BIOS or find different drivers from Asus/Nvidia???

Thanks.

More about : doesnt sata raid

March 19, 2006 1:24:11 AM

You have 2 post.
March 19, 2006 1:28:25 AM

Yeah, I wanted as many people as possible to see this because I need to fix the problem ASAP!!!
Related resources
March 19, 2006 1:46:59 AM

Unplug usb card reader or flash drives until windows fully installed. Check bios for boot order. Try different optical drive for reading install cd (had problems before like this and quirkly dvd drive). Run DLGDiag on both hard drives to be sure one not failing. Oh wait, they're WD, of course they're failing. LOL - go by Seagate or Samsung drives :) 
March 19, 2006 1:30:15 PM

Hey Bwave,

Thanks for the advice. There's no usb card readers or flash drives installed. This is a new build and I didnt want any of that junk on the pc.

The boot order is: floppy / CD / harddrives......is that OK???

I'm running a lite-on cd/dvd dual-layer read/write drive. After trying to install XP a few times I started getting errors on reading certain files on the install. Still, if the drive can read XP to start the install it shouldnt be keeping windows from completeing the install process would it???

I'm going to flash the BIOS and see if that helps. I checked ASUS website and there's a RAID ROM flash upgrade that may help.

Anybody else have any other idea's???
March 19, 2006 6:28:36 PM

Boot order is good, I'm sorry to say it seems your XP cd is defective. You can try testing memory, as that can cause crc errors in files. Or, try a different optical drive, but you should not be getting read errors for sure.
March 19, 2006 7:06:27 PM

During the install I assume you:

If PATA, on the proper IDE buss, drives set as MASTER, can not be on same buss.

Some MB only support SATA on specific ports (1 & 2).

1, set BIOS config for raid. And your boot order sees the RAID and not single drives.
2, Configure for the raid, which drives to use.

3, enter F5 to load raid controller drives for your MB (not HD).

4, Do XP install.
March 19, 2006 7:25:54 PM

I think its the dvd dual layer drive thats causing the problems. I took the same XP disc and loaded it with no problems on another build I'm doing that has a dvd read only drive. ( same name brand--lite-on )

The SATA drives are on port channels 1 & 2.

There are no PATA hard drives install period.

BIOS was set for RAID and it see's the array on bootup.
( Funny thing is it wont show the array as bootable in F10 setup??? )

Loaded raid drivers with F6 on XP using ASUS MB drivers disc.

XP loads and formats array but on restart to finish install it goes into a loop and starts all over again.

Like I said....I seriously think its the dvd dl r/w drive thats causing the problems. I going to try the dvd read only drive that works with my other build and see what happens. I'll let you guys know.

Thanks for the help.
March 19, 2006 8:37:41 PM

Hey....my first post ....well
when you have been asked which driver for your storage you want to specify
you have to specify
1_ the Sata storage driver
and then you have to specify
2 the SATA Raid storage .

U have to chose the two drivers.SATA& SATA_RAID

Hope to have it solved ..
keep us informed.
March 19, 2006 8:55:37 PM

OK, I tried the other dvd drive and it still goes through a feedback loop on the install so we can rule that part of the problem out. I dont get it....XP see's the array and so does the motherboard. What is causing XP not to see it after it reboots for the final part of the install??? I tried fooling around with the boot config in the BIOS to see if that would help like changing the floppy to first boot and the same with the cd/dvd plus hard drive array and still no luck. I still havent flashed the BIOS yet so I guess I'm going to give it a try. Anybody else have any suggestions?
March 19, 2006 9:01:00 PM

Hey HitecXo,

Yeah, I know, I installed the Nvidia raid driver and the Nvidia storage controller as well. Both were used from the MB disc. Both of these worked fine for my other build but not for this micro board.
March 19, 2006 9:24:13 PM

Quote:
I think its the dvd dual layer drive thats causing the problems. I took the same XP disc and loaded it with no problems on another build I'm doing that has a dvd read only drive. ( same name brand--lite-on )


I recently had an XP install fail due to a Lite-On dual layer DVD burner. It had a ton of problems reading the XP discs. Swapped to a Mad Dog and life was good.
March 20, 2006 2:40:13 AM

Hey everybody,

I downloaded the latest BIOS drivers and now, thankfully, XP see's the raid and everything installed without a hitch. If anybody reading this decides to buy this motherboard make sure you update the BIOS software from the ASUS website if your going to boot from the raid array. :roll: :oops: 


I just wanted to say thanks for everybody who pitched in with advice. Through trial-n-error and insight from forumz members I was able to narrow it down. ( and not go insane in the process :wink: )
!