Sign in with
Sign up | Sign in
Your question

tyan S2885 SiL raid and Promise SX4300 raid SUCKS

Tags:
  • Hard Drives
  • Tyan
  • NAS / RAID
  • Storage
Last response: in Storage
Share
March 19, 2006 5:40:44 AM

We have been using the Tyan S2885 Sil buildin Raid 10 for almost an year. However, it seems that it likes to always drop the 3rd HD. Recenlty, it killed the 3rd HD; now JavaSATARAID will not even OPEN.

I'm quite fed up with the up and downs of Tyan Sil and decided to try my luck with Promise SX4300.

Now the nightmare 1 begins:

I try to migrate the entire windows 2k3 to SX4300 (Do not try this at work because I tried it at work)
1. plug the SX4300 into the board and bootup the Server and Install new Drivers.
2. Bootup with Ghost 8 and clone the entire Server into a firewire external drive (Took 7 Hours)
3. Unplug all the sata cable from Tyan MB and hook it up to SX4300
4. Reboot, define new set of RAID 5 and cleared the MBR
5. Reboot with ghost bootdisk and clone back the entire Server (Took 7 hours)
6. Reboot > I see windows 2003 screen > Ask me to prompt Password >
Able to login and OS ask me to reboot OS due to new installed driver.
7. on reboot, Promise SX4300 BIOS shows "CRITICAL". After checking the BIOS, 2 HD are gone.

8 tried 4-7 about 4 times to get it work
9 However, I keep getting complains of broken files. (Well I did windows 2003 backup and ghost but only the windows 2003 backup was not corrupted which allowed me to restore them)


Since Nightmare 1 corrupted important files, I have to restore the entire OS back again.

I was thinking, could it be my server HDs? then I bought 4 brand new Maxtor 200GB sata drives to do the restore again on this weekend.

Nightmare 2:
1. This time I tried to not to use ghost but install a brand new windows 2003 server and run the NTBACKUP to restore the entire server.
2. Swap Raid 5 HDs out and plug new HDs in.
3. Entered SX4300 Bios and defined a RAID 10 and cleared MBR
4. Reboot and initialize windows 2003 installation.
5. Windows Setup Can't detect any HD (Of course, I pressed F6 and insert the floppy with the sx4300/sx8300 driver)
6. reboot and I see sx4300 BIOS showing 2x2 critical. Then I enter the BIOS and 3 HDs are gone. Only one is showing
7. Shutdown server, swap a BRAND new SX4300 (the spare that I bought) into the board.
8. reboot and I see sx4300 BIOS showing 2x2 raid offline. In Promise Bios shows only 1 drive is detected
9. shutdown again and check the cables. Reboot and I see it is now critical .Then Ienter the BIOS and 3 HDs are now showing free (not in raid mod). Sigh
10. Deleted the raid 10 and defined a new RAID 10 and cleared MBR
11. Redo clean OS installation. Windows SETUP (now HD is showing) > Reboot > key in Serial > reboot > RAID is critical > see the windows 2003 black screen > auto reboot > RAID is offline > PULLING MY HAIRS $!@#@!#!

I tried to make the raid functional but it seems after 1-2 reboots. The Raid is either offline or critical.

Since I was using the newest Tyan BIOS, I restoreed the bios to s2885v4 and same issue. Either the RAID goes CRITICAL or Offline. NOTE: I DISABLE THE ONBOARD RAID while I did all these things.

sigh, promise and tyan suck. Bottom line do not RAID your server on TYAN MB ......

any good hardware raid that works with tyan S2885?

More about : tyan s2885 sil raid promise sx4300 raid sucks

March 19, 2006 9:09:11 PM

update!

Grabbed LSI 1506 RAID from fry's electronic and test it in the server.
It turns out that one of the HD that I bought is defective which Promise failed to tell. It just keep dropping HD randomly.

LSI is way better than the sloppy SX4300 in term of"
- memory 64 mb vs 32 mb
- real time failure alarm
LSI has software, hardware and BIOS warning.
Promise software and BIOS warning.
- BIOS
LSI (2 type of BIOS WOW)
Promise BIOS is over simplified which only allows you to delete and define HD. I don't even see the rebuild option in it.
- Speed
LSI only 1.5GB which is fine
Promise 3 GB ... well if it doesn't work ... 3GB is useless

Promise sucks.
!