Sign in with
Sign up | Sign in
Your question

Very FRUSTRATING problem (Win2K & software RAID)

Last response: in Windows 2000/NT
Share
Anonymous
July 2, 2001 7:04:46 AM

Hey everybody... I've been having a big problem with my system which has me completely stumped. I've been trying to fix it for months now and it's my hope that someone will be able to offer some insight into what might be going wrong.

This is my <A HREF="http://www.anandtech.com/mysystemrig.html?rigid=7830" target="_new">rig</A>. In a nutshell, here's my problem: I have a Maxtor 15GB 7200RPM drive which I'm using as my boot drive (it's a 51536H2 if anyone's wondering). I also have four Maxtor 60GB 7200RPM drives (T060H6) which I have set up as a stripe set using Windows 2000's software RAID. The boot drive is connected to my onboard IDE controller, and the 60 gigs are hooked up to two Promise ATA 100 controller cards, with each drive on its own channel.

I'll partition and format one big volume across all my disks. It will works great initially... I can install and run programs from it, it's really fast, and it seems stable. But after running it for a couple of days, and installing most of my programs, it gets flakey. I'll start getting weird error messages in my programs, and when I run a disk check it will find hundreds of disk errors. At first, it will fix these errors and my system will work okay for another day or so. Eventually I'll be using my computer and I'll get one final error message. Usually I'll be playing some game like UT or Serious Sam and it will crash out between levels. Sometimes, though, it would happen overnight, when I'm not touching my computer, presumably while Diskeeper is running its scheduled defrag but I'm not really sure. I have to reboot my computer, and when it comes up again, my 229GB volume now shows up as being 0 bytes.

Disk administrator under computer management shows the volume as being healthy, but all my data is gone. There's no way to easily recover it as far as I can tell. This has happened to me with probably a dozen clean installs. Here's some history so you know what I've tried already to fix it.

Originally, I had an 800MHz coppermine running on a <A HREF="http://www.tyan.com/products/html/trinity400_p.html" target="_new">Tyan Trinity 400</A> motherboard. I think I had 384 megs of Micron PC133. I was using a Radeon 64MB ViVo as my primary video card, and the PCI Voodoo 3 as my secondary card. I had a SoundBlaster Live 5.1 and a Linksys NIC. I had a 10GB boot drive and two 15GB drives set up in a stripe set. The 10GB was hooked up to my motherboard, the 15GBs to one of the Promise ATA 100 cards.

I started having the problem exactly as I described above, only with the two 15GB drives. My volume would get corrupted, and eventually vanish. I installed all the latest patches, drivers, firmware for the ATA card, chipset drivers from VIA, etc. Still had the exact same problem. Thinking it might be hardware related, I decided to swap out some parts. Over the course of a month or so, I replaced virtually everything in the system.

I got a 1GHz coppermine instead of the 800, in case it was a problem with the CPU. I replaced my Radeon with a GeForce3. I got the four 60GB drives, so I used them as my stripe set and used one of my old 15GB drives as my boot drive. I got two brand new Promise controller cards and got rid of the old one I had been using. I exchanged my SoundBlaster Live for a new one. I replaced my Linksys NIC with a Realtek. I got rid of my Micron RAM and replaced it with two 256MB sticks of Infineon PC133 2-2-2. Because of the problems I read about people having with the SBLive and the VIA VT82C694X & VT82C596B north & southbridges, I decided to try a new motherboard. I picked up the <A HREF="http://www.soyousa.com/sy7is2.html" target="_new">Soyo SY-7IS2</A>, which is based off the Intel 815EP chipset.

Guess what? Same problem. I'm installing Windows 2000 off a CD with SP2 already slipstreamed in. My hardware is pretty different and almost all the drivers I'm using are new or updated from when I first started having this problem. All sorts of critical updates and whatnot. Nothing fixes it. I tried turning the hardware acceleration on my SBLive off and that didn't solve anything, so I pulled it out and tried using a SoundBlaster 16 and some generic Aureal A3D card, but no love. I tried using some SiS PCI graphics card instead of the Voodoo 3 for a little while, but that didn't fix anything so I went back to the Voodoo which can do higher resolutions.

It's really hard to tell exactly what is causing this to start happening. It doesn't occur unil I've been using my computer for a little while, and I don't really use my computer much until I have all my drivers and programs installed. I've observed that I never get any sort of data corruption on my 15GB. The stripe sets I've created have always been with drives hooked up to a Promise controller card. I haven't tried hooking the drives up to my motherboard, since that wouldn't be practical for my current setup so I don't care whether it would fix the problem or not. In a little bit I'm going to ditch the Promise cards and get an Adaptec 2400A IDE RAID controller to see if that helps, but since I'm stuck with my current setup for the time being I'd like to get it working if possible.

There are a few things which I think could be causing this problem. One is the Promise cards. They've been a constant the whole time I've been experiencing these issues with my computer. I know it's not a hardware problem with the cards, since I got them brand new. It's also not a compatibility issue between the ATA cards and my chipset, since I've tried two different motherboards. It could be a conflict with one of the other cards in my system, but I've replaced every single one of them at some point. I'm inclined to think that if it is a conflict with another card, it's with "the PCI video card" or "the sound card", not with a particular card from a particular manufacturer. One thing to note is that I have 8 different devices all sharing IRQ 11, including my two video cards, my two ATA cards, my NIC, and my SBLive. From what I understand this shouldn't be a problem under Windows 2000 with a 100% ACPI compliant motherboard, but it's still kind of weird to see.

I haven't tried taking out my secondary video card or my sound card completely, since I need both of them. I don't think there's problem with using two ATA cards, since I had the same problem back when I was only using one. Also, the Promise cards handle it very elegantly... during boot when the ATA card it detecting drives, it shows drives 0 through 7, instead of showing the card's BIOS twice with 0 - 3 each time.

My system event log has one slightly odd warning in it. Every 60 minutes (to the second) after booting my computer, I'll get this warning twice, 1 second apart:

Event Type: Warning
Event Source: Ultra
Event Category: None
Event ID: 26
User: N/A
Description:
The description for Event ID ( 26 ) in Source ( Ultra ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. The following information is part of the event: \Device\Scsi\Ultra1.

I'm pretty sure it's unrelated, since this error is widely reported on the usenet and doesn't appear to be associated with data corruption on anybody else's system. Still, I figured it was worth mentioning.

Anyway, if you're still reading this, I appreciate you taking the time to see if you can offer any help... I'd be very grateful for any suggestions or feedback since I've been fighting with this stupid machine for way too long. Thanks in advance for any insight anyone can offer into this mysterious problem I'm having with my computer.

-Y
July 2, 2001 6:41:39 PM

When you installed Win2k did you press the F6 or F8 during installation to install your special scsi drivers needed for those huge drives? Also ACPI can be checked with some software off Microsofts Web site. It checks to see if your System is 100% ACPI compliant.

I know for a fact you can disable the ACPI on install to route seperate IRQ's for most of your devices. You need to make a bootdisk. You can browse your Win2k Installation CD to find the subdirectory called Bootdisk. Run the executible in that subdirectory and make the 4 disks it requires. After that is complete you should go into the first floppy and modify a file in there. There is a Microsoft step by step on their site. Just search for disable acpi. Its a simple proceedure and saves you the heart ache of re-installing drivers if you just change your computer type from ACPI compliant system to Standard PC. Now when you do this it will allocated IRQ's from your BIOS. This still doesn't allow you to change IRQ's in device manager in most cases, but you can have some control by checking out your motherboard manual and see which slots on your motherboard are shared IRQ's. Then shift cards around based on that information. I have 2 items sharing the same IRQ in Win2k. My Sound Card and my USB. That was the best configuration I could set up. *grin* Works great. I'm not to sure on the URL's for those web pages so do a little bit of research on the microsoft site. Hope that helps ya.

Dantin
July 3, 2001 3:47:54 AM

My friend tried running software raid stripped set on his Abit BP6 with two IBM 7200 drives. The system ran perfect before with just the two drives as NTFS drives. Once they were stripped and win2k reloaded it did work great for a while, but then went to complete sh|t. I have heard from more then a few people that the software RAID under win2k is completely useless. I would just get a hardware raid card and run the 4 drives from that. Or you might be lucky enough to be able to flash one of your promise cards with the RAID versions bios and run it that way. Some of the cards are able to do that and work. I think the article on how to do it was on BP6.com a while back. Bottom line is that the software raid just isnt stable.

You can prick your finger, but don't finger your prick! :wink:
Related resources
July 10, 2001 9:55:27 PM

Hi!
Well, you sure have a big problem there...

What I can see of your text, it is one thing you maybee dont yet have tested. You write you have two promise-cards, and have each disk in seperate channel. Have you tried to only use one card and connect two disks to each channel?
Also, have you switched the ide-cables to new ones?
You say it only happens when using it for a while. Can it be a heatproblem with your disks, are they to packed and no airflow in your case? Are you having a 300W powersupply?
One more thing. Dont use diskeeper. Use Windows 2000 internal defragmenter. See if it makes a difference...

Windows 2000 software Raid5 function works just great for me! I've been using it the last year, and have no problems at all. I also experienced a harddrivecrash on one of the disks in the raidset, I switched the disk, and after the rebuild, everything was back to normal! Cant complain about that!

If anyone here can get their raid5 formatted drives in w2k to work in winXP, please reply. Nothing I do seems to make it work in XP?
July 18, 2001 11:47:34 AM

I know its a bit harsh but buy a PCI RAID card such as a Promise or Highpoint chipped board.

I live in the UK, the one I use is a Chaintech with Highpoint HPT370A chipset and it was only £21 ($32?).

I have absolutely no problems with my card in both ME and 2K.

You should be able to connect all four drives to the one card without problems.
Anonymous
July 18, 2001 3:59:00 PM

"I'll partition and format one big volume across all my disks"

im not really sure from your post, but are you including the boot disk in your raid 5 dynamic disk? Are you using a striped volume, or a raid 5 dynamic volume? when striping in win 2k software RAID you cannot include the boot/system partition in that volume. i think you probably understand that, but wanted to make sure. most people having problems with win2k RAID are experiencing data corruption because the boot partition is being striped. remember that win2k does not offer pure raid striping. its raid striping with parity, or mirroring only. when the boot partition is mirrorred, everything is fine! When it is striped, everything goes nuts. other than that, im afraid i have no comments other than that it could be a power supply issue. i have seen severe data corruption on under-powered systems. good luck.....

ignore everything i say<P ID="edit"><FONT SIZE=-1><EM>Edited by antivirus on 07/18/01 01:40 PM.</EM></FONT></P>
!