Sign in with
Sign up | Sign in
Your question

XPs built in VPN

Last response: in Networking
Share
Anonymous
June 23, 2005 9:07:21 PM

Archived from groups: comp.dcom.vpn (More info?)

I am having a hell of a time getting connected to my XP Pro box at home. I
setup an incoming VPN connection using the wizard, set my firewall to allow
PPTP passthrough and forwarded port 1723 (both TCP and UDP, but I think I
only need TCP) to my XP box.

I setup my machine at work using the XP VPN wizard to make an outgoing
connection. Well, when I try to connect to my WAN IP address I am unable to
connect. I don't know what I should try now. I have my outgoing connection
set to AUTO instead of PPTP or IPSec, but I am pretty sure the XP VPN
connections are PPTP, right?

Any tips would be greatly appreciated!
Thanks!
--Dan

More about : xps built vpn

Anonymous
June 23, 2005 9:07:22 PM

Archived from groups: comp.dcom.vpn (More info?)

dg wrote:
> I am having a hell of a time getting connected to my XP Pro box at home. I
> setup an incoming VPN connection using the wizard, set my firewall to allow
> PPTP passthrough and forwarded port 1723 (both TCP and UDP, but I think I
> only need TCP) to my XP box.
>
> I setup my machine at work using the XP VPN wizard to make an outgoing
> connection. Well, when I try to connect to my WAN IP address I am unable to
> connect. I don't know what I should try now. I have my outgoing connection
> set to AUTO instead of PPTP or IPSec, but I am pretty sure the XP VPN
> connections are PPTP, right?
>
> Any tips would be greatly appreciated!
> Thanks!
> --Dan
>
>
Couple of things it could be. You mention that you are trying to connect
from work. Does work have a firewall that might be blocking?

Also, keep in mind that in addition to port 1723 TCP. you need to open
up and forward GRE, which is neither TCP nor UDP, but it's own IP protocol.
Anonymous
June 24, 2005 12:06:46 AM

Archived from groups: comp.dcom.vpn (More info?)

Yes, "work" does indeed have a firewall that could be screwing me up. If
that is the case, is there any way to make this work without asking the
network administrator to change the firewall settings? I work under the IT
dept and the administrators office is right across the hall from me, but I
would never ask him to change the firewall for something so unnecessary.
Really I just wanted the ability to grab a file from home if necessary. Any
tips? I know there are alternatives to VPN like using FTP for transferring
files (which would be downright easy), but ideally I could use a VPN.

Thanks,
--Dan

"T. Sean Weintz" <strap@hanh-ct.org> wrote in message
news:11bm23jci9cnj57@news.supernews.com...
> dg wrote:
>> I am having a hell of a time getting connected to my XP Pro box at home.
>> I setup an incoming VPN connection using the wizard, set my firewall to
>> allow PPTP passthrough and forwarded port 1723 (both TCP and UDP, but I
>> think I only need TCP) to my XP box.
>>
>> I setup my machine at work using the XP VPN wizard to make an outgoing
>> connection. Well, when I try to connect to my WAN IP address I am unable
>> to connect. I don't know what I should try now. I have my outgoing
>> connection set to AUTO instead of PPTP or IPSec, but I am pretty sure the
>> XP VPN connections are PPTP, right?
>>
>> Any tips would be greatly appreciated!
>> Thanks!
>> --Dan
>>
>>
> Couple of things it could be. You mention that you are trying to connect
> from work. Does work have a firewall that might be blocking?
>
> Also, keep in mind that in addition to port 1723 TCP. you need to open up
> and forward GRE, which is neither TCP nor UDP, but it's own IP protocol.
Related resources
Anonymous
June 24, 2005 12:06:47 AM

Archived from groups: comp.dcom.vpn (More info?)

dg wrote:
> Yes, "work" does indeed have a firewall that could be screwing me up. If
> that is the case, is there any way to make this work without asking the
> network administrator to change the firewall settings?

Probably not.

Anyway, these restrictions are on the firewall for a reason, right?
Anonymous
June 24, 2005 3:15:14 AM

Archived from groups: comp.dcom.vpn (More info?)

It doesn't really matter if there is a specific reason. Pretty much we
don't allow anything through the firewall that isn't absolutely necessary.
My situation here, isn't absolutely necessary. I still wonder if there is
another type of VPN that doesn't use PPTP, that WILL work given the state of
the firewall at work.

--Dan

"T. Sean Weintz" <strap@hanh-ct.org> wrote in message
news:11bm81jd6ev9l7c@news.supernews.com...
> dg wrote:
>> Yes, "work" does indeed have a firewall that could be screwing me up. If
>> that is the case, is there any way to make this work without asking the
>> network administrator to change the firewall settings?
>
> Probably not.
>
> Anyway, these restrictions are on the firewall for a reason, right?
Anonymous
June 24, 2005 8:15:37 AM

Archived from groups: comp.dcom.vpn (More info?)

dg wrote:
> It doesn't really matter if there is a specific reason. Pretty much we
> don't allow anything through the firewall that isn't absolutely necessary.
> My situation here, isn't absolutely necessary. I still wonder if there is
> another type of VPN that doesn't use PPTP, that WILL work given the state of
> the firewall at work.
>
> --Dan
>
> "T. Sean Weintz" <strap@hanh-ct.org> wrote in message
> news:11bm81jd6ev9l7c@news.supernews.com...
>
>>dg wrote:
>>
>>>Yes, "work" does indeed have a firewall that could be screwing me up. If
>>>that is the case, is there any way to make this work without asking the
>>>network administrator to change the firewall settings?
>>
>>Probably not.
>>
>>Anyway, these restrictions are on the firewall for a reason, right?

If you are using XP Pro (I assume you are if the VPN server
functionality is there)

You can use the disk sharing of the Remote desktop client to copy files
between home and work.

--
WARNING! Email address has been altered for spam resistance.
Please remove the -deletethispart-. section before replying directly.
Mike Drechsler (mike-newsgroup@-deletethispart-.upcraft.com)
June 24, 2005 2:46:28 PM

Archived from groups: comp.dcom.vpn (More info?)

On Fri, 24 Jun 2005 04:15:37 GMT, Mike Drechsler - SPAM PROTECTED
EMAIL <mike-newsgroup@-DELETETHISPART-.upcraft.com> wrote:

>If you are using XP Pro (I assume you are if the VPN server
>functionality is there)

XP Home has VPN functionality. I know because I set one up.


--

Map of the Vast Right Wing Conspiracy
http://home.houston.rr.com/rkba/vrwc.html

"Whatever crushes individuality is despotism."
--John Stuart Mill, "On Liberty"
Anonymous
June 24, 2005 3:25:24 PM

Archived from groups: comp.dcom.vpn (More info?)

Bob wrote:
> On Fri, 24 Jun 2005 04:15:37 GMT, Mike Drechsler - SPAM PROTECTED
> EMAIL <mike-newsgroup@-DELETETHISPART-.upcraft.com> wrote:
>
>
>>If you are using XP Pro (I assume you are if the VPN server
>>functionality is there)
>
>
> XP Home has VPN functionality. I know because I set one up.
>
>
Duh. Yes, of course it does. How does that help the original poster who
already knew this and was looking for a way to get it to work through
his corporate firewall without having to open up any ports?
Anonymous
June 24, 2005 3:26:39 PM

Archived from groups: comp.dcom.vpn (More info?)

Mike Drechsler - SPAM PROTECTED EMAIL wrote:

>
> You can use the disk sharing of the Remote desktop client to copy files
> between home and work.
>

Probably not. I would certainly hope that the same firewall that is
blocking his VPN is blocking SMB!
June 24, 2005 7:41:14 PM

Archived from groups: comp.dcom.vpn (More info?)

On Fri, 24 Jun 2005 11:25:24 -0400, "T. Sean Weintz"
<strap@hanh-ct.org> wrote:

>>>If you are using XP Pro (I assume you are if the VPN server
>>>functionality is there)

>> XP Home has VPN functionality. I know because I set one up.

>Duh. Yes, of course it does. How does that help the original poster who
>already knew this and was looking for a way to get it to work through
>his corporate firewall without having to open up any ports?

If it is so obvious that XP Home has VPN implemented, then why did
someone make the comment above which implies that the OP must be using
XP Pro because VPN functionality is there?


--

Map of the Vast Right Wing Conspiracy
http://home.houston.rr.com/rkba/vrwc.html

"Whatever crushes individuality is despotism."
--John Stuart Mill, "On Liberty"
Anonymous
June 24, 2005 7:41:15 PM

Archived from groups: comp.dcom.vpn (More info?)

Bob wrote:
> On Fri, 24 Jun 2005 11:25:24 -0400, "T. Sean Weintz"
> <strap@hanh-ct.org> wrote:
>
>
>>>>If you are using XP Pro (I assume you are if the VPN server
>>>>functionality is there)
>
>
>
>>>XP Home has VPN functionality. I know because I set one up.
>
>
>
>>Duh. Yes, of course it does. How does that help the original poster who
>>already knew this and was looking for a way to get it to work through
>>his corporate firewall without having to open up any ports?
>
>
> If it is so obvious that XP Home has VPN implemented, then why did
> someone make the comment above which implies that the OP must be using
> XP Pro because VPN functionality is there?
>
>


Yeah, sorry. I should have flamed HIM, since the OP specifically said he
was using pro anyway.
Anonymous
June 25, 2005 2:32:23 AM

Archived from groups: comp.dcom.vpn (More info?)

T. Sean Weintz wrote:
> Mike Drechsler - SPAM PROTECTED EMAIL wrote:
>
>>
>> You can use the disk sharing of the Remote desktop client to copy
>> files between home and work.
>>
>
> Probably not. I would certainly hope that the same firewall that is
> blocking his VPN is blocking SMB!

Disk sharing is not done via SMB on the remote desktop client. It is
encapsulated within the RDP stream just like printer sharing, sound, and
the clipboard. It is independent of the PPTP and SMB protocols that
were being discussed. It is off by default on the client but can be
enabled on the client by going to the options under local resources and
checking disk drives.

It can also be disabled on the server side with group policy or registry
settings:
http://www.microsoft.com/resources/documentation/Window...



--
WARNING! Email address has been altered for spam resistance.
Please remove the -deletethispart-. section before replying directly.
Mike Drechsler (mike-newsgroup@-deletethispart-.upcraft.com)
Anonymous
June 25, 2005 3:17:33 PM

Archived from groups: comp.dcom.vpn (More info?)

dg wrote:
> Yes, "work" does indeed have a firewall that could be screwing me up. If
> that is the case, is there any way to make this work without asking the
> network administrator to change the firewall settings? I work under the IT
> dept and the administrators office is right across the hall from me, but I
> would never ask him to change the firewall for something so unnecessary.
> Really I just wanted the ability to grab a file from home if necessary. Any
> tips? I know there are alternatives to VPN like using FTP for transferring
> files (which would be downright easy), but ideally I could use a VPN.
>
> Thanks,
> --Dan
>

Two other methods you can try:
1) SSH - if you firewall does not block port 22. In this case, you need a
SSH daemon on your home PC. Try installing cygwin (http://www.cygwin.com),
which makes linux utilities available on Windows. You need to port forward
port 22 to you XP machine. If you manage to set this up, it will give you
the maximum flexibility; shell access. In addition, SSH is very secure
(suggest to use protocol version 2 only).

2) Run IIS (better Apache) on your Home PC, map the directory you want to
grab files into IIS document tree. Now, a lot of ISP block port 80 hosting.
So, I suggest you use port 443 on your IIS. Port forward port 443 at your
firewall to the PC. At work, to access your home web server, always use
this http://a.b.c.d:443 (not https:// which will start a SSL negotiation).
Please be real careful with your access control on your IIS, otherwise,
your will be attracting lots of problem.

Good luck.
K.
!