Sign in with
Sign up | Sign in
Your question

INITIALIZING SCSI 146 GB / DATA RECOVERY PLS HELP

Last response: in Storage
Share
March 24, 2006 2:58:41 PM

Hi all,

i have a Maxtor scssi 146gb 10k ultra 320scsi drive that wount initialize.

the disk holds critical info, it was on the domain controller dell server.

i have connected it on another server running on win 2003 as a n indipendent drive, its seen in the divice manger properties but with a yellow sign to it, and the machine took like 1hr to boot.

none of my tools can see it: winhex, r-studio and get data back for ntfs.

i tried using media tools which am not sure if i can use it to view scssi drives but it still not being seen.

which tool can i use to get info out of this drive, its detected on boot up but as i said you have to wait.

kindly assist on suggestinos to get data out or tools that i can use to work on the drive

More about : initializing scsi 146 data recovery pls

March 24, 2006 3:24:17 PM

was it on a raid controller in the dell or a standallone drive? if it was on a raid controller you have to:

a: put the raid controller in the other machine and pull it up that way.

b: put a crappy hd on the ide/sata bus of the dell and install a temp of server on there and pull it up.

If you right click the grey part in disk management does it say import or initialize?
March 24, 2006 4:14:59 PM

Since you mention this was on a domain controller, what kind of critical info are you trying to recover? Maybe there is another way besides restoreing the hard drive to life.

Or some bad assumptions

1. this was your only domain controller :(  ouch

2. the drives were not mirrored



More questions

1. was this setup as a basic or dynamic disk?

2. is the hard drive seen in bios?

3. if seen in bios, what does the maxtor hard disk utility say?

4. have you run chkdsk, or is the partition info missing from the drive

Also check out Winternals.
Related resources
Can't find your answer ? Ask !
March 25, 2006 10:09:45 AM

the serever had 3 same drives

one is the one that failled, and up to now the rest seem to be ok am scanning with winternals one at a time i dont know the chances of getting data from each because form the infomation i have is that

the drives were seen as one volume
the user was not using raid
the 3 drives which now is one volume were divided into 3 partitions and one of the partitions had the OS. its suspected that the failled drive is the one that had the os


what is the way forward
March 25, 2006 4:58:23 PM

You mean it was either a JBOD array or a RAID 0? If that's the case you're SOL :(  However if windows saw only a single drive, the PERC or whatever controller the dell would already have put it in some kind of array, just hope it was 5 not JBOD or 0.

Put the drive back in the dell and go into the SCSI utility upon boot and see what it shows.
March 25, 2006 6:07:17 PM

http://support.microsoft.com/kb/222189/EN-US/

Ok I think we need to get our terminoligy on the same track here!

1. you have physical drives you can hold in your hand

2. with a raid card you can join physical drives logically to create arrays that in the OS look like one physical drive.

3. different raid types 0-6, 10, 50

4. in windows you then have basic disks with partitions and dynamic disks which can create volumes

5. basic disks can have at most 4 primary partitions, or at most 3 primary and a secondary partion which can then be subdivided into smaller. With the partition information stored in a MBR in the front of the drive

6. dynamic disks store the disk group information at the end of the drive for all dynamic disks in the system. Also allowing software volumes, simple- like a primary partition
spanned-muliple physical drives joined logically for one volume
stripped, raid 5 and so on

You say it is not using raid, but then you say it is all one volume

if windows reports one large disk in disk management it is using RAID! Not windows raid but some kind of hardware raid. And that is what I think you are trying to say " the drives were seen as one volume "

So if it is using raid you need to find out what type of raid array was being used, that will determine what you can do to recover the information if at all

From the description it really sounds like some kind of hardware raid on the dell. Probably a perc2, perc 3/di 3/si. Windows then saw one physical drive in disk management. Then they setup a basic disk with multiple partitions.

You say it has 3 physical hard drives all the same size, hmm just what you need for a raid 5!

Phew!

Well this sounds scary but I work on Dell servers alot, we have about 35 different models all with direct attached storage right now. There have been a few times where for some reason the raid arrays lost its info. The physical disks were ok, just the raid array lost its cohesion. We put all the drives in their exact original locations they were before and deleted the array. Then recreated the exact same array, WITHOUT ZEROING OR INITIALIZING the array. And the array container with all the information came back. This is scary as all hell and sort of a all or nothing gamble. I about shit myself the first time Dell tech support told me to do this.

If you can't find any other way and what I describe is your situation well use your best judgement!

I would boot the system and look for something for scsi/raid management. Usually cntrl-a to get to the perc firmware management. Write down what kind of array is in there exactly. Write down what kind of raid it is, sector size, order of the drives by scsi channel drive id, anything on the screen!

If nothing else this will confirm or deny a raid setup!

If it is a raid then delete the raid and recreate it exactly. And don't be to freaked out. At least on raid 5 when I had to set it up again it says to initialize the drives again, which in most tech circles means re-writeing all 0's to a raid 5 wipeing out all data. But for some strange reason that is not what Dell meant. There is actually a tech article about it at Dell.

Well what does every one else think? Does this sound like his problem and has anyone else had to do this with Dell servers before?

Good luck! and let us know how you handled the problem ok

Boracus


P.S is this a Dell server we are talking about? I don't see anything about it in your first post but the second reply mentions Dell. Was this just an assumption?
March 26, 2006 12:13:11 AM

Talk about the long winded version of what I said :D  (Good descriptions though!)

I've used 9 or 10 percs over the years, I've recreated corupt arrays without damaging anything, on lsi and adaptec controllers as well. We need more info from GIKUYU on the perc setup.

Quote:
the disk holds critical info, it was on the domain controller dell server


I almost couldn't find it again, thought I started the rumor!
March 26, 2006 6:32:10 AM

Crap I just read my own replay again and man that is long!
!