Sign in with
Sign up | Sign in
Your question

How to test 4GB of RAM? - Crash problems ...

Last response: in Memory
Share
March 25, 2006 4:11:38 PM

Hello,

I'm having some stability issues on my PC. Not overclocked and pretty standard components. Can't figure out what's going on.

Here's the configuration:
Asus A8N-VM
4GB OCZ platinum (timing set on default. Verified w/ CPU-Z that the timing is correct)
2 Maxtor 250GB SATA HD
Athlon 64 3200+
NEC DVD burner
Thermaltake 430W PSU

No dedicated graphic or audio card.

Here's the problem:
1) I installed Win XP Home. The system would crash every 1-2 hrs, especially if I was multitasking (download antivirus updates while listening to a CD, for example)
2) Formatted and installed Win XP Pro x64. Much more stable, but it crashed a couple of times while watching a DVD.

So I looked online and found Prime95 (64 bit version). It has a built-in stress test. I used it and it fails (returns error message - system does NOT crash) always at the same spot (after, maybe, 5 minutes).
Reading the documentation it seems that repeatable errors MAY be due to the software. Faulty parts are likely to give "random" failures.

Notice that I also used Asus' Probe tool to monitor temperatures. They seemed normal.

Then I downloaded a memory test software from Microsoft website. The software is said to be able to test up to 4GB, but when I start it tells me it won't be able to test all the RAM cause it exceeds the software capabilities.
http://oca.microsoft.com/en/windiag.asp

I run it, bot standard and extended set: no errors.
I let it run overnight. After ~6hrs still no errors but I noticed 2 "funny" characters towards the bottom of the screen. Note: this is a "DOS" application that boots/runs from floppy disk bypassing windows completely.
After 12hrs the run has crashed: I see garbage on the screen but I can also read that "No errors found" is still there. Makes me wonder if it's again, a software crash or if it is a hardware problem.
Since the software says no error, I also wonder if the error was due to other components (mother board?) other than th ememory.

I found also "memtest86" online but I could not create a floppy with it because the installation routine would not run on Windows XP 64.

Any suggestion?

Note that I have nstalled the 64-bit versions of Asus' applications/drivers (diwnloaded form the website cause they were not included in the CD with drivers - disappointment)

Thanks for any help.
March 26, 2006 1:53:31 AM

Firstly, default timings aren't enough description. Are the RAM modules running in dual-channel mode? 1T or 2T command rate? DDR400, 333, or some other value.

If your answers to the above are No, 2T, and 333, then you're running the RAM under the most stable condition possible, so it sounds like one of the RAM modules is damamged. Follow the steps below to find the faulty module.

1) Remove all but one stick of RAM in the machine.
2) Download and set up memtest86 using your XP home installation.
3) Start up memtest86 and let it run for a while (preferably a couple of hours, though once through the test suite maybe good enough). See if any errors occur.
4) Replace the one RAM module with a different one
5) Repeat steps 3 & 4 so that each memory module is individually tested.

If the answers for the first questions are different, report to us what the correct settings are, or if your testing fails to find a faulty modul.
March 26, 2006 2:31:22 AM

Answers are YES, don't know (how do I find out?) and 333.

By cirrect timing I mean that they match what's here:
http://www.newegg.com/Product/Product.asp?Item=N82E1682...
(timings are set on auto, so I thought it made sense)

An update: I re-installed Win XP home and created memtest86.
Run clean in ~1hr and 15min for 1 pass. All clean.
I stopped it, installed some drivers in Win XP (video, audio, chipset, ...) and I noticed that the RAM count at the boot was now 2960M.
Restart Memtest86: showed phys mem 2959M (I noticed also earlier that BIOS showed 4032 while memtest had 4031).
I did not let the run complete: now I was planning on doing the one-module-at-the-time test to see what's going on.

Will let you know.
Related resources
March 27, 2006 12:01:41 AM

On your board, I think you can select between 1T and 2T command rate using the "CMD-ADDR Timing Mode" as seen here.

I'd also disable the Dual-channel mode, and put it in single channel mode to see if that gets rid of any errors, if the single module testing doesn't show any problems.
March 27, 2006 12:38:26 AM

I'll check the 1T/2T settings.
All the stress tests with 1GB worked well. Every time, the bus was set at 400MHz (all BIOS settings are default on Auto).

Then I tried using 2GB (the memory I have are paired. Don't think it matters, since they are 4 identical modules, but, just in case ...).
Still, 400MHz, not a problem.
The 1GB runs were 6-12hrs. The 2GB runs were 4hrs each.

Now I put again 4GB in. The BIOS again is set to 333MHz (without me changing any settings) and it sees only 2960MB.
Seems to me that the 2nd pair of slots is not working.
I'm not sure if I can/shoud try with 3GB only or with 1GB in one of the "non-working" slots. The manual does not list it as a "recommended" config, but it does not say anything about allowed/not-allowed options.

I emailed Asus, cause at this point I don't think it's a memory issue anymore.

Any idea? :?:
March 27, 2006 1:50:49 AM

The memtest w/ 4GB was running slow, even though, I got no errors. 3 passes went through clean.
I tried to use 2GB only in the 2nd set of slots: worked like a charm.
So the problem seems to be using all 4GB, regardless from the displacement.
If it's not the MoBo and not the memory. Could it be the CPU?
How can the controller on the CPU fail?
And how can I check that?
!