Number pad keys not working

My number pad keys 1 2 3 do not work. I have 2 keyboards, and they don't work on either one, so I presume it is a problem with my Mac?
28 answers Last reply
More about number keys working
  1. USB keyboards, blutooth?
    Are they made for the country who's language system you're working in?

    Most likely it's not your computer, perhaps you've spilled whatever onto both keyboards the same way.
  2. Yes, both keyboards are correct for NZ. Both have been used for a couple of years. One is mine, the other I was given as a spare and haven't used, but plugged it in hoping it would solve the problem. I haven't spilled anything on mine and I think that would be too much of a coincidence for both keyboards, since all keys surrounding 1 2 3 are working fine.
  3. I think it's more likely you've hit the NumLock (number lock) key which toggles the use of the keypad FOR EVERY KEYBOARD connected to that system.

    Hit the button below F16 (it's like a crossed out rectangle) and try your number pad again.
  4. I'm using a mac extended keyboard and don't have a number lock key. To lock the keypad, it uses the clear key, in conjunction with shift or option. That works to lock/unlock all the numbers on the numeric keypad, but doesn't change 1 2 3 which still don't work.
  5. Can't suggest anything else, I'm not a mac user, merely using an apple keyboard on a Windows PC.
  6. Thanks. Hopefully someone else can figure it out. It's a USB keyboard by the way.
  7. Sounds like a software issue. Some software troubleshooting in here, about halfway down.

    Http://support.apple.com/kb/TS1381
  8. It sounds like you've turned on the 'mouse keys' feature. It lets you move the mouse cursor around with your number pad and can be used in case you don't have a working mouse.

    You can disable 'Mouse Keys' from: System Preferences --> Universal Access --> Mouse & Trackpad preferences.

    If you're mouse goes down and you actually NEED to use the 'Mouse Keys' function, quickly hit your Option key five times in a row.
  9. It turns out that Ubuntu thinks Mac extended keyboards have a numlock key. The key is marked "clear" (and sits below the f16 key as previously mentioned) and as I have no indicator lights for numlock I just press clear whenever the number pad behaves like it's been numlocked.
  10. Ahh, I see. It would have helped if you mentioned you were using Ubuntu. :whistle:

    I lost correct functionality with some of the function keys on my 15" Macbook Pro right after upgrading from Ubuntu 12.10 to 12.04 too.
    A quick edit of the alsa-base.conf file solved my problem, fixing both the volume keys (F3, F4, F5), and the brightness keys (F9 & F10) for me.
  11. Nup, that's not it. Mouse keys are disabled. Thanks.
  12. Yes, I've already been down the number lock path and know about the clear key (see my previous answer). So that's not it. Thanks.
  13. No, I'm not using Ubuntu - that was a suggestion from teatimeG, and I had already checked my clear key (see my previous answer). Thanks.
  14. Did you try using the keyboards on a different computer just in case you hit a 1 in a billion chance of having the 1-3 keys go out on both? Also have you tried different usb slots with the keyboards, what about a different user account?
  15. Unfortunately I don't have access to a different computer and I don't have a different user account. I have tried all 4 usb slots on my computer, and oddly one of them worked, but only momentarily. I managed to get the 123, but the next time I tried, they didn't work again. Go figure!
  16. This worked for me! Thank you very much! I thought there was something wrong with the keyboard!
  17. Sorry bsurge, I don't understand your answer. What worked for you?
    For others reading my thread, I (wekiwis) have still not managed to solve the problem, so any further suggestions are welcomed.
  18. wildwell said:
    It sounds like you've turned on the 'mouse keys' feature. It lets you move the mouse cursor around with your number pad and can be used in case you don't have a working mouse.

    You can disable 'Mouse Keys' from: System Preferences --> Universal Access --> Mouse & Trackpad preferences.

    If you're mouse goes down and you actually NEED to use the 'Mouse Keys' function, quickly hit your Option key five times in a row.


    Thanks for this - I had the same problem, and that's exactly what the source was (guess I got too happy with the option key once!)
  19. pauls3743 said:
    I think it's more likely you've hit the NumLock (number lock) key which toggles the use of the keypad FOR EVERY KEYBOARD connected to that system.

    Hit the button below F16 (it's like a crossed out rectangle) and try your number pad again.


    wildwell said:
    It sounds like you've turned on the 'mouse keys' feature. It lets you move the mouse cursor around with your number pad and can be used in case you don't have a working mouse.

    You can disable 'Mouse Keys' from: System Preferences --> Universal Access --> Mouse & Trackpad preferences.

    If you're mouse goes down and you actually NEED to use the 'Mouse Keys' function, quickly hit your Option key five times in a row.


    Hitting the OPTION key 5 times in succession worked for me. I was at my wits end until I came across this solution. Thanks.

    Kent
  20. Key board wouldn't work on my MAC until I hit the option key 5 times in quick succession. Works now.
  21. wekiwis said:
    My number pad keys 1 2 3 do not work. I have 2 keyboards, and they don't work on either one, so I presume it is a problem with my Mac?


    What Microsoft says is:

    Hold down :

    Left alt
    Left shift

    Then press the
    Num Lock key

    Worked for me where nothing else did...my mouse keys was off, etc. This is an excel issue (not a problem) as you can enable mouse keys in excel, and disable them as well.
  22. Thank kkay4!

    Hitting the OPTION key 5 times in succession worked for me. I was at my wits end until I came across this solution. Thanks.

    Kent


    kkay4 said:
    Key board wouldn't work on my MAC until I hit the option key 5 times in quick succession. Works now.
  23. on mac's just press shift & clear key (the clear key is on top of #7) this will unlock your number pad :)
  24. oh the shift-clear is what worked when the numeric keybad didnt work when I was in excel.

    In the Mac Help, it says, If your keyboard has a separate keypad but no Num Lock key, try pressing Shift-Clear.
    If you’re using a portable computer, the Num Lock is a function key, marked Num Lock (F6).


    If the numeric keypad still doesn’t work as you expect, you may have enabled Mouse Keys, which lets you move the pointer with the keypad.

    To find the option that turns off Mouse keys, choose Apple menu > System Preferences, click Universal Access, and then click “Mouse & Trackpad.”
  25. below was the answer
    wildwell said:
    It sounds like you've turned on the 'mouse keys' feature. It lets you move the mouse cursor around with your number pad and can be used in case you don't have a working mouse.

    You can disable 'Mouse Keys' from: System Preferences --> Universal Access --> Mouse & Trackpad preferences.

    If you're mouse goes down and you actually NEED to use the 'Mouse Keys' function, quickly hit your Option key five times in a row.
  26. wildwell said:
    It sounds like you've turned on the 'mouse keys' feature. It lets you move the mouse cursor around with your number pad and can be used in case you don't have a working mouse.

    You can disable 'Mouse Keys' from: System Preferences --> Universal Access --> Mouse & Trackpad preferences.

    If you're mouse goes down and you actually NEED to use the 'Mouse Keys' function, quickly hit your Option key five times in a row.



    The only working answer I found after a lot of searching.

    Thank you.
  27. Anonymous said:
    oh the shift-clear is what worked when the numeric keybad didnt work when I was in excel.

    In the Mac Help, it says, If your keyboard has a separate keypad but no Num Lock key, try pressing Shift-Clear.
    If you’re using a portable computer, the Num Lock is a function key, marked Num Lock (F6).


    If the numeric keypad still doesn’t work as you expect, you may have enabled Mouse Keys, which lets you move the pointer with the keypad.

    To find the option that turns off Mouse keys, choose Apple menu > System Preferences, click Universal Access, and then click “Mouse & Trackpad.”


    Argh!! Thank you!
  28. Voltechs - thank you!! I was working from home, on my mac (logging in to my computer at work) and I somehow managed to turn off the 10-key on my keyboard. Pressing "shift-clear" worked for me! thank you! : )
Ask a new question

Read More

Keyboards Macintosh Mac OS X