Sign in with
Sign up | Sign in
Your question

NTLDR is missing & USB Hookup

Last response: in Storage
Share
March 30, 2006 2:51:15 AM

I've searched thru here for some answers,but not certain as to the ones I've come across.. I have a fairly new PC built for me by a buddy, it's an AMD 64 3500+ 2.2 Ghz system, got 2 Sata Drives, with an MSI k8N Platinum MB..Here's my Quandry..

I can boot up normally everytime, but when I have an external USB Hard drive connected and reboot, it gives me the infamous "NTLR is Missing" error..

I turn off/disconnect the USB drive, reboot, and everything runs fine, and I then turn on the USB drive, and it operates the way it supposed to.. Only problems I have is that it happens everytime I leave the USB Drive connected and reboot I get the problem..I have to turn it off, reboot and then re-connect it.., or else the PC just keeps on telling me to hit ctrl-alt-del over and over again until I disconnect the USB drive and then reboot...

On the MSI website they have a USB Bios Update (dated 09/05; my Bios is 07/05 dated version) with very limited info as to what it's an upgrade for, except that it's an upgrade for some USB devices compatablitly issues..

I'm just curious as if I'll fix the problerm with this USB update, or if it may be something a bit more deeper in the system...Any pointers/help/advice/suggestions appreciated in advance..
March 30, 2006 3:03:13 AM

Disable the "USB boot" and "try other boot devices" in the BIOS. I'd update the BIOS if this doesn't help.
March 30, 2006 1:12:06 PM

Quote:
Disable the "USB boot" and "try other boot devices" in the BIOS.

That'll definitely fix it.

Nope, it's already disabled..Doesn't fix it..Guess I'll have to update the Bios and see what happens..

I'm a bit leary bout doing that cause other than that little annoyance, it's working all OK, and I'm a big follower of "if it an't broke, don't fix it"...
Related resources
March 30, 2006 1:20:36 PM

For some reason, it's looking for a boot record on your USB. Disabling this option should solve the problem. Is there an OS on that USB drive? Don't forget in the boot menue, don't let it search for other boot up drives.
March 30, 2006 1:29:42 PM

Check your boot order, the problem lies there, its hitting your USB first instead of your Sata's. The reason your getting the NTLDR is becuase there is no OS on the USB drive. so if you change the boot order in the BIOS it could fix the problem. There could be an error in the bios that the update would fix......try updating then change the boot order.
March 30, 2006 1:54:09 PM

I've seen this happen is there's a failed/corrupt OS on the drive, why I asked about a possible OS on it. I agree, it's pretty much a boot order problem from what you've described.
March 30, 2006 2:56:38 PM

Nope, no OS on the USB drive, just Jpeg's, Zips, RAR's and some MP3's..Just a storage disk... My Boot order is Floppy 1st, CD 2nd, Hard drive 3rd, and everything else is disabled..I've gone in and disabled the floppy and the CD, making the Hard drive the only boot device, and I still get the NTLDR error if the USB Device is connected and on..I've got the file to flash the Bios with the updated USB compatability file, but now I guess I've got to go and get some new floppies..been so long since I've used floppies, all the ones I'm trying to format according to the flash instructions won't work......figures....Normal for me..Thanks for all the replies and advice..I'll get'r done..
March 30, 2006 3:29:46 PM

Hang in there, you'll get r done ;)  Doesn't you MB have a utility to flash it for you?
March 30, 2006 3:35:37 PM

If it does, I don't know anything about it..it's a:
MSI K8N Neo2 Platinum (MS-7025)

The manufacturer has a Live update utility for doing that stuff, but all it does is search for the drivers, bios and utility files which may need updating and provides me with the ability to download each individual one in a zip file, no built in update capability as far as I'm aware..The USB update file isn't even included in the live update, just as a "specific user" type of download for certain unidentified Manufacturer types of USB devices..No other info about the file.
June 14, 2008 2:32:01 AM

did you or anyone else find a fix for the issue rds1955?

I have a similar issue when using a Western Digital 320G Passport (External USB Hard drive)

My computer reboots itself after a few minutes if the external HDD is connected. On reboot, it can't find the boot disk and I get the "ntldr is missing" error

There's no OS on the USB, and, BIOS on computer has USB boot disabled.

I have to manually select to boot from my IDE Harddrive everytime I boot now (such a pain)

Have re-installed OS (Windows XP Pro, SP2) and the same error re-occurs.

Motherboard is an Asus A8N-SLI
Processor AMD Athlon 64x2 Dual Core 3800+

Any help would be much appreciated!
!