Software? Problem with HP 4L

Archived from groups: comp.periphs.printers (More info?)

I have a HP 4L laser jet operating under XP Home, SP2. Up until
about 2 weeks ago it was working perfectly. Now however, a problem
has arisen with the first print job after boot up. A single sheet is
printed with 4 lines of code(?). All subsequent jobs print OK.

The following lines are printed:
X@PJL COMMENT HP LaserJet 4L
@PJL SET PAGEPROTECT=OFF
@PJL SET PAGEPROTECT=AUTO
@PJ
Any ideas how to prevent this from printing and returning the printer
to it's previous flawless operation?

Thanks
John Normile
3 answers Last reply
More about software problem
  1. Archived from groups: comp.periphs.printers (More info?)

    Have you tried deleting the printer driver and reinstalling it?


    "John Normile" <aajnorm@yahoo.com> wrote in message
    news:41fd8fd2.295558468@news.dallas.sbcglobal.net...
    > I have a HP 4L laser jet operating under XP Home, SP2. Up until
    > about 2 weeks ago it was working perfectly. Now however, a problem
    > has arisen with the first print job after boot up. A single sheet is
    > printed with 4 lines of code(?). All subsequent jobs print OK.
    >
    > The following lines are printed:
    > X@PJL COMMENT HP LaserJet 4L
    > @PJL SET PAGEPROTECT=OFF
    > @PJL SET PAGEPROTECT=AUTO
    > @PJ
    > Any ideas how to prevent this from printing and returning the printer
    > to it's previous flawless operation?
    >
    > Thanks
    > John Normile
  2. Archived from groups: comp.periphs.printers (More info?)

    > "John Normile" <aajnorm@yahoo.com> wrote in message
    > news:41fd8fd2.295558468@news.dallas.sbcglobal.net...
    >> I have a HP 4L laser jet operating under XP Home, SP2.
    >> Up until about 2 weeks ago it was working perfectly. Now
    >> however, a problem has arisen with the first print job
    >> after boot up. A single sheet is printed with 4 lines of
    >> code(?). All subsequent jobs print OK.
    >>
    >> The following lines are printed:
    >> X@PJL COMMENT HP LaserJet 4L
    >> @PJL SET PAGEPROTECT=OFF
    >> @PJL SET PAGEPROTECT=AUTO
    >> @PJ
    >> Any ideas how to prevent this from printing and returning
    >> the printer to it's previous flawless operation?
    >>
    >> Thanks
    >> John Normile

    This happened to me a several years ago (with Win95, actually)
    and turned out to be some file that got replaced by another
    program as part of a software install. All I had to do was
    restore the original file and the problem went away.

    The file in question back then was 'lpt.vxd'. This should at
    least give you a good starting place to search for an answer!
  3. Archived from groups: comp.periphs.printers (More info?)

    On Mon, 31 Jan 2005 02:07:12 GMT, aajnorm@yahoo.com (John Normile)
    wrote:

    >I have a HP 4L laser jet operating under XP Home, SP2. Up until
    >about 2 weeks ago it was working perfectly. Now however, a problem
    >has arisen with the first print job after boot up. A single sheet is
    >printed with 4 lines of code(?). All subsequent jobs print OK.
    >
    >The following lines are printed:
    >X@PJL COMMENT HP LaserJet 4L
    >@PJL SET PAGEPROTECT=OFF
    >@PJL SET PAGEPROTECT=AUTO
    >@PJ
    >Any ideas how to prevent this from printing and returning the printer
    >to it's previous flawless operation?


    I don't know why this is happening, but aside from the "X", what
    you're seeing is the correct PJL (Printer Job Language) setup for your
    printer that should begin each job. It looks like a spurious character
    is being sent on boot that messes this up, so the subsequent commands
    are being printed instead of executed.
    What might work is a process that runs on startup that clears the
    printer spool. My knowledge of Windows XP is zero, so I can't tell you
    exactly how to so set that up.

    Or it could be hardware setting or error with the port, either
    physical or logical.
Ask a new question

Read More

Printers Hewlett Packard Software Peripherals