Sign in with
Sign up | Sign in
Your question

Changing user id in update software screen in mac pro book

Last response: in Mac Os X
Share
September 9, 2012 6:51:11 AM

Hello,
I could reset password, change my name etc. But whenever i try to update software, a default user id is appearing. This field is in grey and I am unable to type my apple id, though password field is white. I am unable to update softwares du to this. Please let me know how to change this.
September 12, 2012 5:04:32 AM

Have you tried leaving that password field blank and just proceeding? Many users who started on an OSX 10.6 (Snow Leopard) or earlier system never setup a password for their default admin account because they didn't have to.

Is your user id an admin? You maybe need to add yourself as an admin user and use that user account to perform software updates.

Are you using an external drive for your system drive? External drives have their own list of user permissions and ACLs (access control lists), perhaps your user isn't an admin user on your external system drive.

If you're comfortable in terminal (and an admin user), you can view a list of all user accounts on your system and their permissions.
It's possible the software update application has been locked to a particular user. This can result from tinkering around with the unix system flags; it can also be solved by changing the 'uchg' system flag to 'nouchg' using 'sudo chflags,' but I wouldn't go editing system files from terminal if you aren't already familiar/comfortable working from a unix command line.

One solution would be to remove the '.applesetupdone' file from the root volume and restart the computer setting yourself up as the 'default' admin, but again, deleting root system files isn't recommended for someone not familiar with command line operation. The root volume is hidden and never mounted by your Mac; it contains many crucial system files, a misstep here could cause catastrophic system failure and potential data loss.
If you're computer is still covered by an AppleCare protection plan, you might just have an Apple tech take care of the problem for you.
m
0
l
September 13, 2012 5:57:07 PM

Don't know if you've solved your problem yet, but since your permissions conflict is with a system process (software update), you can try using Disk Utility's Verify & Repair Disk Permissions function.

Applications-->Disk Utility
Select your system volume on the left side (the indented volume, not the 'disk').
Click 'Verify Disk Permissions' on the bottom, then 'Repair Disk Permissions' if needed.

Good luck.
m
0
l
Related resources
Can't find your answer ? Ask !
November 30, 2013 6:22:10 AM

need iser id
m
0
l
November 30, 2013 6:22:38 AM

need user id
m
0
l
!