Sign in with
Sign up | Sign in
Your question

DOS subst command

Last response: in Windows XP
Share
Anonymous
September 12, 2004 9:54:14 PM

Archived from groups: microsoft.public.windowsxp.basics (More info?)

The DOS subst command will not work with my new machine:

HP pavilion ze5700 notebook computer
Windows XP with Service Pack 2 installed
At the c: prompt in DOS I type subst g:c:gdisk (or with a
back or foreword slash after the c:)  and get the error
message: Invalid parameter - G:c:gdisk
gdisk is a folder in the c: drive. I called the HP
service line and his Win 98 machine worked fine. He
suggest several things, none of which worked. Trying it
immediately after reboot had no effect. What now?

More about : dos subst command

Anonymous
September 13, 2004 12:26:14 AM

Archived from groups: microsoft.public.windowsxp.basics (More info?)

Bob Appleby wrote:
> The DOS subst command will not work with my new machine:
>
> HP pavilion ze5700 notebook computer
> Windows XP with Service Pack 2 installed
> At the c: prompt in DOS I type subst g:c:gdisk (or with a
> back or foreword slash after the c:)  and get the error
> message: Invalid parameter - G:c:gdisk
> gdisk is a folder in the c: drive. I called the HP
> service line and his Win 98 machine worked fine. He
> suggest several things, none of which worked. Trying it
> immediately after reboot had no effect. What now?

Are you neglecting the <space>?

g: c:\gdisk

Open Help and Support, type: subst and press the arrow button to see the
information.

--

Ronnie Vernon
Microsoft MVP
Windows Shell/User
Anonymous
September 13, 2004 1:15:46 PM

Archived from groups: microsoft.public.windowsxp.basics (More info?)

To see HELP for subst
Start a command prompt
Type:
subst /?
ENTER

--
Hope this helps. Let us know.
Wes

In news:abf101c4992c$307289c0$a601280a@phx.gbl,
Bob Appleby <boba@midcoast.com> hunted and pecked:
> The DOS subst command will not work with my new machine:
>
> HP pavilion ze5700 notebook computer
> Windows XP with Service Pack 2 installed
> At the c: prompt in DOS I type subst g:c:gdisk (or with a
> back or foreword slash after the c:)  and get the error
> message: Invalid parameter - G:c:gdisk
> gdisk is a folder in the c: drive. I called the HP
> service line and his Win 98 machine worked fine. He
> suggest several things, none of which worked. Trying it
> immediately after reboot had no effect. What now?
Related resources
Anonymous
September 18, 2004 10:39:43 AM

Archived from groups: microsoft.public.windowsxp.basics (More info?)

Many thanks to you and Wesley. Indeed it was a lack of a
space after the colon. My 1985 DOS manuel did not have
one and my brain chose to ignore the one in the current
help section. Duh! By the way I'm using it to narrow down
the area for the search command. It was taking too long
to search the whole C: drive.

Bob

>-----Original Message-----
>Bob Appleby wrote:
>> The DOS subst command will not work with my new
machine:
>>
>> HP pavilion ze5700 notebook computer
>> Windows XP with Service Pack 2 installed
>> At the c: prompt in DOS I type subst g:c:gdisk (or
with a
>> back or foreword slash after the c:)  and get the error
>> message: Invalid parameter - G:c:gdisk
>> gdisk is a folder in the c: drive. I called the HP
>> service line and his Win 98 machine worked fine. He
>> suggest several things, none of which worked. Trying
it
>> immediately after reboot had no effect. What now?
>
>Are you neglecting the <space>?
>
>g: c:\gdisk
>
>Open Help and Support, type: subst and press the
arrow button to see the
>information.
>
>--
>
>Ronnie Vernon
>Microsoft MVP
>Windows Shell/User
>
>
>.
>
Anonymous
September 18, 2004 4:59:31 PM

Archived from groups: microsoft.public.windowsxp.basics (More info?)

Bob Appleby wrote:
> Many thanks to you and Wesley. Indeed it was a lack of a
> space after the colon. My 1985 DOS manuel did not have
> one and my brain chose to ignore the one in the current
> help section. Duh! By the way I'm using it to narrow down
> the area for the search command. It was taking too long
> to search the whole C: drive.
>
> Bob




Your Welcome, Bob.

One thing that can significantly increase your search speed is to exclude
..zip files in the search. MVP Kelly has a simply procedure for doing this.
Take a look on her website.

Windows XP from A to Z:
http://www.kellys-korner-xp.com/xp_w.htm#z

--

Ronnie Vernon
Microsoft MVP
Windows Shell/User
!