Program Files folder read-only attribute won't stick

Archived from groups: microsoft.public.win98.gen_discussion (More info?)

I am trying to get the Program Files folder to display the warning message in
the left-hand pane when you open the folder in My Computer. In order to do
this, the read-only attribute needs to be set for the folder. This means that
it will display the folder.htt file in the left-hand pane.

The problem is that every time I start Windows, the read-only attribute is
always turned off! I have tried setting it through Windows Explorer and
through the attrib command in DOS but it always gets reset the next time I
start Windows. Why is this happening and how can I get the read-only
attribute to stay on?
11 answers Last reply
More about program files folder read only attribute stick
  1. Archived from groups: microsoft.public.win98.gen_discussion (More info?)

    Let it be! I'm sure I played with that once to my regret! Windows does
    not want it so, with Program Files!


    --
    Thanks or Good Luck,
    There may be humor in this post, and,
    Naturally, you will not sue,
    should things get worse after this,
    PCR
    pcrrcp@netzero.net
    "Daniel" <Daniel@discussions.microsoft.com> wrote in message
    news:D6195EB9-CA6F-4417-BA80-0024F6D5D166@microsoft.com...
    | I am trying to get the Program Files folder to display the warning
    message in
    | the left-hand pane when you open the folder in My Computer. In order
    to do
    | this, the read-only attribute needs to be set for the folder. This
    means that
    | it will display the folder.htt file in the left-hand pane.
    |
    | The problem is that every time I start Windows, the read-only
    attribute is
    | always turned off! I have tried setting it through Windows Explorer
    and
    | through the attrib command in DOS but it always gets reset the next
    time I
    | start Windows. Why is this happening and how can I get the read-only
    | attribute to stay on?
  2. Archived from groups: microsoft.public.win98.gen_discussion (More info?)

    That's odd because mine IS Read Only attributed and appearently always
    has been (I never even noticed before). That is the only attribute for
    the Program Files folder too if that makes a difference.

    I'm suspecting perhaps a setting in the Registry might play a part in
    this?
  3. Archived from groups: microsoft.public.win98.gen_discussion (More info?)

    Hi Lee

    Don't know... I did look at the Registry but couldn't find anything. Do you
    have any ideas?


    "Lee" wrote:

    > That's odd because mine IS Read Only attributed and appearently always
    > has been (I never even noticed before). That is the only attribute for
    > the Program Files folder too if that makes a difference.
    >
    > I'm suspecting perhaps a setting in the Registry might play a part in
    > this?
    >
    >
  4. Archived from groups: microsoft.public.win98.gen_discussion (More info?)

    I'm sure certain folders should never be made Hidden. Perhaps it wasn't
    Program Files, but System or Desktop that caused me grief, though.

    Note: If one turns on Thumbnails view for a folder in it's Properties,
    then Windows will automatically make the folder Hidden, & visa versa, as
    soon as one clicks Apply.

    Can that be what you did to Program Files?


    --
    Thanks or Good Luck,
    There may be humor in this post, and,
    Naturally, you will not sue,
    should things get worse after this,
    PCR
    pcrrcp@netzero.net
    "Lee" <melee5@my-deja.com> wrote in message
    news:1114080720.123465.19160@o13g2000cwo.googlegroups.com...
    | That's odd because mine IS Read Only attributed and appearently always
    | has been (I never even noticed before). That is the only attribute
    for
    | the Program Files folder too if that makes a difference.
    |
    | I'm suspecting perhaps a setting in the Registry might play a part in
    | this?
    |
  5. Archived from groups: microsoft.public.win98.gen_discussion (More info?)

    Hi PCR

    A big thank you to you! It looks like your thumbnails suggestion worked. I
    checked the "Enable thumbnail view" option for the Program Files folder and
    the read-only attribute was set. Next, I un-checked the thumbnail option and
    the read-only attribute still stayed set. I then re-booted the computer and...

    .... the read-only attribute was still set! At last - it looks like it's
    stuck and I now get the warning message on the left-hand pane for the Program
    Files folder. Thanks again.

    Regards

    Daniel


    "PCR" wrote:

    > I'm sure certain folders should never be made Hidden. Perhaps it wasn't
    > Program Files, but System or Desktop that caused me grief, though.
    >
    > Note: If one turns on Thumbnails view for a folder in it's Properties,
    > then Windows will automatically make the folder Hidden, & visa versa, as
    > soon as one clicks Apply.
    >
    > Can that be what you did to Program Files?
    >
    >
    > --
    > Thanks or Good Luck,
    > There may be humor in this post, and,
    > Naturally, you will not sue,
    > should things get worse after this,
    > PCR
    > pcrrcp@netzero.net
    > "Lee" <melee5@my-deja.com> wrote in message
    > news:1114080720.123465.19160@o13g2000cwo.googlegroups.com...
    > | That's odd because mine IS Read Only attributed and appearently always
    > | has been (I never even noticed before). That is the only attribute
    > for
    > | the Program Files folder too if that makes a difference.
    > |
    > | I'm suspecting perhaps a setting in the Registry might play a part in
    > | this?
    > |
    >
    >
    >
  6. Archived from groups: microsoft.public.win98.gen_discussion (More info?)

    Hi PCR (again)

    BTW, hope you found that link I posted to the McAfee SuperDAT downloads
    useful. Oh, I should have mentioned that it asks you whether or not you have
    a PrimeSupport agreement - wouldn't worry about this too much, just click
    "Agree" and you're done.

    Regards

    Daniel


    > "PCR" wrote:
    >
    > > I'm sure certain folders should never be made Hidden. Perhaps it wasn't
    > > Program Files, but System or Desktop that caused me grief, though.
    > >
    > > Note: If one turns on Thumbnails view for a folder in it's Properties,
    > > then Windows will automatically make the folder Hidden, & visa versa, as
    > > soon as one clicks Apply.
    > >
    > > Can that be what you did to Program Files?
    > >
    > >
    > > --
    > > Thanks or Good Luck,
    > > There may be humor in this post, and,
    > > Naturally, you will not sue,
    > > should things get worse after this,
    > > PCR
    > > pcrrcp@netzero.net
    > > "Lee" <melee5@my-deja.com> wrote in message
    > > news:1114080720.123465.19160@o13g2000cwo.googlegroups.com...
    > > | That's odd because mine IS Read Only attributed and appearently always
    > > | has been (I never even noticed before). That is the only attribute
    > > for
    > > | the Program Files folder too if that makes a difference.
    > > |
    > > | I'm suspecting perhaps a setting in the Registry might play a part in
    > > | this?
    > > |
    > >
    > >
    > >
  7. Archived from groups: microsoft.public.win98.gen_discussion (More info?)

    Yes, I saw the link you posted, thanks. Well... I'm glad you got what
    you wanted. Perhaps the Thumbnails box jogged a setting or something.
    Still, in mine, unchecking the Thumbnails box & clicking apply removed
    the Hidden attribute.

    Definitely, don't try this with C:\Windows\System or with
    C:\Windows\Desktop. I am fairly certain one of those leads to an
    exceedingly unpleasant experience!


    --
    Thanks or Good Luck,
    There may be humor in this post, and,
    Naturally, you will not sue,
    should things get worse after this,
    PCR
    pcrrcp@netzero.net
    "Daniel" <Daniel@discussions.microsoft.com> wrote in message
    news:B7793D2E-0F42-4AE8-B987-52265B151DC3@microsoft.com...
    | Hi PCR (again)
    |
    | BTW, hope you found that link I posted to the McAfee SuperDAT
    downloads
    | useful. Oh, I should have mentioned that it asks you whether or not
    you have
    | a PrimeSupport agreement - wouldn't worry about this too much, just
    click
    | "Agree" and you're done.
    |
    | Regards
    |
    | Daniel
    |
    |
    | > "PCR" wrote:
    | >
    | > > I'm sure certain folders should never be made Hidden. Perhaps it
    wasn't
    | > > Program Files, but System or Desktop that caused me grief, though.
    | > >
    | > > Note: If one turns on Thumbnails view for a folder in it's
    Properties,
    | > > then Windows will automatically make the folder Hidden, & visa
    versa, as
    | > > soon as one clicks Apply.
    | > >
    | > > Can that be what you did to Program Files?
    | > >
    | > >
    | > > --
    | > > Thanks or Good Luck,
    | > > There may be humor in this post, and,
    | > > Naturally, you will not sue,
    | > > should things get worse after this,
    | > > PCR
    | > > pcrrcp@netzero.net
    | > > "Lee" <melee5@my-deja.com> wrote in message
    | > > news:1114080720.123465.19160@o13g2000cwo.googlegroups.com...
    | > > | That's odd because mine IS Read Only attributed and appearently
    always
    | > > | has been (I never even noticed before). That is the only
    attribute
    | > > for
    | > > | the Program Files folder too if that makes a difference.
    | > > |
    | > > | I'm suspecting perhaps a setting in the Registry might play a
    part in
    | > > | this?
    | > > |
    | > >
    | > >
    | > >
  8. Archived from groups: microsoft.public.win98.gen_discussion (More info?)

    Hi PCR

    Now that I've fixed the Program Files folder issue, I'm definitely leaving
    the rest of the folders alone!

    Regards

    Daniel


    "PCR" wrote:

    > Yes, I saw the link you posted, thanks. Well... I'm glad you got what
    > you wanted. Perhaps the Thumbnails box jogged a setting or something.
    > Still, in mine, unchecking the Thumbnails box & clicking apply removed
    > the Hidden attribute.
    >
    > Definitely, don't try this with C:\Windows\System or with
    > C:\Windows\Desktop. I am fairly certain one of those leads to an
    > exceedingly unpleasant experience!
    >
    >
    > --
    > Thanks or Good Luck,
    > There may be humor in this post, and,
    > Naturally, you will not sue,
    > should things get worse after this,
    > PCR
    > pcrrcp@netzero.net
    > "Daniel" <Daniel@discussions.microsoft.com> wrote in message
    > news:B7793D2E-0F42-4AE8-B987-52265B151DC3@microsoft.com...
    > | Hi PCR (again)
    > |
    > | BTW, hope you found that link I posted to the McAfee SuperDAT
    > downloads
    > | useful. Oh, I should have mentioned that it asks you whether or not
    > you have
    > | a PrimeSupport agreement - wouldn't worry about this too much, just
    > click
    > | "Agree" and you're done.
    > |
    > | Regards
    > |
    > | Daniel
    > |
    > |
    > | > "PCR" wrote:
    > | >
    > | > > I'm sure certain folders should never be made Hidden. Perhaps it
    > wasn't
    > | > > Program Files, but System or Desktop that caused me grief, though.
    > | > >
    > | > > Note: If one turns on Thumbnails view for a folder in it's
    > Properties,
    > | > > then Windows will automatically make the folder Hidden, & visa
    > versa, as
    > | > > soon as one clicks Apply.
    > | > >
    > | > > Can that be what you did to Program Files?
    > | > >
    > | > >
    > | > > --
    > | > > Thanks or Good Luck,
    > | > > There may be humor in this post, and,
    > | > > Naturally, you will not sue,
    > | > > should things get worse after this,
    > | > > PCR
    > | > > pcrrcp@netzero.net
    > | > > "Lee" <melee5@my-deja.com> wrote in message
    > | > > news:1114080720.123465.19160@o13g2000cwo.googlegroups.com...
    > | > > | That's odd because mine IS Read Only attributed and appearently
    > always
    > | > > | has been (I never even noticed before). That is the only
    > attribute
    > | > > for
    > | > > | the Program Files folder too if that makes a difference.
    > | > > |
    > | > > | I'm suspecting perhaps a setting in the Registry might play a
    > part in
    > | > > | this?
    > | > > |
    > | > >
    > | > >
    > | > >
    >
    >
    >
  9. Archived from groups: microsoft.public.win98.gen_discussion (More info?)

    Not here no as I always use detail view and delete desktop.ini and
    folder.htt files with a passion. I'm now suspecting that it's
    desktop.ini file (or lack of) that was playing a part in Daniel's issue
    which appears to be fixed now - that's what I call I a lucky shot PCR!!
    I'd still take credit for it though if I were you.

    No thanks on making Systems folder Read Only, I'll leave well enough
    alone there.
  10. Archived from groups: microsoft.public.win98.gen_discussion (More info?)

    Goooood! It was a horrid experience that I needed to undo in DOS! Glad
    you've gotten what you wanted.


    --
    Thanks or Good Luck,
    There may be humor in this post, and,
    Naturally, you will not sue,
    should things get worse after this,
    PCR
    pcrrcp@netzero.net
    "Daniel" <Daniel@discussions.microsoft.com> wrote in message
    news:659A7149-5792-4FAF-B969-7749BD89503A@microsoft.com...
    | Hi PCR
    |
    | Now that I've fixed the Program Files folder issue, I'm definitely
    leaving
    | the rest of the folders alone!
    |
    | Regards
    |
    | Daniel
    |
    |
    | "PCR" wrote:
    |
    | > Yes, I saw the link you posted, thanks. Well... I'm glad you got
    what
    | > you wanted. Perhaps the Thumbnails box jogged a setting or
    something.
    | > Still, in mine, unchecking the Thumbnails box & clicking apply
    removed
    | > the Hidden attribute.
    | >
    | > Definitely, don't try this with C:\Windows\System or with
    | > C:\Windows\Desktop. I am fairly certain one of those leads to an
    | > exceedingly unpleasant experience!
    | >
    | >
    | > --
    | > Thanks or Good Luck,
    | > There may be humor in this post, and,
    | > Naturally, you will not sue,
    | > should things get worse after this,
    | > PCR
    | > pcrrcp@netzero.net
    | > "Daniel" <Daniel@discussions.microsoft.com> wrote in message
    | > news:B7793D2E-0F42-4AE8-B987-52265B151DC3@microsoft.com...
    | > | Hi PCR (again)
    | > |
    | > | BTW, hope you found that link I posted to the McAfee SuperDAT
    | > downloads
    | > | useful. Oh, I should have mentioned that it asks you whether or
    not
    | > you have
    | > | a PrimeSupport agreement - wouldn't worry about this too much,
    just
    | > click
    | > | "Agree" and you're done.
    | > |
    | > | Regards
    | > |
    | > | Daniel
    | > |
    | > |
    | > | > "PCR" wrote:
    | > | >
    | > | > > I'm sure certain folders should never be made Hidden. Perhaps
    it
    | > wasn't
    | > | > > Program Files, but System or Desktop that caused me grief,
    though.
    | > | > >
    | > | > > Note: If one turns on Thumbnails view for a folder in it's
    | > Properties,
    | > | > > then Windows will automatically make the folder Hidden, & visa
    | > versa, as
    | > | > > soon as one clicks Apply.
    | > | > >
    | > | > > Can that be what you did to Program Files?
    | > | > >
    | > | > >
    | > | > > --
    | > | > > Thanks or Good Luck,
    | > | > > There may be humor in this post, and,
    | > | > > Naturally, you will not sue,
    | > | > > should things get worse after this,
    | > | > > PCR
    | > | > > pcrrcp@netzero.net
    | > | > > "Lee" <melee5@my-deja.com> wrote in message
    | > | > > news:1114080720.123465.19160@o13g2000cwo.googlegroups.com...
    | > | > > | That's odd because mine IS Read Only attributed and
    appearently
    | > always
    | > | > > | has been (I never even noticed before). That is the only
    | > attribute
    | > | > > for
    | > | > > | the Program Files folder too if that makes a difference.
    | > | > > |
    | > | > > | I'm suspecting perhaps a setting in the Registry might play
    a
    | > part in
    | > | > > | this?
    | > | > > |
    | > | > >
    | > | > >
    | > | > >
    | >
    | >
    | >
  11. Archived from groups: microsoft.public.win98.gen_discussion (More info?)

    Absolutely, let System\ be or undo it in DOS! Also, Some Desktop.ini
    should not be deleted...

    Acc. to "Windows 98 Secrets" (Livingston/Straub), p. 199, special
    folders can also contain a Desktop.ini which "may have a reference to a
    dynamic link library (dll) file that defines a specific set of behaviors
    for the folder".

    I'm glad it worked for him, is all, to use Thumbnail View for it! It
    must have jogged a setting. Well, perhaps it added a fit/proper
    Desktop.ini.


    --
    Thanks or Good Luck,
    There may be humor in this post, and,
    Naturally, you will not sue,
    should things get worse after this,
    PCR
    pcrrcp@netzero.net
    "Lee" <melee5@my-deja.com> wrote in message
    news:1114506998.723808.82860@f14g2000cwb.googlegroups.com...
    | Not here no as I always use detail view and delete desktop.ini and
    | folder.htt files with a passion. I'm now suspecting that it's
    | desktop.ini file (or lack of) that was playing a part in Daniel's
    issue
    | which appears to be fixed now - that's what I call I a lucky shot
    PCR!!
    | I'd still take credit for it though if I were you.
    |
    | No thanks on making Systems folder Read Only, I'll leave well enough
    | alone there.
    |
Ask a new question

Read More

Read Only Microsoft Windows Displays