Why is alg.exe process running?

Archived from groups: microsoft.public.windowsxp.basics,microsoft.public.windowsxp.general,microsoft.public.windowsxp.perform_maintain (More info?)

Hello
I turned off Windows Firewall. I do not use Internet connection sharing. Why
is alg.exe process running?
OS is Windows XP Pro SP2.
4 answers Last reply
More about process running
  1. Archived from groups: microsoft.public.windowsxp.basics,microsoft.public.windowsxp.general,microsoft.public.windowsxp.perform_maintain (More info?)

    Start | Run | Type: services.msc | OK |
    Double click: Application Layer Gateway Service |
    Set to: Disabled | Apply | Click the Stop button | OK |
    Close Services

    --
    Hope this helps. Let us know.
    Wes

    In news:%23$u7kVYmEHA.2096@TK2MSFTNGP15.phx.gbl,
    Dmitriy Kopnichev <kopn@hotbox.ruDELETE> hunted and pecked:
    > Hello
    > I turned off Windows Firewall. I do not use Internet connection
    > sharing. Why is alg.exe process running?
    > OS is Windows XP Pro SP2.
  2. Archived from groups: microsoft.public.windowsxp.basics (More info?)

    Thank you
    "Blane" <a-blclar@online.microsoft.com> wrote in message
    news:ti97ZdZmEHA.3024@cpmsftngxa10.phx.gbl...
    > Dmitriy,
    >
    > Thank you for your post.
    >
    > There is always the potential that a malicious copy of the alg.exe has
    > been
    > installed by a spyware program. If the file is not in either
    > c:\winnt\system32 or c:\windows\system32 then that copy is very suspect.
    > Try renaming the file (if it is outside of c:\winnt\system32 or
    > c:\windows\system32) and reboot. See if the process starts and you can
    > still access the internet.
    >
    > I would recommend running a third party spyware tool to scan for spyware
    > as
    > well.
    >
    > Best regards,
    > Blane Clark
    >
    >
    > This posting is provided "AS IS" with no warranties, and confers no
    > rights.
    > You assume all risk for your use.
    > (C) 2003 Microsoft Corporation. All rights reserved
  3. Archived from groups: microsoft.public.windowsxp.basics,microsoft.public.windowsxp.general,microsoft.public.windowsxp.perform_maintain (More info?)

    Thanks
    "Wesley Vogel" <123WVogel955@comcast.net> wrote in message
    news:uKzpz0ZmEHA.3452@TK2MSFTNGP15.phx.gbl...
    > Start | Run | Type: services.msc | OK |
    > Double click: Application Layer Gateway Service |
    > Set to: Disabled | Apply | Click the Stop button | OK |
    > Close Services
    >
    > --
    > Hope this helps. Let us know.
    > Wes
    >
    > In news:%23$u7kVYmEHA.2096@TK2MSFTNGP15.phx.gbl,
    > Dmitriy Kopnichev <kopn@hotbox.ruDELETE> hunted and pecked:
    >> Hello
    >> I turned off Windows Firewall. I do not use Internet connection
    >> sharing. Why is alg.exe process running?
    >> OS is Windows XP Pro SP2.
  4. Archived from groups: microsoft.public.windowsxp.basics,microsoft.public.windowsxp.general,microsoft.public.windowsxp.perform_maintain (More info?)

    Application Layer Gateway Service turned to Manual at Windows Firewall
    turning off. I think alg.exe will not start anymore.
    "Wesley Vogel" <123WVogel955@comcast.net> wrote in message
    news:uKzpz0ZmEHA.3452@TK2MSFTNGP15.phx.gbl...
    > Start | Run | Type: services.msc | OK |
    > Double click: Application Layer Gateway Service |
    > Set to: Disabled | Apply | Click the Stop button | OK |
    > Close Services
    >
    > --
    > Hope this helps. Let us know.
    > Wes
    >
    > In news:%23$u7kVYmEHA.2096@TK2MSFTNGP15.phx.gbl,
    > Dmitriy Kopnichev <kopn@hotbox.ruDELETE> hunted and pecked:
    >> Hello
    >> I turned off Windows Firewall. I do not use Internet connection
    >> sharing. Why is alg.exe process running?
    >> OS is Windows XP Pro SP2.
Ask a new question

Read More

Microsoft Internet Connection Windows XP