Sign in with
Sign up | Sign in
Your question

MS-DOS Compatibility Mode

Last response: in Windows 95/98/ME
Share
Anonymous
May 8, 2005 3:11:32 PM

Archived from groups: microsoft.public.win98.gen_discussion (More info?)

I hope this is the right group, at least for starters. I use Windows 98SE.

The Problem: Under system properties, screen performance, there is a
message: "Compatibility-mode paging reduces overall system performance."
The problem began when I installed then uninstalled hardware and software
designed to capture video and convert VHS tapes into mpg files. Since then,
when I click on system properties, device manager, there a yellow
exclamation mark by each of the first two lines under hard disk
controllers. These lines say “Primary IDE controller (single fifo)” and
“Secondary IDE controller (single fifo).” The third line says “Standard
Dual PCI-IDE controller.” The next time I started up the computer, before
Windows completely loaded, I got a blue screen that began: “Your multi
function device (Standard Dual PCI IDE Controller) has some child devices
using compatibility-mode drivers. This configuration is not supported, so
your computer has been halted ....”

Attempted fixes so far: I found Microsoft's articles 130179
(Troubleshooting MS-DOS Compatibility Mode on Hard Disks, rev 3/17/05) and
151911 (MS-DOS Compatibility Mode Problems with PCI IDE Controllers, rev
12/16/04). Following the advice there, I ran a regedit, deleted the NOIDE
value, and rebooted. No improvement.

I'm stuck as to where to go next. I infer that the old driver(s) were
somehow overwritten by some kind of generic drivers. I do have a complete
system backup tape from last month before the problem started. I could
maybe restore the registry and proper drivers if I knew what they are
called and where they are located. Also, the store that assembled this
computer in 2001 is now out of business; but at the time they did burn and
give me a CD marked “image” along with the commercial driver disks. Maybe
there is something there to help me restore the system to the way it was,
but I have never dealt with image disks before and would not know where to
start.

All knowledgeable suggestions appreciated.

Paul in San Francisco

More about : dos compatibility mode

Anonymous
May 8, 2005 7:17:37 PM

Archived from groups: microsoft.public.win98.gen_discussion (More info?)

Delete the noide value from Regedit, then start in Safe Mode, open Device Manager in
Safe Mode, expand the Hard disk controllers category, select and remove all
instances of Primary IDE Controller and Secondary IDE Controller, and then all other
items listed in that category. Don't worry if you get a message saying you can't
remove the Standard Dual PCI-IDE controller. Look in the other categories and see
if any vestige of the hardware you had installed for video capture is still
there....if so, remove all instances of that also. If there is an "Other" category
in DM, expand it and remove everything listed there. Expand the CDROM category,
Floppy Disk Controllers category, Disk Drives category....if there are duplicates of
any devices there, remove ALL instances of that device.
For now, leave the other categories alone, especially if you are not sure if you
have driver disks for the rest of the devices.
When done, click OK\Close, and restart in normal mode. Windows should detect the
hardware and install its own drivers. Reboot when prompted.

Then check and see if the problem still exists, and post back here.
--
Glen Ventura, MS MVP Shell/User, A+
http://dts-l.org/goodpost.htm
http://www.microsoft.com/communities/conduct/default.ms...


"Paul MR" <pmr921@yahoo.com> wrote in message
news:eLV9Zk$UFHA.3636@TK2MSFTNGP14.phx.gbl...
> I hope this is the right group, at least for starters. I use Windows 98SE.
>
> The Problem: Under system properties, screen performance, there is a
> message: "Compatibility-mode paging reduces overall system performance."
> The problem began when I installed then uninstalled hardware and software
> designed to capture video and convert VHS tapes into mpg files. Since then,
> when I click on system properties, device manager, there a yellow
> exclamation mark by each of the first two lines under hard disk
> controllers. These lines say “Primary IDE controller (single fifo)” and
> “Secondary IDE controller (single fifo).” The third line says “Standard
> Dual PCI-IDE controller.” The next time I started up the computer, before
> Windows completely loaded, I got a blue screen that began: “Your multi
> function device (Standard Dual PCI IDE Controller) has some child devices
> using compatibility-mode drivers. This configuration is not supported, so
> your computer has been halted ....”
>
> Attempted fixes so far: I found Microsoft's articles 130179
> (Troubleshooting MS-DOS Compatibility Mode on Hard Disks, rev 3/17/05) and
> 151911 (MS-DOS Compatibility Mode Problems with PCI IDE Controllers, rev
> 12/16/04). Following the advice there, I ran a regedit, deleted the NOIDE
> value, and rebooted. No improvement.
>
> I'm stuck as to where to go next. I infer that the old driver(s) were
> somehow overwritten by some kind of generic drivers. I do have a complete
> system backup tape from last month before the problem started. I could
> maybe restore the registry and proper drivers if I knew what they are
> called and where they are located. Also, the store that assembled this
> computer in 2001 is now out of business; but at the time they did burn and
> give me a CD marked “image” along with the commercial driver disks. Maybe
> there is something there to help me restore the system to the way it was,
> but I have never dealt with image disks before and would not know where to
> start.
>
> All knowledgeable suggestions appreciated.
>
> Paul in San Francisco
Anonymous
May 9, 2005 5:52:33 AM

Archived from groups: microsoft.public.win98.gen_discussion (More info?)

On Sun, 08 May 2005 11:11:32 -0700, Paul MR <pmr921@yahoo.com>
wrote:

>I hope this is the right group, at least for starters. I use Windows 98SE.
>
>The Problem: Under system properties, screen performance, there is a
>message: "Compatibility-mode paging reduces overall system performance."
>The problem began when I installed then uninstalled hardware and software
>designed to capture video and convert VHS tapes into mpg files. Since then,
>when I click on system properties, device manager, there a yellow
>exclamation mark by each of the first two lines under hard disk
>controllers. These lines say “Primary IDE controller (single fifo)” and
>“Secondary IDE controller (single fifo).” The third line says “Standard
>Dual PCI-IDE controller.” The next time I started up the computer, before
>Windows completely loaded, I got a blue screen that began: “Your multi
>function device (Standard Dual PCI IDE Controller) has some child devices
>using compatibility-mode drivers. This configuration is not supported, so
>your computer has been halted ....”
>
>Attempted fixes so far: I found Microsoft's articles 130179
>(Troubleshooting MS-DOS Compatibility Mode on Hard Disks, rev 3/17/05) and
>151911 (MS-DOS Compatibility Mode Problems with PCI IDE Controllers, rev
>12/16/04). Following the advice there, I ran a regedit, deleted the NOIDE
>value, and rebooted. No improvement.
>
>I'm stuck as to where to go next. I infer that the old driver(s) were
>somehow overwritten by some kind of generic drivers. I do have a complete
>system backup tape from last month before the problem started. I could
>maybe restore the registry and proper drivers if I knew what they are
>called and where they are located. Also, the store that assembled this
>computer in 2001 is now out of business; but at the time they did burn and
>give me a CD marked “image” along with the commercial driver disks. Maybe
>there is something there to help me restore the system to the way it was,
>but I have never dealt with image disks before and would not know where to
>start.
>
>All knowledgeable suggestions appreciated.
>
>Paul in San Francisco

Paul,

Dos Compatibility Mode can also be caused by Dos device drivers in
the autoexec.bat and config.sys files. Check those. An entry may
have been made by the video software. The NOIDE registry entry is a
"safe mode" and is not always removed even if the condition is fixed
so you need to check that after every change.

Regards,

Bill Watt
Computer Help and Information http://home.ptd.net/~bwatt/
Related resources
Anonymous
May 9, 2005 1:28:42 PM

Archived from groups: microsoft.public.win98.gen_discussion (More info?)

Control panel, system, performance tab: any comments about MS DOS
compatibility? If so:

MS-DOS Compatibility Mode Problems with PCI-IDE Controllers [Q151911]
http://support.microsoft.com/support/kb/articles/q151/9...

Troubleshooting MS-DOS Compatibility Mode on Hard Disks [Q130179]
http://support.microsoft.com/support/kb/articles/q130/1...

Large IDE Hard Disk May Run In Compatibility Mode [Q175629]
http://support.microsoft.com/support/kb/articles/q175/6...

FAT32 Using Compatibility Mode with OnTrack Disk Manager [Q152701]
http://support.microsoft.com/support/kb/articles/q152/7...

Troubleshooting Floppy Disk Drive Problems in Windows [Q131690]
http://support.microsoft.com/support/kb/articles/q131/6...

--
Regards

Ron Badour, MS MVP W95/98 Systems
----

Chris Quirke
http://users.iafrica.com/c/cq/cquirke/doscompat.htm

--
Jack E. Martinelli 2002-05 MS MVP for Shell/User / DTS
Help us help you: http://www.dts-L.org/goodpost.htm
In Memorium: Alex Nichol
http://www.microsoft.com/windowsxp/expertzone/meetexper...
Your cooperation is very appreciated.
------
"Paul MR" <pmr921@yahoo.com> wrote in message
news:eLV9Zk$UFHA.3636@TK2MSFTNGP14.phx.gbl...
> I hope this is the right group, at least for starters. I use Windows
98SE.
>
> The Problem: Under system properties, screen performance, there is a
> message: "Compatibility-mode paging reduces overall system performance."
> The problem began when I installed then uninstalled hardware and software
> designed to capture video and convert VHS tapes into mpg files. Since
then,
> when I click on system properties, device manager, there a yellow
> exclamation mark by each of the first two lines under hard disk
> controllers. These lines say “Primary IDE controller (single fifo)” and
> “Secondary IDE controller (single fifo).” The third line says “Standard
> Dual PCI-IDE controller.” The next time I started up the computer, before
> Windows completely loaded, I got a blue screen that began: “Your multi
> function device (Standard Dual PCI IDE Controller) has some child devices
> using compatibility-mode drivers. This configuration is not supported, so
> your computer has been halted ....”
>
> Attempted fixes so far: I found Microsoft's articles 130179
> (Troubleshooting MS-DOS Compatibility Mode on Hard Disks, rev 3/17/05) and
> 151911 (MS-DOS Compatibility Mode Problems with PCI IDE Controllers, rev
> 12/16/04). Following the advice there, I ran a regedit, deleted the NOIDE
> value, and rebooted. No improvement.
>
> I'm stuck as to where to go next. I infer that the old driver(s) were
> somehow overwritten by some kind of generic drivers. I do have a complete
> system backup tape from last month before the problem started. I could
> maybe restore the registry and proper drivers if I knew what they are
> called and where they are located. Also, the store that assembled this
> computer in 2001 is now out of business; but at the time they did burn and
> give me a CD marked “image” along with the commercial driver disks. Maybe
> there is something there to help me restore the system to the way it was,
> but I have never dealt with image disks before and would not know where to
> start.
>
> All knowledgeable suggestions appreciated.
>
> Paul in San Francisco
Anonymous
May 14, 2005 6:49:35 AM

Archived from groups: microsoft.public.win98.gen_discussion (More info?)

glee wrote:
> Delete the noide value from Regedit, then start in Safe Mode, open Device Manager in
> Safe Mode, expand the Hard disk controllers category, select and remove all
> instances of Primary IDE Controller and Secondary IDE Controller, and then all other
> items listed in that category. Don't worry if you get a message saying you can't
> remove the Standard Dual PCI-IDE controller. Look in the other categories and see
> if any vestige of the hardware you had installed for video capture is still
> there....if so, remove all instances of that also. If there is an "Other" category
> in DM, expand it and remove everything listed there. Expand the CDROM category,
> Floppy Disk Controllers category, Disk Drives category....if there are duplicates of
> any devices there, remove ALL instances of that device.
> For now, leave the other categories alone, especially if you are not sure if you
> have driver disks for the rest of the devices.
> When done, click OK\Close, and restart in normal mode. Windows should detect the
> hardware and install its own drivers. Reboot when prompted.
>
> Then check and see if the problem still exists, and post back here.

Thanks to you (and the others) for your suggestions. I did the best I
could, without joy. After days of struggle, the bottom line is that a tech
professional upgraded Windows 98 to Windows 2000, and everything I've tried
to use in the last day and a half is working again. Knock wood.

Paul in San Francisco
Anonymous
May 14, 2005 11:02:49 AM

Archived from groups: microsoft.public.win98.gen_discussion (More info?)

"Paul MR" <pmr921@yahoo.com> wrote in message
news:eoyXsnGWFHA.3076@TK2MSFTNGP12.phx.gbl...
> glee wrote:
> > Delete the noide value from Regedit, then start in Safe Mode, open Device
Manager in
> > Safe Mode, expand the Hard disk controllers category, select and remove all
> > instances of Primary IDE Controller and Secondary IDE Controller, and then all
other
> > items listed in that category. Don't worry if you get a message saying you
can't
> > remove the Standard Dual PCI-IDE controller. Look in the other categories and
see
> > if any vestige of the hardware you had installed for video capture is still
> > there....if so, remove all instances of that also. If there is an "Other"
category
> > in DM, expand it and remove everything listed there. Expand the CDROM category,
> > Floppy Disk Controllers category, Disk Drives category....if there are
duplicates of
> > any devices there, remove ALL instances of that device.
> > For now, leave the other categories alone, especially if you are not sure if you
> > have driver disks for the rest of the devices.
> > When done, click OK\Close, and restart in normal mode. Windows should detect
the
> > hardware and install its own drivers. Reboot when prompted.
> >
> > Then check and see if the problem still exists, and post back here.

>
> Thanks to you (and the others) for your suggestions. I did the best I
> could, without joy. After days of struggle, the bottom line is that a tech
> professional upgraded Windows 98 to Windows 2000, and everything I've tried
> to use in the last day and a half is working again. Knock wood.

Instead of "struggling for days", you should have posted back here right away with
the results of my suggestions, as I stated in my reply. There was no reason to
upgrade just to fix the stated problem, as the tech should have been able to tell
you. Windows 2000 is a poor choice for the home user, though your hardware may not
be able to support Windows XP.
--
Glen Ventura, MS MVP Shell/User, A+
http://dts-l.org/goodpost.htm
!