Sign in with
Sign up | Sign in
Your question

Strange boot problems with Promise SATA 300TX4 controller

Last response: in Storage
Share
April 28, 2006 10:32:54 PM

Hi,

I am having a strange problem. I just installed an new Promise SATA300 TX4 controller in my machine as I did this I also decided to clone my original system drive and put in a new SATA drive instead. I put the new system drive on the MB controller channel 1 since I kept the PATA DVD-burner and HDD on channel 2. I then cloned my old system drive that was located on my other promise controller (Ultra 100 T2). No problems at all doing this. I then restarted the computer and changed the boot sequens in BIOS so that it pointed to the new SATA drive on channel 1 on the MB. This is when the funny things start to happen.

I booted up the machine again with 3 other SATA drives conected to my new controller and the computer just stalls on just before the windows loading screen. I got mad and turned of the last 3 SATA drives and rebooted, Now windows starts as usual.

I then tried to turn on the 3 drives when windows was allready running, and it worked perfectly. I initialize them and formatted them as usual. I then rebooted the system again to see if that helped but I was back to the same problem as before. Fixed it by turning them of and reboot.

So now I can use all my HDDs as long as I remember to turn the 3 new SATA drives of when booting.

My question is: What can be causing this?

Is it conflicts between my old promise controller and my new one?
Is it a bug in the drivers for the new controller?

Any suggestions on what to try?
April 29, 2006 4:42:58 PM

OK...here we go:

On the MB:
Channel 1 - SATA HDD (new system drive)
Channel 2 - Plextor DVD-burner (master) and PATA HDD (slave)

On the old controller (Ultra 100 TX2):
Channel 1 - PATA HDD (master (old system drive)) and PATA HDD (slave)
Channel 2 - PATA HDD (master) and PATA HDD (slave)

On the new controller (SATA 300 TX4):
Channel 1 - SATA HDD
Channel 2 - SATA HDD
Channel 3 - SATA HDD
Channel 4 - empty

All SATA drives are Samsung 250GB SATA II drives and all PATA except old systems drive are Western Digital 120 GB ATA-100 drives. Old system drive is a Western Digital 80 GB ATA-100 drive.

If it matters the order of the controllers in the PCI-slots are new controller (SATA 300 TX4) in the first slot (closest to the CPU) and then the old controller (Ultra-100 TX2) in the second slot. after these ones the following are inserted:
third slot: Haupaugge PVR-250
fourth slot: 3com 10/100 network card
fith slot: empty
April 30, 2006 9:16:28 AM

After testing all different PCI and Onboard controlle setups I have concluded that the bios in new controller is to blame since everything works if I just turn of the 3 HDDs on that controller forcing it to not load its bios. Then I can boot as normally and turn on the drives when Windows is up and running. A bit a pain in the ***, but it works until Promise comes out (hopefully) with a bios upgrade for the SATA 300 TX4 controller.

I did search for a new MB bios but there is none newer availible. Actually when I go into the MB bios with the drives turned on it sees all drives and assign them different names (e.g. BBS-0 to BBS-7) so I dfo not belive it to be any MB bios issues.

I will try contqacting Promise support to see if they may shed some light on this matter.

Thanks for the reply, wusy
Related resources
April 30, 2006 11:46:11 AM

I have a similar problem. my mainbord is Asus P4C800-E Deluxe.It has 4 sata ports 2 from intel southbridge and 2 from onboard promise sata controller. my system drive is connected to intel sata ports. when I connect a drive to a promise sata port the computer hangs on for 40-60 seconds just before the windows loading screen. You see a black screen. First I didnt know it would continue to boot. I forgetted it on that black screen and it continued to boot. drivers and bios is newest. I couldnt solve the problem. I lokked for a conflict and detached my X-Fi but no response. It was working before creative X-Fi. Sorry for my english.

Intel southbridge______________SATA1 WDRaptor 74GB
____________________________SATA2 WDRaptor 74GB These raptors are in raid0

Promise onboard sata controller__SATA3 Seagate 7200.8 120GB sata
___________________________SATA4 Empty
May 1, 2006 8:59:27 AM

After testing this weekend I noticed that the computer had become unstable and kept freezing and since Promise support told me to do exactly what I already had done I decided to remove the old controller card and try that. And it worked so I made some changes in the setup up of the drives (see below).

On the MB:
Channel 1: HDD (master) and HDD (slave)
Channel 2: DVD-Burner (master) and HDD (slave)

On the new controller (SATA 300 TX4):
Channel 1: SATA HDD (new system drive)
Channel 2: SATA HDD
Channel 3: SATA HDD
Channel 4: SATA HDD

This means that I will lose about 200GB of storage but i can always use those HDDs as backup drives since the HDD on the second MB Channel is sitting in a "fast" swap case accesible from the outside. I just take it out and change drive when I need to.

Thanks for all the help, by the way below is what Promise Support replyed:

Quote:
Dear sir , We recommand you to, try the following things : 1 Make sure th controllers and motherboard have the newest version of bios and drivers, 2 if that not work pleas disable the onboard card , 3 try only one controller at the time. Pleas note that the bios , and drivers is one of the most important to chek. With kind regards


By the way, sorry if my English made it hard to understand, but it sometimes is hard to describe a problem when you do not have english as your mothertounge (I am Swedish).
!