Sign in with
Sign up | Sign in
Your question

overclocking my x800 GTO

Last response: in Overclocking
Share
May 1, 2006 9:39:58 PM

within the past few weeks, I purchased a new x800 GTO AGP graphics card and installed it in my old dell 4550. (yeah i know, dell isn't the best but it is my first ever computer that i own.) Anyway, I recently downloaded the ATi tool and tried ocing it there, but when I get to about 600mhz memory speed, everything goes crazy and I have to turn the pc off and restart it. I know that the memory is capable of going all the way up to 980 or more, but why can't I get it there? Is it my system?

Specs:
P4@2.4ghz
intel 845PE motherboard
1280mb RAM

Also, I can't use the bios to overclock cuz it's Dell. (stupid dell)

More about : overclocking x800 gto

May 1, 2006 9:58:00 PM

490-600MHz = Memory speed.

980 = DDR (Double Data Rate) Memory speed. I.e., equivalent to a 490MHz memory speed, your card's stock.

Your card is currently crapping out at 1200, if you want to compare it to 980. I haven't any experience with such cards, but I'd say that's still pretty good.

Synergy6
May 1, 2006 10:00:18 PM

Ohhhhhh, that's why. I forgot about the ram speed. Sweeet. What about the VPU core running from 400 to 440mhz? if I put it up much more it craps out too.
Related resources
May 1, 2006 10:54:30 PM

It sounds like your card has an R430 core in it. That is the same one that I have in my AGP Sapphire X800GTO. The R430 is also the chip found on the X800XL. R430s are well known for not being terribly good overclockers. I don't think I have heard of anyone getting them much beyond about 450MHz. I currently have mine at 444MHz.

If you want some more performance, you can look into unlocking the 4 disabled pipes on the card. The GTO comes stock with 12 pixel pipes but the chips used have 16 pipes on them. ATItool can read information from your card that will tell you if it is unlockable.

Follow these instructions to find out if your card is unlockable:

Open ATItool, click the settings button and choose overclocking in the drop-down menu.

Scroll down until you can see the CONFIG_DIE_FUSES and CONFIG_SUBSTRATE_FUSES.

To determine if your card can be unlocked, check for an ‘F’ in the indicated positions of the hexadecimal numbers. The capital X represents any hexadecimal digit(0-9 or A-F).

CONFIG_DIE_FUSES 0xXXXXFXXX
(the fifth character after the little x must be an 'F')

CONFIG_SUBSTRATE_FUSES 0xXXXXXXXF
(the last character must be an 'F')

If ATItool reads an ‘F’ in the indicated spots, you should be able to unlock your card. If not, I am afraid you are out of luck.

If your card can be unlocked and you are interested in doing it I can help you out with how to do it.
May 1, 2006 11:41:37 PM

Yeah, I am very interested.

the conifg die fuses is all 'F's and the config substrate fuses is 0xFFFFFF9F.

ATI tool also says that it's an R430 core. Im guessing that it's unlockable. Can I do that with ATItool though? cuz if I have to use the BIOS it's not going to work cuz of Dell's stupid bios options.

Thanks alot.
May 2, 2006 12:22:50 AM

Unlocking involves modifying the VGA bios which is independant of the computer that the card is in. I have to leave home for a while but I'll try to get back to you later with more information.

BTW it does look like your card is unlockable. I think that most if not all of the Sapphire models these are right now.
May 2, 2006 4:41:56 AM

In ATItool click settings and select "Miscellaneous".

Click the button that says “Save VGA Bios to file...”. Give the file a simple name like “12pipe.bin”. This will be your backup copy.

Make a second copy, which will be modified, and name it something like “16pipe.bin”.

Download the hex editor from this website (I would recommend using the “stable” version instead of the beta version): http://www.mh-nexus.de/programs.htm#HxD
This software will allow you to modify your bios to enable the pipelines.

Extract the hex editor program and run it. Open “16pipe.bin”.

Find the row marked 00000070 and the column labeled ‘A’. You should find ‘61’ at that location. The second bit represents the number of disabled pixel pipe quads. Change the data value to ‘60’ to enable all 16 pixel pipes.

Note: If you ever get bord later you can mess around with disabling pipes. 1 means four pipes are disabled (X800GTO), 2 means eight pipes are disabled (X800GT), 3 means twelve pipes are disabled (yep only 4 left active).

Save the modified bios and exit the hex editor.

The next part of the process is creating a bootable device (floppy, CD, or USB flash drive) which will be used to flash VGA Bios. I used a floppy because it is easy.

For detailed information on how to do these things go to this link and read about flashing your VGA Bios: http://www.techpowerup.com/articles/overclocking/vidcar...
This link contains instructions for creating a bootable USB flashdrive if a floppy is not an option.

I recommend using ATIflash if you plan to do it in DOS.
You can download it at the bottom of this page:
http://www.techpowerup.com/bios/
I used version 3.09

You will want to put the contents of the ATIflash archive onto the bootable media as well as the two bios files (the backup copy and the new unlocked version).

Boot into DOS and type the following command at the prompt:
atiflash.exe -p 0 16pipe.bin

Note: This assumes that you followed my naming conventions.
May 3, 2006 2:45:08 AM

Ok. I did everything as you said and I had a problem with typing in the file. I assumed the 0 that you put in was the number, but that gave me an error. So I put in the letter 'O' and it did something on the disk for a second then said something like: ATIFLASH.exe -p (location) (file name) So i don't know if the card was flashed or not. I then checked out atitool and found that under the 'active piplines' row it said '12' not 16. I don't know if it worked or not.

Again, I did everything as you said.

thanks
May 3, 2006 3:45:17 AM

I did a similar BIOS update a few days ago, but instead went from X850 Pro to X850 XT PE.

When I flashed my BIOS it made a beep out of the PC speaker when it was done. My ATI Tools showed 12 pipes too but I restarted after my drivers were reinstalled and it showed 16.
May 3, 2006 4:36:17 AM

It was the number zero that I intended for you to use.

Do you remember what the error said?

You may need to add -f before the -p but I would need to know what the error said to be more sure.

The thing about drivers that superbrett2000 was talking about I don't think is an issue because to the computer the card is the same. He was flashing with a bios for a different card.
May 3, 2006 2:22:20 PM

I wrote down the error, but I am at school now and don't have the error. I will get the error and post it.

As far as the number 0 and the letter O, the number gave me the error.

i will get back to you.
May 3, 2006 9:23:28 PM

Ok. The error was: 0FL01 (and those are zeros)
May 3, 2006 10:25:43 PM

If ".bin" appears as part of the file name delete it. Then try flashing again. You still have to include the ".bin" when you type the command in DOS.

I am guessing that when you typed the file name you included the ".bin" when the program automatically saves it as a bin file type.
May 3, 2006 11:02:18 PM

Ok. You told me to add the '.bin' part to the filename. No matter, I'll try it with the file name as '16pipe' and NO .bin.

Do I need the -f before the -p?

Update: just tried it again, and the filenames showed up as just '16pipe' and NO .bin afterwards. I tried it again and all it showed up with is:
'Format: ATIFLASH -p <adapternam> <filename>

What am I doing wrong?
May 4, 2006 5:02:28 AM

Sorry for the confusion.
The command line should look like this:

atiflash.exe -p 0 16pipe.bin

I think your problem is the actual file name. When you look at the icon for the file in Windows, you should see 16pipe without the .bin
May 4, 2006 2:18:24 PM

Ok. I will try it again when I get home. Ill resave the files as just '16pipe' and '12pipe' with no .bin after.
a b U Graphics card
May 4, 2006 3:13:03 PM

Actualy you may want to run the command like this:

atiflash.exe -f -p 0 16pipe.bin

This way it will force the flash, if you use a bios that you downloaded from the web you will need that force command because the PIN number will be different.

I just tried to flash my 850pro to an 850xt and it wouldn't work with out the force I just recieve an error message 0FL01 and Pin not matching. Sad thing is my card doesn't seem to be able to activate the 4 xtra pipes even though its a vivo pro but its running 2.0 ram instead of 1.6 =(. However I can run the card at PE speed with out a problem and I can go higher but since I'm using stock fan don't want to risk it.
May 4, 2006 5:48:07 PM

ikaz,
If you look above at the stuff about the fuses, it should tell you if your card is unlockable. If it isn't unlockable the fuses won't have an 'F' in the two required locations.
May 5, 2006 12:01:04 AM

So should I try the -f -p ?
May 5, 2006 12:20:32 AM

ALright, i tried it again with renaming the files and typed in the -f -p thing. It didn't work before when I tried it, but now it did i think.

It said: Flashtype M25P05/c
10000/ 10000h bytes programmed
10000/ 10000h bytes verified.

And then I booted up in windows and started atitool. Guess what? it registered 16 pipelines active instead of the 12 before!!!! I think that means that everything is good.

So now if I needed to for some reason, I could do the same thing but input '12pipe' .bin and go back to the old bios then right?

And what benefit will the extra 4 pipes have on my performance? little? Big?

Thanks
May 5, 2006 5:45:41 AM

Great! I'm glad that you finally got it worked out. :D 
I wasn't sure if it required the -f because I started by using an XL bios before I knew how to mod my bios.

I gained about 500 points in 3DMark 2005 went from around 5000 to around 5500. That is on a P4 2.8C @ 3.5GHz and 1GB of dual channel DDR400. 8)
May 5, 2006 1:49:06 PM

I will run 3dmark05 when i get home and try it to see how much of an improvement it makes on my system.

Thanks for all of your help.
May 5, 2006 8:34:27 PM

so theoretically I should be able to over clock the core and memory speeds to the x850XT model of 540/ 590?
May 7, 2006 12:49:00 AM

Ok. I just ran 3dmark05 and recieved 4561 on it. I had the 16 pipes active and core @ 443 and memory @ 560. Origionally, when I oced everything to the same speeds, I got about 4200. but with the 16 pipes, it made a big difference.


One question: should I be able to oc the core to the 850xt speed of 540mhz and memory to 590 mhz with the unlocked pipelines?
May 7, 2006 5:58:19 AM

No you won't be able to overclock it any more. You are still limited by the physical capabilities of the hardware. You have an R430 which is the same core that is on the X800XL. The XL is clocked at 400core and 490mem so you are already beyond its factory settings. The R430 is known for its lackluster overclocking performance. It sounds like you are probably about at the max for your card. You can try pushing it further but unlocking the pipes has nothing to do with overclocking.
May 7, 2006 3:14:15 PM

Ok. I just thought that it should oc to the 850xt speeds because that's what the posted article made it out to be. Now that I know I can't overclock anymore, I won't keep testing core speed and having my system crash.

Thanks alot. Your help is greatly appreciated!!!! 8)
May 7, 2006 3:32:26 PM

Right, that article was primarily about unlocking the X800GTO2 which has the R480 GPU which is the same one used in the X850 XT. That is why they suggest using the X850 XT bios which would also overclock the card. If you were to try that it would just crash. You can still try to push your memroy. It is specified to go up to 600MHz (DDR1200) but probably won't make it that high.
May 8, 2006 12:32:20 AM

Alright, Ill try it.

Also, when I got my new gpu and I went to play half life 2, I noticed that the frame rates were alot slower with my ati gpu than my old MX 420. The MX 420 was running at an average of 70 fps and no lower on low detail, no AA etc running at 800 x 600. So I popped in my Ati gpu and ran it. Everything was slow. Of course it had all the details turned up, but I lowered the details to what the mx420 was running at and it still had an average of 35-40 fps. What could be causing half life to run so slow? I had to reinstall the nvidia drivers with my old card then uninstall them and install the ati drivers cuz I just put the ati gpu into my pc without uninstalling the old drivers. That made some of a difference, but there was nothing different with my pc or any spyware/viruses on my pc at both times.
May 8, 2006 6:45:47 PM

Do you have the latest drivers for your X800 or did you use the ones from the CD that came with it?

You might try uninstalling the drivers and using drivercleaner for both the Nvidia and ATI drivers. Then reinstall the newest drivers for your X800. I use Omega drivers instead of ATI's Catalyst drivers. I like the driver settings menues in the Omega drivers better than the Catalyst ones.

I know that with your old GF4 you were probably only running dirct X 7. With the X800 you would undoubtedly be running dx 9.0

Your CPU/Motherboard/RAM combo could be holding you back some but I doubt that is what is causing your problem since you are running 800x600 with low detail. If you haven't done it already, you can enable a framerate counter in games based on the Source engine by bringing up the game console. To enable it go into options inside the game and click the keyboard tab. Then click the advanced button and check the box that says something about the console. Then press the '~' key (next to the 1 key) and type "cl_showfps 2" and press enter.
May 8, 2006 9:31:18 PM

Yeah, I reinstalled the ati drivers. I think I was using the latest Ati drivers, but it made things run weird so I rolled back the drivers so it would make everything else run smoother. ??

What is the difference between the catalyst drivers and Omega drivers? Could that be the culprit of my low HL2 framerates?

And I also use the console and fps code for HL2 like you said. Actually there is more than one way to bring up the frames in HL2.

the last thing is I know I had updated the direct x drivers to 9.0c with my old Nvidia card. But I don't know if it ran in directx 7 or not.
May 8, 2006 10:03:00 PM

Does your frame rate go up when there is less to render like inside small rooms and stuff?

The Catalyst drivers should't cause a problem but who knows. You could try switching to Omega drivers. Omega drivers are just modified Catalyst drivers. I started using them because for some reason, the Catalyst control panel won't work on my system.

What I meant about directx is that I don't think a Geforce 4MX will run anything higher than dx7.

Another though, you could try disableing HDR in the game's video settings. I don't know how widely HDR has been implemented but it can easily kill your system performance. I haven't spent much time with Half Life 2 for a while. I have mostly been playing CS:S when I have the time. That game is a little easier on your system most of the time. I usually run 1600x1200 with everything on high except on AA and no AF. I don't remember if I turned off HDR or not but you could try it.

I think your motherboard is holding you back though because it only supports single channel DDR333 and may only be running at DDR266. I think it also only supports AGP 4x which could be limiting you. I still don't think that it should make you play at 800x600 with low detail though.


the last thing is I know I had updated the direct x drivers to 9.0c with my old Nvidia card. But I don't know if it ran in directx 7 or not.
May 9, 2006 1:18:46 PM

yeah, I turned HDR off and everything down to low and it gave me lower fps than my mx420.

As far as my motherboard goes, it does run the AGP slot at 4x instead of 8x, but the card can run on a 4x system. As far as the ram goes, I have a 256mb stick that came with my system and a kingston 1gb stick. both at ddr2700.
May 9, 2006 9:02:29 PM

:? Hmm...
You could try forcing the directx level to a lower setting.
Do do this type in the console mat_dxlevel xx

The xx represent the directx version without the decimal point.
For level 7.0 you would type 70.
For level 8.1 you would type 81.
etc.

I would maybe try 8.1 and see what happens. You can always switch back if it doesn't help. Some scenes in HL2 are going to make your framrate relatively low no matter what detail setting you are on. Places where there are a lot of lighting effects like water and long veiw distances can make your framrate tank.

Your CPU/Motherboard/memory are definately holding you back the question is how can you get acceptable performance. Have you tried to see if there is a clockgen that is compatible with your computer. That might allow you to overclock a bit which should help. If you do find one, don't go too far because it will overclock your PCI and AGP busses as well which usually don't overclock very well.
May 9, 2006 10:02:44 PM

Ok. Ill try that in half life2 and see what happens.

What is a 'clockgen' ??
May 9, 2006 10:48:47 PM

clockgen is a free utility that you can use to overclock some computers via software. It doesn't have to be supported in the bios as far as I know.
May 10, 2006 2:18:05 AM

Aright. I tried setting half life 2 to diretx 7 and 8.1 and 7 gave me the same frames as my mx420. So that's why it was giving me slower framerates. I know directx 7 is old, but what difference does it make if I run my current x800 card in directx 7 for hl2? Can I still crank up the graphics? or does the newer drivers cause the game to run or seem 'better'?

And where can I find clockgen?
Update: I saved clockgen onto my pc from pcid.com (i think). The only problem is that I dont know what to do to overclock things.
May 10, 2006 5:53:29 AM

Running in directx 7.0 will just disable some features that make the game look better. You can go ahead and crank up the graphics settings and see how it works. It looks as if your motherboard is really holding you back, but you probably aren't in the market for upgrading the rest of your system right now. :( 
Oh well.

Do you know if your CPU has the 533fsb or the 400fsb?

Did you say that the computer is a Dell?

I think you meant CPUID.com
There are directions on this page: http://www.cpuid.com/clockgen.php
It looks to me like you should use ICS 9502XX for your PLL where the Xs could be anything.
May 10, 2006 1:16:18 PM

It's 533 fsb and yes the pc is a Dell..

youre right, Im not ina position to upgrade my dell's mobo because Im going to build a new pc anyway. I just want to get the most out of this system.
May 15, 2006 8:57:40 PM

Quote:
It looks to me like you should use ICS 9502XX for your PLL where the Xs could be anything.


When I looked at the dropdown menu, I couldn't find that number.
May 15, 2006 9:01:10 PM

Quote:
It looks to me like you should use ICS 9502XX for your PLL where the Xs could be anything.


When I looked at the dropdown menu, I couldn't find that number.
May 16, 2006 10:58:37 AM

:? That is weird. The chipset identification stuff on the website doesn't seem to match up with the program itself. I don't know what to tell you. It sounds like you are out of luck. You can try to figure it out on your own. Maybe if you just start trying them one will work.
May 16, 2006 9:39:39 PM

Ok, I do have ICS 950403 and 952XXX with variations of those two numbers. There is no ICS 9502XXX. Anyways, how can I use clockgen even if I don't have the correct number?

thanks
May 16, 2006 9:43:09 PM

Ok, I do have ICS 950403 and 952XXX with variations of those two numbers. There is no ICS 9502XXX. Anyways, how can I use clockgen even if I don't have the correct number?

thanks
May 21, 2006 1:51:26 AM

So. Can you help me?
May 30, 2006 5:47:33 PM

Sorry that I didn't get back to you. :( 
If the numbers don't match, the only thing that I can suggest is trying different ones and seeing if they work. Some of the wrong PLLs will alow the program to read your clocks fine but won't allow you to actually change them. You can use CPUZ to tell if you are actually changing the clocks.
May 31, 2006 2:31:02 AM

Ok, ill try that. Ive tried a few before, but it didn't seem to change. o well. trial and error..

Something weird: when I went to hit the link to your recent post here, it said "the topic or post you requested does not exist" odd huh? since I found it??
May 31, 2006 2:52:35 AM

Ok. I tried cpu-z with other numbers, all that arent ics950.. (or something like that) either don't work or crash my pc immediately (like the rtm ones). I can change the slider on the ics 950..., but it doesn't change the speed of anything..... :cry:  :(  :? I am afraid that that means i absolutely can't overclock this beast as it is. o well......

Thanks for your help so far....
!