Hosts File

Archived from groups: microsoft.public.win98.gen_discussion (More info?)

Something appears to have happened to my Hosts file. The Hosts file icon in
Windows Explorer has changed to the Windows Media Player icon. When I click
on it , the Windows Media Player comes up followed by the Error window. I
deleted the Hosts file (Media Player), opened a Notebook file, and saved it
in C:Windows as Hosts. It appeared in C:Windows as Hosts.txt. Somewhere in my
reading about the Hosts file I think I read that the Hosts file in C:Windows
does not contain a file extension. When I renamed Hosts.txt to Hosts, the
icon changed to the Media Player icon. I would like to re-establish my Hosts
file. Would anyone know if that is possible? Then of course the next question
is how to build a safe Hosts File? All ideas, suggestions and comments will
be greatly appreciated. Thanks, K.
6 answers Last reply
More about hosts file
  1. Archived from groups: microsoft.public.win98.gen_discussion (More info?)

    "K" <K@discussions.microsoft.com> wrote in message
    news:2D0B3671-AB79-4ED5-8ED5-0B44037AB90E@microsoft.com...
    > Something appears to have happened to my Hosts file. The Hosts file
    > icon in
    > Windows Explorer has changed to the Windows Media Player icon. When I
    > click
    > on it , the Windows Media Player comes up followed by the Error
    > window.

    Open Windows Explorer, go to View menu>Folder Options. Click on
    Filetypes tab. Look for the entry for HOSTS and delete it.

    > I deleted the Hosts file (Media Player), opened a Notebook file, and
    > saved it
    > in C:Windows as Hosts. It appeared in C:Windows as Hosts.txt.

    Becasue the default when you save a file in Notepad is "As TXT file", so
    it adds ".txt" to the filename you enter (unless it's already ".txt"--it
    doesn't repeat it.) To save without the TXT extension, change the "Save
    As..." to "All Files".

    >Somewhere in my
    > reading about the Hosts file I think I read that the Hosts file in
    > C:Windows
    > does not contain a file extension. When I renamed Hosts.txt to Hosts,
    > the
    > icon changed to the Media Player icon. I would like to re-establish my
    > Hosts
    > file. Would anyone know if that is possible?

    As I intimated above, you managed to associate HOSTS as being a WMP
    file. You need to delete the HOSTS entry in Filetypes. Just so you know,
    though, this file association glitch doesn't affect the functioning of
    the HOSTS file--it only affects what happens when you double-click the
    file to read it.

    >Then of course the next question
    > is how to build a safe Hosts File? All ideas, suggestions and comments
    > will
    > be greatly appreciated. Thanks, K.

    Personally, after getting rid of the erroneous Filetype, I'd recommend
    you use the MVP HOSTS file from
    http://www.mvps.org/winhelp2002/hosts.htm One of the easiest ways to use
    that HOSTS file is to get George Geyde's "HOSTS File Manager". You can
    find it at the bottom of this page:
    http://www.mvps.org/PracticallyNerded/Software.htm

    On the former site (the winhelp2002 site) you'll find lots of helpful
    documentation. The "HOSTS File Manager" Help section includes a bit
    about adding custom sites to the MVPS HOSTS file.

    --
    Gary S. Terhune
    MS MVP Shell/User
    http://www.grystmill.com/articles/cleanboot.htm
    http://www.grystmill.com/articles/security.htm
  2. Archived from groups: microsoft.public.win98.gen_discussion (More info?)

    Everything went fine till: "To save without the TXT extension, change the
    "Save
    As..." to "All Files". I opened Notepad, clicked File-Save As, changed "Save
    as file type:" to All Files, labeled File Name: Hosts, clicked Save, and got
    another Hosts.txt. What do you spose I'm doing wrong? K.

    "Gary S. Terhune" wrote:

    > "K" <K@discussions.microsoft.com> wrote in message
    > news:2D0B3671-AB79-4ED5-8ED5-0B44037AB90E@microsoft.com...
    > > Something appears to have happened to my Hosts file. The Hosts file
    > > icon in
    > > Windows Explorer has changed to the Windows Media Player icon. When I
    > > click
    > > on it , the Windows Media Player comes up followed by the Error
    > > window.
    >
    > Open Windows Explorer, go to View menu>Folder Options. Click on
    > Filetypes tab. Look for the entry for HOSTS and delete it.
    >
    > > I deleted the Hosts file (Media Player), opened a Notebook file, and
    > > saved it
    > > in C:Windows as Hosts. It appeared in C:Windows as Hosts.txt.
    >
    > Becasue the default when you save a file in Notepad is "As TXT file", so
    > it adds ".txt" to the filename you enter (unless it's already ".txt"--it
    > doesn't repeat it.) To save without the TXT extension, change the "Save
    > As..." to "All Files".
    >
    > >Somewhere in my
    > > reading about the Hosts file I think I read that the Hosts file in
    > > C:Windows
    > > does not contain a file extension. When I renamed Hosts.txt to Hosts,
    > > the
    > > icon changed to the Media Player icon. I would like to re-establish my
    > > Hosts
    > > file. Would anyone know if that is possible?
    >
    > As I intimated above, you managed to associate HOSTS as being a WMP
    > file. You need to delete the HOSTS entry in Filetypes. Just so you know,
    > though, this file association glitch doesn't affect the functioning of
    > the HOSTS file--it only affects what happens when you double-click the
    > file to read it.
    >
    > >Then of course the next question
    > > is how to build a safe Hosts File? All ideas, suggestions and comments
    > > will
    > > be greatly appreciated. Thanks, K.
    >
    > Personally, after getting rid of the erroneous Filetype, I'd recommend
    > you use the MVP HOSTS file from
    > http://www.mvps.org/winhelp2002/hosts.htm One of the easiest ways to use
    > that HOSTS file is to get George Geyde's "HOSTS File Manager". You can
    > find it at the bottom of this page:
    > http://www.mvps.org/PracticallyNerded/Software.htm
    >
    > On the former site (the winhelp2002 site) you'll find lots of helpful
    > documentation. The "HOSTS File Manager" Help section includes a bit
    > about adding custom sites to the MVPS HOSTS file.
    >
    > --
    > Gary S. Terhune
    > MS MVP Shell/User
    > http://www.grystmill.com/articles/cleanboot.htm
    > http://www.grystmill.com/articles/security.htm
    >
    >
    >
  3. Archived from groups: microsoft.public.win98.gen_discussion (More info?)

    Sorry, I thought that would do it. You can either locate the file and
    delete the extension, or you can put double-quotes around the name

    "HOSTS"

    I'm *fairly* certain that will do the trick. (I don't dare guarantee
    anything today, <s>.)

    --
    Gary S. Terhune
    MS MVP Shell/User
    http://www.grystmill.com/articles/cleanboot.htm
    http://www.grystmill.com/articles/security.htm

    "K" <K@discussions.microsoft.com> wrote in message
    news:691B1307-32F7-46FB-B82D-E7203AF076D2@microsoft.com...
    > Everything went fine till: "To save without the TXT extension, change
    > the
    > "Save
    > As..." to "All Files". I opened Notepad, clicked File-Save As, changed
    > "Save
    > as file type:" to All Files, labeled File Name: Hosts, clicked Save,
    > and got
    > another Hosts.txt. What do you spose I'm doing wrong? K.
    >
    > "Gary S. Terhune" wrote:
    >
    >> "K" <K@discussions.microsoft.com> wrote in message
    >> news:2D0B3671-AB79-4ED5-8ED5-0B44037AB90E@microsoft.com...
    >> > Something appears to have happened to my Hosts file. The Hosts file
    >> > icon in
    >> > Windows Explorer has changed to the Windows Media Player icon. When
    >> > I
    >> > click
    >> > on it , the Windows Media Player comes up followed by the Error
    >> > window.
    >>
    >> Open Windows Explorer, go to View menu>Folder Options. Click on
    >> Filetypes tab. Look for the entry for HOSTS and delete it.
    >>
    >> > I deleted the Hosts file (Media Player), opened a Notebook file,
    >> > and
    >> > saved it
    >> > in C:Windows as Hosts. It appeared in C:Windows as Hosts.txt.
    >>
    >> Becasue the default when you save a file in Notepad is "As TXT file",
    >> so
    >> it adds ".txt" to the filename you enter (unless it's already
    >> ".txt"--it
    >> doesn't repeat it.) To save without the TXT extension, change the
    >> "Save
    >> As..." to "All Files".
    >>
    >> >Somewhere in my
    >> > reading about the Hosts file I think I read that the Hosts file in
    >> > C:Windows
    >> > does not contain a file extension. When I renamed Hosts.txt to
    >> > Hosts,
    >> > the
    >> > icon changed to the Media Player icon. I would like to re-establish
    >> > my
    >> > Hosts
    >> > file. Would anyone know if that is possible?
    >>
    >> As I intimated above, you managed to associate HOSTS as being a WMP
    >> file. You need to delete the HOSTS entry in Filetypes. Just so you
    >> know,
    >> though, this file association glitch doesn't affect the functioning
    >> of
    >> the HOSTS file--it only affects what happens when you double-click
    >> the
    >> file to read it.
    >>
    >> >Then of course the next question
    >> > is how to build a safe Hosts File? All ideas, suggestions and
    >> > comments
    >> > will
    >> > be greatly appreciated. Thanks, K.
    >>
    >> Personally, after getting rid of the erroneous Filetype, I'd
    >> recommend
    >> you use the MVP HOSTS file from
    >> http://www.mvps.org/winhelp2002/hosts.htm One of the easiest ways to
    >> use
    >> that HOSTS file is to get George Geyde's "HOSTS File Manager". You
    >> can
    >> find it at the bottom of this page:
    >> http://www.mvps.org/PracticallyNerded/Software.htm
    >>
    >> On the former site (the winhelp2002 site) you'll find lots of helpful
    >> documentation. The "HOSTS File Manager" Help section includes a bit
    >> about adding custom sites to the MVPS HOSTS file.
    >>
    >> --
    >> Gary S. Terhune
    >> MS MVP Shell/User
    >> http://www.grystmill.com/articles/cleanboot.htm
    >> http://www.grystmill.com/articles/security.htm
    >>
    >>
    >>
  4. Archived from groups: microsoft.public.win98.gen_discussion (More info?)

    Yea, that didn't work for me, either, though some say it would.

    Well, another way to go is to put quotes around the name in the save
    box: "HOSTS". This will suppress the .txt extension & only use what is
    inside the quotes.


    --
    Thanks or Good Luck,
    There may be humor in this post, and,
    Naturally, you will not sue,
    should things get worse after this,
    PCR
    pcrrcp@netzero.net
    "K" <K@discussions.microsoft.com> wrote in message
    news:691B1307-32F7-46FB-B82D-E7203AF076D2@microsoft.com...
    | Everything went fine till: "To save without the TXT extension, change
    the
    | "Save
    | As..." to "All Files". I opened Notepad, clicked File-Save As, changed
    "Save
    | as file type:" to All Files, labeled File Name: Hosts, clicked Save,
    and got
    | another Hosts.txt. What do you spose I'm doing wrong? K.
    |
    | "Gary S. Terhune" wrote:
    |
    | > "K" <K@discussions.microsoft.com> wrote in message
    | > news:2D0B3671-AB79-4ED5-8ED5-0B44037AB90E@microsoft.com...
    | > > Something appears to have happened to my Hosts file. The Hosts
    file
    | > > icon in
    | > > Windows Explorer has changed to the Windows Media Player icon.
    When I
    | > > click
    | > > on it , the Windows Media Player comes up followed by the Error
    | > > window.
    | >
    | > Open Windows Explorer, go to View menu>Folder Options. Click on
    | > Filetypes tab. Look for the entry for HOSTS and delete it.
    | >
    | > > I deleted the Hosts file (Media Player), opened a Notebook file,
    and
    | > > saved it
    | > > in C:Windows as Hosts. It appeared in C:Windows as Hosts.txt.
    | >
    | > Becasue the default when you save a file in Notepad is "As TXT
    file", so
    | > it adds ".txt" to the filename you enter (unless it's already
    ".txt"--it
    | > doesn't repeat it.) To save without the TXT extension, change the
    "Save
    | > As..." to "All Files".
    | >
    | > >Somewhere in my
    | > > reading about the Hosts file I think I read that the Hosts file in
    | > > C:Windows
    | > > does not contain a file extension. When I renamed Hosts.txt to
    Hosts,
    | > > the
    | > > icon changed to the Media Player icon. I would like to
    re-establish my
    | > > Hosts
    | > > file. Would anyone know if that is possible?
    | >
    | > As I intimated above, you managed to associate HOSTS as being a WMP
    | > file. You need to delete the HOSTS entry in Filetypes. Just so you
    know,
    | > though, this file association glitch doesn't affect the functioning
    of
    | > the HOSTS file--it only affects what happens when you double-click
    the
    | > file to read it.
    | >
    | > >Then of course the next question
    | > > is how to build a safe Hosts File? All ideas, suggestions and
    comments
    | > > will
    | > > be greatly appreciated. Thanks, K.
    | >
    | > Personally, after getting rid of the erroneous Filetype, I'd
    recommend
    | > you use the MVP HOSTS file from
    | > http://www.mvps.org/winhelp2002/hosts.htm One of the easiest ways to
    use
    | > that HOSTS file is to get George Geyde's "HOSTS File Manager". You
    can
    | > find it at the bottom of this page:
    | > http://www.mvps.org/PracticallyNerded/Software.htm
    | >
    | > On the former site (the winhelp2002 site) you'll find lots of
    helpful
    | > documentation. The "HOSTS File Manager" Help section includes a bit
    | > about adding custom sites to the MVPS HOSTS file.
    | >
    | > --
    | > Gary S. Terhune
    | > MS MVP Shell/User
    | > http://www.grystmill.com/articles/cleanboot.htm
    | > http://www.grystmill.com/articles/security.htm
    | >
    | >
    | >
  5. Archived from groups: microsoft.public.win98.gen_discussion (More info?)

    Thanks Ya'll, it's very kind of you to take the time to offer your help.
    Apparently I have more problems then these symptoms indicate. No matter what
    combination of quotes or no quotes, and Text Documents or All Files I select,
    the saved Hosts file always ends up in C:Windows as either Hosts as a WMP
    icon or Hosts.txt. I'll keep trying to identify all the symptoms and come
    back when I have more info to work with. I really appreciate your taking the
    time to consider my promlem. K.

    "PCR" wrote:

    > Yea, that didn't work for me, either, though some say it would.
    >
    > Well, another way to go is to put quotes around the name in the save
    > box: "HOSTS". This will suppress the .txt extension & only use what is
    > inside the quotes.
    >
    >
    > --
    > Thanks or Good Luck,
    > There may be humor in this post, and,
    > Naturally, you will not sue,
    > should things get worse after this,
    > PCR
    > pcrrcp@netzero.net
    > "K" <K@discussions.microsoft.com> wrote in message
    > news:691B1307-32F7-46FB-B82D-E7203AF076D2@microsoft.com...
    > | Everything went fine till: "To save without the TXT extension, change
    > the
    > | "Save
    > | As..." to "All Files". I opened Notepad, clicked File-Save As, changed
    > "Save
    > | as file type:" to All Files, labeled File Name: Hosts, clicked Save,
    > and got
    > | another Hosts.txt. What do you spose I'm doing wrong? K.
    > |
    > | "Gary S. Terhune" wrote:
    > |
    > | > "K" <K@discussions.microsoft.com> wrote in message
    > | > news:2D0B3671-AB79-4ED5-8ED5-0B44037AB90E@microsoft.com...
    > | > > Something appears to have happened to my Hosts file. The Hosts
    > file
    > | > > icon in
    > | > > Windows Explorer has changed to the Windows Media Player icon.
    > When I
    > | > > click
    > | > > on it , the Windows Media Player comes up followed by the Error
    > | > > window.
    > | >
    > | > Open Windows Explorer, go to View menu>Folder Options. Click on
    > | > Filetypes tab. Look for the entry for HOSTS and delete it.
    > | >
    > | > > I deleted the Hosts file (Media Player), opened a Notebook file,
    > and
    > | > > saved it
    > | > > in C:Windows as Hosts. It appeared in C:Windows as Hosts.txt.
    > | >
    > | > Becasue the default when you save a file in Notepad is "As TXT
    > file", so
    > | > it adds ".txt" to the filename you enter (unless it's already
    > ".txt"--it
    > | > doesn't repeat it.) To save without the TXT extension, change the
    > "Save
    > | > As..." to "All Files".
    > | >
    > | > >Somewhere in my
    > | > > reading about the Hosts file I think I read that the Hosts file in
    > | > > C:Windows
    > | > > does not contain a file extension. When I renamed Hosts.txt to
    > Hosts,
    > | > > the
    > | > > icon changed to the Media Player icon. I would like to
    > re-establish my
    > | > > Hosts
    > | > > file. Would anyone know if that is possible?
    > | >
    > | > As I intimated above, you managed to associate HOSTS as being a WMP
    > | > file. You need to delete the HOSTS entry in Filetypes. Just so you
    > know,
    > | > though, this file association glitch doesn't affect the functioning
    > of
    > | > the HOSTS file--it only affects what happens when you double-click
    > the
    > | > file to read it.
    > | >
    > | > >Then of course the next question
    > | > > is how to build a safe Hosts File? All ideas, suggestions and
    > comments
    > | > > will
    > | > > be greatly appreciated. Thanks, K.
    > | >
    > | > Personally, after getting rid of the erroneous Filetype, I'd
    > recommend
    > | > you use the MVP HOSTS file from
    > | > http://www.mvps.org/winhelp2002/hosts.htm One of the easiest ways to
    > use
    > | > that HOSTS file is to get George Geyde's "HOSTS File Manager". You
    > can
    > | > find it at the bottom of this page:
    > | > http://www.mvps.org/PracticallyNerded/Software.htm
    > | >
    > | > On the former site (the winhelp2002 site) you'll find lots of
    > helpful
    > | > documentation. The "HOSTS File Manager" Help section includes a bit
    > | > about adding custom sites to the MVPS HOSTS file.
    > | >
    > | > --
    > | > Gary S. Terhune
    > | > MS MVP Shell/User
    > | > http://www.grystmill.com/articles/cleanboot.htm
    > | > http://www.grystmill.com/articles/security.htm
    > | >
    > | >
    > | >
    >
    >
    >
  6. Archived from groups: microsoft.public.win98.gen_discussion (More info?)

    K.

    Lets step back a moment: You describe two entirely different problems.
    First, getting the file to be named HOSTS with no extension. It doesn't
    really matter how you do it, whether you can name it while saving or you
    have to rename it later to delete the extension. If the name is HOSTS,
    then it's correct.

    Your original problem, that the file has a WMP icon and tries to open in
    WMP when you d-click it, that's the problem that needs fixing. You fix
    that by looking for a HOSTS item in Filetypes tab of Folder Options.
    Open Windows Explorer, and in the View menu, choose Folder Options. When
    it comes up, click on Filetypes tab and wait for it to load, then look
    for any entry that either has HOSTS in the name, or that has the WMP
    icon you're seeing. It might even be a "blank" entry. The notation will
    include the information that it uses WMP to open. Make a list of all
    that you find that use WMP to open and have that particular icon, and
    report back here with the list.

    You should understand that this problem shouldn't keep HOSTS from acting
    properly. The functions that involve HOSTS don't really care if it's
    been erroneously associated or not. The only problem is that you can't
    d-click it to open the file directly and edit it. However, you *can*
    open Notepad and then open the HOSTS file from Notepad's File>Open
    dialogue.

    --
    Gary S. Terhune
    MS MVP Shell/User
    http://www.grystmill.com/articles/cleanboot.htm
    http://www.grystmill.com/articles/security.htm

    "K" <K@discussions.microsoft.com> wrote in message
    news:EE388A95-1B2A-4317-9A55-A142DADF51EC@microsoft.com...
    > Thanks Ya'll, it's very kind of you to take the time to offer your
    > help.
    > Apparently I have more problems then these symptoms indicate. No
    > matter what
    > combination of quotes or no quotes, and Text Documents or All Files I
    > select,
    > the saved Hosts file always ends up in C:Windows as either Hosts as a
    > WMP
    > icon or Hosts.txt. I'll keep trying to identify all the symptoms and
    > come
    > back when I have more info to work with. I really appreciate your
    > taking the
    > time to consider my promlem. K.
    >
    > "PCR" wrote:
    >
    >> Yea, that didn't work for me, either, though some say it would.
    >>
    >> Well, another way to go is to put quotes around the name in the save
    >> box: "HOSTS". This will suppress the .txt extension & only use what
    >> is
    >> inside the quotes.
    >>
    >>
    >> --
    >> Thanks or Good Luck,
    >> There may be humor in this post, and,
    >> Naturally, you will not sue,
    >> should things get worse after this,
    >> PCR
    >> pcrrcp@netzero.net
    >> "K" <K@discussions.microsoft.com> wrote in message
    >> news:691B1307-32F7-46FB-B82D-E7203AF076D2@microsoft.com...
    >> | Everything went fine till: "To save without the TXT extension,
    >> change
    >> the
    >> | "Save
    >> | As..." to "All Files". I opened Notepad, clicked File-Save As,
    >> changed
    >> "Save
    >> | as file type:" to All Files, labeled File Name: Hosts, clicked
    >> Save,
    >> and got
    >> | another Hosts.txt. What do you spose I'm doing wrong? K.
    >> |
    >> | "Gary S. Terhune" wrote:
    >> |
    >> | > "K" <K@discussions.microsoft.com> wrote in message
    >> | > news:2D0B3671-AB79-4ED5-8ED5-0B44037AB90E@microsoft.com...
    >> | > > Something appears to have happened to my Hosts file. The Hosts
    >> file
    >> | > > icon in
    >> | > > Windows Explorer has changed to the Windows Media Player icon.
    >> When I
    >> | > > click
    >> | > > on it , the Windows Media Player comes up followed by the Error
    >> | > > window.
    >> | >
    >> | > Open Windows Explorer, go to View menu>Folder Options. Click on
    >> | > Filetypes tab. Look for the entry for HOSTS and delete it.
    >> | >
    >> | > > I deleted the Hosts file (Media Player), opened a Notebook
    >> file,
    >> and
    >> | > > saved it
    >> | > > in C:Windows as Hosts. It appeared in C:Windows as Hosts.txt.
    >> | >
    >> | > Becasue the default when you save a file in Notepad is "As TXT
    >> file", so
    >> | > it adds ".txt" to the filename you enter (unless it's already
    >> ".txt"--it
    >> | > doesn't repeat it.) To save without the TXT extension, change the
    >> "Save
    >> | > As..." to "All Files".
    >> | >
    >> | > >Somewhere in my
    >> | > > reading about the Hosts file I think I read that the Hosts file
    >> in
    >> | > > C:Windows
    >> | > > does not contain a file extension. When I renamed Hosts.txt to
    >> Hosts,
    >> | > > the
    >> | > > icon changed to the Media Player icon. I would like to
    >> re-establish my
    >> | > > Hosts
    >> | > > file. Would anyone know if that is possible?
    >> | >
    >> | > As I intimated above, you managed to associate HOSTS as being a
    >> WMP
    >> | > file. You need to delete the HOSTS entry in Filetypes. Just so
    >> you
    >> know,
    >> | > though, this file association glitch doesn't affect the
    >> functioning
    >> of
    >> | > the HOSTS file--it only affects what happens when you
    >> double-click
    >> the
    >> | > file to read it.
    >> | >
    >> | > >Then of course the next question
    >> | > > is how to build a safe Hosts File? All ideas, suggestions and
    >> comments
    >> | > > will
    >> | > > be greatly appreciated. Thanks, K.
    >> | >
    >> | > Personally, after getting rid of the erroneous Filetype, I'd
    >> recommend
    >> | > you use the MVP HOSTS file from
    >> | > http://www.mvps.org/winhelp2002/hosts.htm One of the easiest ways
    >> to
    >> use
    >> | > that HOSTS file is to get George Geyde's "HOSTS File Manager".
    >> You
    >> can
    >> | > find it at the bottom of this page:
    >> | > http://www.mvps.org/PracticallyNerded/Software.htm
    >> | >
    >> | > On the former site (the winhelp2002 site) you'll find lots of
    >> helpful
    >> | > documentation. The "HOSTS File Manager" Help section includes a
    >> bit
    >> | > about adding custom sites to the MVPS HOSTS file.
    >> | >
    >> | > --
    >> | > Gary S. Terhune
    >> | > MS MVP Shell/User
    >> | > http://www.grystmill.com/articles/cleanboot.htm
    >> | > http://www.grystmill.com/articles/security.htm
    >> | >
    >> | >
    >> | >
    >>
    >>
    >>
Ask a new question

Read More

Windows Explorer Media Player Windows