Sign in with
Sign up | Sign in
Your question

Help!: System hangs with new raid controller.

Tags:
  • NAS / RAID
  • Controller
  • Storage
Last response: in Storage
Share
May 9, 2006 8:37:28 PM

:!: Background:
I have a PC used for serving storage for other PCs.
The pc is a Intel Celeron 2.4Ghz with 2x256Mb RAM, the powersupply is 360W. It had four 120Gb disks conected to a Promise Ultra100 TX2 controllercard. This configuration has been working but every time one patition has been full I´ve been forced to move big videofiles between the disks before I can continue capture or edit more video.
I´ve decided to buy a new controller card with raid and with that four 250Gb disks and I also added a coolingfan for the disks.
The controllercard I have for now is a Q-tec IDE RAID133 PCI Card. http://www.qtec.info/products/product.htm?artnr=14426
The controllercard appears as "ITE IT8212 ATA RAID Controller".


:arrow: Problem:
I have tried to configure the raid as JBOD just to get one single partition. It seems to be working from the beginning but when I start writing files or any data on the drives the system hangs for betwen 30 seconds to 3 minutes. Files that are beeing restored to the fileserver by uploading by ftp is not completly uploaded. Probably because the connection breaks during the hangups. I have also tried to configure every disk by it self. Just like a Extra IDE controller. But the hangups still occure.

:?: Question:
What might be wrong?
I was thinking it was the powersupply because I added some extra cooling fans for the new drives. But disconnecting all unnececary drives, fans and other powerconsuming devices did no difference. After all the four disks are replacing four other disks and should not consume that mutch extra power, right? Next issue is general system requirements. Is Intel Celeron 2.4Ghz and 512 MB of RAM to small for handling four 250GB? Before upgrading I want to be sure I dont do buy expensive upgrades in vain. I want to be sure it isnt a simple configuration I´ve overlooked or some known problems with raid controllers I want to know before upgrading.

More about : system hangs raid controller

May 10, 2006 4:39:49 PM

Do the storage is a network storage being used to act as a NAS? What subsystem is running on that pc? Assuming that the correct drivers are installed for the controller, is there any other PCI devices other than a NIC that is taking up bus bandwith?

JBOD, what about 0+1 or 5 configurations? Your hardware seems to be ok, however I think your haveing a config issue. Are you using hardware or software raid?
May 10, 2006 6:48:55 PM

The network storage or as I woul call it, File server does work as a NAS and have no other functions. All computers are connected to a router witch is handling a local network. The (subsystem?) operating system is Windows XP Professional on the file server and Win XP Home edition on all workstations. The file server does not have any other PCI devices mounted. I have tried to use every disk by it self (IDE) and Raid 0 and JBOD. It does seems to be the same problem however I configure it. I have not tried raid 5. Dont know what that is, dont think the controllercard supports that. I´ve been using the hardware config in BIOS, that was why I bought an new controller card. I´m still out of Ideas... :cry: 
!