BABYtel Asterisk settings

Archived from groups: comp.dcom.voice-over-ip (More info?)

Has Anyone been able to get asterisk to work with this VOIP provider.

It works good from a sipura 2000 behind nat. but unable to get it to
work on asterisk. I enter the nat.babytel.ca into my /etc/hosts

not sure if I entered it right on the hosts file....
(here is what I have in there)

----------------------
127.0.0.1 box localhost
nat.babytel.ca

# The following lines are desirable for IPv6 capable hosts
# (added automatically by netbase upgrade)

::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts

-----------------------

now my settings in sip for babytel are
I had Free world dial working but now unable to not sure so they are
commented out!

I have tryed Nat=yes I have tryed adding the port anyone?
------------------------
[general]
externip=xx.xxx.xxx.xxx
localnet=192.168.0.101/255.255.255.0
context = from-sip

disallow=all ; Disallow all codecs
allow=gsm
allow=ilbc
;allow=ima-adpcm
allow=ulaw
allow=alaw
allow=g729
allow=g726
allow=g723.1

;register=xxxxx:secret@fwd.pulver.com/xxxxx
;register=xxxxx:secret@fwd.pulver.com/xxxxx
register=1416xxxxxxx:secret@sip.babytel.ca:5065/2201

[fwd]
type=friend
secret=secret
username=xxxxx
host=fwd.pulver.com
dtmfmode=inband
nat=no
[babytel]
context=default
type=friend
insecure=very
dmtfmode=inband
secret=secret
username=1416xxxxxxx ; Authent user for outbound proxies
fromuser=1416xxxxxxx ; Many SIP providers require this!
fromdomain=sip.babytel.ca ; Ncessaire!! :)
host=sip.babytel.ca
port=5065
nat=no
canreinvite=no
; line 1
[2201]
type=friend
host=dynamic
context=home
secret=secret
callerid="SPA1" <2201>
mailbox=2201
dtmfmode=rfc2833
nat=no
; line 2
[2202]
type=friend
host=dynamic
context=home
secret=secret
callerid="SPA2" <2202>
mailbox=2202
dtmfmode=rfc2833
nat=no
----------------------------
1 answer Last reply
More about babytel asterisk settings
  1. Archived from groups: comp.dcom.voice-over-ip (More info?)

    ahh G... I did'nt read the
    http://ip.bourget.cc:8080/wiki/babyTEL_20and_20Asterisk
    or
    http://www.sherman.ca/archives/2004/08/19/babytel-and-asterisk/
    propperly.

    /etc/hosts did't seem right in here.. silly me..

    its like this
    -----------------my-/etc/hosts-file---
    127.0.0.1 box localhost
    216.18.125.7 sip.babytel.ca

    # The following lines are desirable for IPv6 capable hosts
    # (added automatically by netbase upgrade)

    ::1 ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    ------------------------


    I don't get errors anymore..

    any one have any othere Asterisk canadian friendly Providers they
    would like to share?

    m

    m wrote:
    > Has Anyone been able to get asterisk to work with this VOIP provider.
    >
    > It works good from a sipura 2000 behind nat. but unable to get it to
    > work on asterisk. I enter the nat.babytel.ca into my /etc/hosts
    >
    > not sure if I entered it right on the hosts file....
    > (here is what I have in there)
    >
    > ----------------------
    > 127.0.0.1 box localhost
    > nat.babytel.ca
    >
    > # The following lines are desirable for IPv6 capable hosts
    > # (added automatically by netbase upgrade)
    >
    > ::1 ip6-localhost ip6-loopback
    > fe00::0 ip6-localnet
    > ff00::0 ip6-mcastprefix
    > ff02::1 ip6-allnodes
    > ff02::2 ip6-allrouters
    > ff02::3 ip6-allhosts
    >
    > -----------------------
    >
    > now my settings in sip for babytel are
    > I had Free world dial working but now unable to not sure so they are
    > commented out!
    >
    > I have tryed Nat=yes I have tryed adding the port anyone?
    > ------------------------
    > [general]
    > externip=xx.xxx.xxx.xxx
    > localnet=192.168.0.101/255.255.255.0
    > context = from-sip
    >
    > disallow=all ; Disallow all codecs
    > allow=gsm
    > allow=ilbc
    > ;allow=ima-adpcm
    > allow=ulaw
    > allow=alaw
    > allow=g729
    > allow=g726
    > allow=g723.1
    >
    > ;register=xxxxx:secret@fwd.pulver.com/xxxxx
    > ;register=xxxxx:secret@fwd.pulver.com/xxxxx
    > register=1416xxxxxxx:secret@sip.babytel.ca:5065/2201
    >
    > [fwd]
    > type=friend
    > secret=secret
    > username=xxxxx
    > host=fwd.pulver.com
    > dtmfmode=inband
    > nat=no
    > [babytel]
    > context=default
    > type=friend
    > insecure=very
    > dmtfmode=inband
    > secret=secret
    > username=1416xxxxxxx ; Authent user for outbound proxies
    > fromuser=1416xxxxxxx ; Many SIP providers require this!
    > fromdomain=sip.babytel.ca ; Ncessaire!! :)
    > host=sip.babytel.ca
    > port=5065
    > nat=no
    > canreinvite=no
    > ; line 1
    > [2201]
    > type=friend
    > host=dynamic
    > context=home
    > secret=secret
    > callerid="SPA1" <2201>
    > mailbox=2201
    > dtmfmode=rfc2833
    > nat=no
    > ; line 2
    > [2202]
    > type=friend
    > host=dynamic
    > context=home
    > secret=secret
    > callerid="SPA2" <2202>
    > mailbox=2202
    > dtmfmode=rfc2833
    > nat=no
    > ----------------------------
Ask a new question

Read More

vpn Networking