Sign in with
Sign up | Sign in
Your question

Cant open any type of cd in windows 7. 3 different dvdrw's connected

Last response: in Windows 7
Share
April 24, 2011 7:22:57 AM

Hey,

I am trying to load battlefield bad company 2, sims, dvd's, and cd's on my computer, but when I go to My Computer and double click the dvdrw's, windows says it needs to format the disk.

if I press format, it has an error, if I dont, it also has an error.

I have installed 3 dvdrws that I have tested and had working in another computer, and the same goes for each one.

When I insert a disk, the mouse cursor shows the little CD right by it, but nothing happens after it blinks a few times.

Bios recognizes each dvdrw drive, they will boot windows 7 disk before loading windows even, disk management shows each one is working good.

I got one dvd to read through a third party program called dvd decrypter. I didn't go as far as to see if it would copy to the hdd, but it showed all the files.

I used another third party software to analyze the sims2 disk to see if it could copy (i didnt have the full version so I couldnt copy it onto the hdd) but it did show the files as well.

I cannot see any music disks, cdrws disks, dvd's, etc in itunes or windows media player.

I have no idea whats going on and its wasting tons of my time and patience. Please please please help me!

I'm going to reformat, reinstall windows 7 and see if that works... its literally driving me nuts!

Thanks,

Ben

I have a i5-750 with biostar h55 hd, 4gb of xms3 corsair ram, 500watt apevia psu/case.
April 24, 2011 1:06:20 PM

Right click My Computer/Properties/Hardware/Device Manager

Right click on the DVDRW/properties and read the device status does it say that it's working properly? Enable it if it's not enabled.
Try this
http://www.softpedia.com/get/CD-DVD-Tools/Data-CD-DVD-B...

If it still doesn't work in the Device Manager/DVDRW/properties go to the driver tab uninstall the driver and reboot.

m
0
l
April 24, 2011 2:47:59 PM

I have uninstalled the drivers many times and restarted, I have also removed each one and tried them in different sata ports with different cords.

The software that you suggested, did show that there was "track 01: 3,075 MB" on the disk, but thats not even what is on these disks, so it did not work either.

Im very confused about this. Maybe i'll post a youtube video and share the link so that you can see exactly how its responding.
m
0
l
Related resources
April 24, 2011 3:16:21 PM

Check that the device is not on PIO mode. In device manager expand the IDE ATA/ATAPI controllers and check every one of them if they work, if they're on DMA mode and the drivers.
m
0
l
April 26, 2011 1:22:38 AM

I finally chose the quick and easy way out and re-installed windows 7 and now they work; I had already spent hours updating everything imaginable and doing everything that the forums suggested without success... finally a fresh install of windows got it working! :sol: 
m
0
l
!